[ROM][OFFICIAL][ginkgo][11] LineageOS 18.1 for Redmi Note 8 / 8T

Search This thread


Senior Member
Nov 27, 2016
Samsung Galaxy S7
Samsung Galaxy A6
my redmi with lineage17.1 works fine since 2 years.
i wanted to test 18.1but it not start correctly : black screen and reboots

LineageOS version: 18.1
LineageOS Download url: https://mirrorbits.lineageos.org/fu...neage-18.1-20221201-nightly-ginkgo-signed.zip
Gapps version: no gapps ( i only use apkpure )

Did you--
wipe: yes
restore with titanium backup: no
reboot after having the issue: yes, it always reboot

Are you using--
a task killer: no
a non-stock kernel: no
other modifications: new recovery https://mirrorbits.lineageos.org/recovery/ginkgo/20221201/lineage-18.1-20221201-recovery-ginkgo.img

thank you !
... you need to FORMAT (!) /data, not only wipe /data. Make backups of your files before.

See the dev's instructions in the very first post. Furthermore flash latest global (!) firmware if you observe issues (e. g. sim card not detected, bluetooth issues etc.)


Senior Member
Nov 27, 2016
Samsung Galaxy S7
Samsung Galaxy A6


  • Screenshot_20221223-145950_Trebuchet_1.png
    74.1 KB · Views: 52


Dec 23, 2022
Charix (France)
hello, i had to install mui android 11 before.
lineageos 18.1. is now installed and boot ok, 4g is working but i can't activate wifi
Last edited:


Apr 24, 2019
Hi there,
i did clean install and vowifi is not working, i activated it in settings, but my calls don't go on wifi.
How can i do to fix it please?

i did nothing and today it works ..
Last edited:


Feb 6, 2021
My RN 8T Willow worked fine with LOS 17.1. A few weeks ago I upgraded to the latest firmware and installed LOS 18.1. Unfortunately, I have a problem with VoWiFi. When trying to make an outgoing call, I see a message prompting me to deactivate the flight mode or connect to Wi-Fi. However, I can still receive calls without problems. Does anyone have this problem, too?


Feb 6, 2021
With the latest LOS 18.1 Update 2023-02-01, I can't activate Bluetooth, it keeps crashing. Anyone else having this problem?

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Good news from the dev (see screenshots from dev's TG channel): new build for 19.1 might come soon, also going to official seems possible for the dev.
  • 24

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's not working :
    • You tell me
    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Format data (if it is first time installation)
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    LineageOS, ROM for the Redmi Note 8/8T


    Source Code: https://github.com/LineageOS
    Device source code: https://github.com/ginkgo-dev
    Telegram support chat: https://t.me/ginkgodev

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    Based On: LineageOS
    Dear ginkgo/willow users LineageOS is back !
    We are working to promote our devices to 18.1, few things to do are left such as pushing all and opening ticket.
    Changes are open at: https://review.lineageos.org/q/status:open+-is:wip
    Source will be the same as Official lineage 17.1 ones so clean flash will be needed.
    Stay tuned !
    Hello !
    Here is an unofficial test build of LineageOS 19.1 for our device. Everything is working out of the box and it is ready to be daily driven. Will wait a bit to have feedbacks before releasing officially

    Welcome Android 12 !

    Me and danascape booted new Android release at day one.

    Builds aren't unified yet.