[ROM][OFFICIAL][ginkgo/willow] Pixel Experience [11.0]

do you like it ?

  • Total voters
Search This thread


Senior Member
Sep 22, 2010
Somewhere in Amazon
After installing latest 11 (plus edition), my phone restarted and now it's no longer booting. If I restart the phone, it loads the Google logo and then boots into recovery (TWRP) where it has no access to the internal memory.

Everything was working fine before I updated the ROM.
Please help.

I ran "Disable_Dm-Verity_ForceEncrypt_11.02.2020" (from SD card) via TWRP and now the screen is getting stuck at Google logo after restarting the phone.
Last edited:


New member
Oct 8, 2021
I'm on the official Plus version and camera works well, I also flashed the micam linked in the telegram support group which works as good.
And about the maintainership, he is already an internal member of PixelExperience team. So he'll maintain it for long no doubts about that.
In Google pixle i am not able to play pubg or freefire with full notch pls help how can i fix notch problem


Recognized Developer
After installing latest 11 (plus edition), my phone restarted and now it's no longer booting. If I restart the phone, it loads the Google logo and then boots into recovery (TWRP) where it has no access to the internal memory.

Everything was working fine before I updated the ROM.
Please help.

I ran "Disable_Dm-Verity_ForceEncrypt_11.02.2020" (from SD card) via TWRP and now the screen is getting stuck at Google logo after restarting the phone.
Try wiping data


Feb 19, 2022
Redmi Note 8
after failing to install orangefox recovery, my phone is stuck on the google loading thing on boot, but I can still go to fastboot and recovery, any idea how to fix this?

edit: I'm pretty sure I'm in a bootlooop, and I've tried replacing the orangefox recovery with twrp and PE's recovery, but still not working
Last edited:


Senior Member
May 13, 2011
When formatting an SD card as phone storage, it throws an error

Attempt to invoke virtual
method 'java.lang.String
android.os.storage.VolumeInfo.getId()' on
a null object reference.

How can I resolve it?
  • Like
Reactions: GreZord

Top Liked Posts

  • There are no posts matching your filters.
  • 21

    PixelExperience for Xiaomi Redmi Note 8/8T

    What is this?
    Pixel Experience is an AOSP based ROM, with Google apps included and all Pixel goodies (launcher, wallpapers, icons, fonts, bootanimation)

    Our mission is to offer the maximum possible stability and security, along with essential and useful features for the proper functioning of the device

    Based on Android 11

    Whats working?
    Mobile data
    Fingerprint reader
    Sound / vibration

    Known issues
    You tell.

    How to flash
    Flash Latest Ten firmware
    Wipe system
    Wipe Vendor
    Format Data
    Flash ROM

    Telegram Group


    Help with project translation

    Stay tuned
    Our Telegram channel
    Our blog

    XDA:DevDB Information
    pixel-experience, ROM for the Xiaomi Redmi Note 8/8T

    Source Code: https://github.com/PixelExperience-Devices/device_xiaomi_ginkgo

    ROM OS Version: Android 11
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Ten firmware.
    Based On: AOSP

    Version Information
    Beta Release Date: 2021-03-13

    Created 2021-03-15
    Last Updated 2021-03-15
    Thank you all who gave their valuable input in my quest to troubleshoot my issues. After immense trial and error with tons of google searches, I was finally able to frankenstien enough knowledge to create one final solution. As a sign of my respect for this community, I'll pen my experience down in hopes it saves the trouble for someone else down the line.

    Foremost, the installation guide linked was easy to understand and the ROM itself is light and extremely responsive. Apart from some minor hiccups here and there, this is a good Pixel Experience. Thank you iamsaalim!

    That being said, if you're an unfortunate person like me who lives in India and a victim of Xiomi's "yea I'll think about you last" attitude, there are a few things that the guide does not cover at the time of writing this post. Not the maintainers fault tbh, it's just bad luck. Here are the steps that I followed:

    • Grabbed both the ROM and Recovery from the link in the original post.
    • Followed the guide to the letter up until the point where I flashed the recovery in via adb.
    • Encountered recovery issue where the phone would just freeze trying to go into recovery via Vol+ and Power buttom. Tried "fastboot erase userdata" command. Freezing issue gone but instead of TWRP, MI Recovery showed up. After much trial and error and thanks to yn4v4s's input(you rock dude), I finally realized I'm on Q firmware which is Android 10 whereas the TWRP in the original post is meant for R firmware which is Android 11. Decided to grab the yn4v4s's recommended Global version.
    • Went to TWRP website and grabbed December 2020 recovery and flashed that via adb. Success as TWRP flares to life.
    • Continued on with the guide all excited thinking the worse is behind me as all I need is to install ROM, right? WRONG.
    • Immediately new problem: Factory Reset/Formatting failure/Wiping Failed. reason? Operation not Permitted
    • Selected Mount and spotted a weird anomaly. Cycling through the storage, noticed Internal storage was marked as (0) capacity. Immediately stuck that as odd. Google search intensified.
    • Went to Wipe> Selecting /data > Advance Wipe > Change file system, I saw that the file system was FTFS by default. Changed it to ext4 and formatted it. Now ftfs is supposed to be better but I noticed all other drive partitions were in ext4 format, so for the sake of simplicity I stuck with ext4 instead of reverting to ftfs.
    • Tried Factory resetting again. This time new error while formatting: Invalid Argument. Proceeded to chuck neighbor's cat out of the window and fight imaginary sharks to vent frustration.
    • Calmed down and went back a few steps. Realized, forgot to clear cache. Went back into Advance wipe and cleared Davlik /ART Cache, Cache, Data, System and Vendor.
    • Proceeded to format once again typing "yes" while praying. Finally, success!!
    • Time to flash and upgrade to Android 11 firmware first before the ROM. Placed the global firmware into the SD card via USB cable. Saw folks flashing ROMs from TWRP as well so placed PE ROM too.
    • Selected Install on TWRP and navigated to the firmware file. Executed the firmware and noticed it installing within seconds. A bit worrying sign but since no errors were thrown I continued on.
    • Navigated to the directory again, selected PE ROM image this time and installed it as well. Installation went without any incidents and returned with a success message. Okay...
    • Moment of Truth. Reboot! 1 minute passes, Google Icon spins up. YES! 2 minute passes, Google bar starts running. Encouraging! 3 minute passes, bar continues running. Erm. 4 minute passes, bar still. Uh oh.
    • Yeap, no cigar yet. I'm now stuck in a boot loop. To make matter worse, TWRP recovery gets overwritten by PE Recovery. Sigh.
    • Decide to grab the latest TWRP from their website and flash that instead since there is no point in using old Android 10 TWRP.
    • Aaand I'm frozen again on REDMI screen. WTF?! I flashed Android 11 global firmware so I'm pretty sure I'm on the new one. Flashed old TWRP again and sure enough I'm into the recovery. Confused as hell now. For the heck of it, I erased Cache again.
    • Noticed an odd new console error in red. Unable to decrypt FBE device
    • More google searches later, I come across discussion where community came to the conclusion that "console output Unable to decrypt FBE device was nothing but to tell us that incompatible operating system flashed"
    • OS can't be an issue, it's made for my Redmi Note 8 and I'm plenty sure I'm on ginkgo.
    • Going through this thread I noticed how folks swore by Chinese firmware. Decided to deviate and flash that firmware instead. Wiped everything again including the OS.
    • Went back to following the guide and decided to sideload selecting Advanced on TWRP and select "Side Load" option. Copied the ROM in my ADB directory on the PC and used the "sideload 'ROM NAME'.zip" command.
    • Waited patiently for the message: If the process succeeds the output will stop at 47% and report adb: failed to read command: Success/No error.
    • Process ends but no such message. Instead I get: Total xfer: 1.00x
    • Quick google search showed that this is an error message. Too tired to get angry or brainy at this point so I simply reboot for the heck of it.
    • 1 minute into boot and suddenly I see white light. COULD IT BE...?
    • Sure enough, Google bursts out of boot into first time setup. YAY?!!
    Apologies, if this became a weird wall of text but this is a sum total of my experience in the last couple of weeks. I've no idea if I have done this right or I just got lucky eventually but it somehow worked for me. From installing adb, to fighting with drivers to recognize my phone, to waiting 7 days for bootloader to open, to finally all that I listed above, it was truly a nightmarish experience. But in the end, it was worth it. The default camera was a bit of a letdown but thankfully GCam apk uploaded in this thread by another member was easy enough to install and runs without issues. Unable to move the clock on the wallpaper became a bit of an irritant but nothing Nova Launcher couldn't fix.

    All in all, apart from the installation pangs, I'm loving it. Thank you all for your advice. Truly would have been lost without your inputs.
    Yes sir, same for me yesterday with Willow. I thought it was caused by flashing DFE after flashing ROM, but so probably it's not the case. I solved flashing the latest stable fastboot MIUI rom from XiaomiAdbFastboot Tools, than flashing OrangeFox, wipe system etc., format data and than flashing the ROM zip. I also enabled the OTA updater settings in OrangeFox (I don't think it serves any purpose, but I'm writing it anyway).

    EDIT: I tried to go to recovery and I got stuck again......so don't try to open it again... @iamsaalim

    EDIT2 - installing Pitch Black Recovery (as said in previous posts) allows to open recovery but it got stuck on bootanimation if I reboot into system
    1. Flash vbmeta.img and recovery.img using adb fastboot
    2. Boot into recovery mode and connect ur phone to the computer using usb cable
    3. Copy the recovery file, ROM, latest 10 fw
    4. (In the recovery mode) flash recovery file
    5. Flash 10 fw
    6. Wipe cache/dalvik, data, vendor, internal storage, system
    7. Format data
    8. Install ROM
    9. Boot to system
    If u using the latest version of PE+ or PE I suggest using pitch black recovery
    Weird, I was told I had to do at least two months of unoffical stable releases after producing five months of code that worked perfectly for every version and here you are without a proper working camera and you still got official?

    No wonder this ROM only gets maintained a month at a time.
    Camera works very fine for everyone, it's a issue from his side and don't worry I don't plan on dropping maintainership this early
    The stock camera included in this PE (Android 11) rom does not open on my Redmi Note 8.

    Needed to flash the attached Gcam Uninstall zip via TWRP to remove the stock camera i.e. which is system app and thus cannot be uninstalled normally.

    Found the attached GCam 8.1 apk to install on my Note 8. This GCam 8.1 works perfectly.