• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][gta4xlwifi][11] LineageOS 18.1 for Galaxy Tab S6 Lite (Wi-Fi)

Search This thread

R!ffRaff

Senior Member
Oct 21, 2019
256
54
@Linux4
many many thanks for the official support und good work. i bought the tablet from black friday.

So far everything is going very well, but I found 4 bugs:
  1. ota update kill root (magisk) -with & without online recovery update - the most important thing for me!
  2. screen rotation cannot be switched off, the screen changes immediately to portrait format. i only use my tablets in widescreen! I only use 90 + 270, on other devices with lineageos it works without problems
  3. the resolution of the cam app is not adjusted, so the shutter release is only half visible
  4. Under hidden apps you can only hide not protect (lock symbol), logos for protecting are missing. bug?
 

riverstyxxx

Senior Member
May 9, 2015
128
17
Fastboot will never work on this device, you'll have to use Odin or heimdall.

Please make sure the device is in download mode: power the device off, then press both volume and volume down while inserting a cable connected to a computer. When you get on the first download mode screen you have to press volume up once to enter the real download mode.
Your heimdall command should be:
Code:
heimdall flash --no-reboot --RECOVERY li
neage-18.1-20211117-recovery-gta4xlwifi.img
(filename may vary)

If you are running stock you must reboot into recovery immediately or stock will overwrite the recovery partition. There's a hardware key dance to be performed if that's the case. Reread https://wiki.lineageos.org/devices/gta4xlwifi/install#installing-a-custom-recovery-using-heimdall for the howto.

If heimdall is still failing, post the full heimdal log please, not just the error code.

EDIT: Got it working. Had to run through Zadig and reinstall a few things. Thanks!
 

Attachments

  • recovery.JPG
    recovery.JPG
    994.2 KB · Views: 64
  • heimdall.JPG
    heimdall.JPG
    304 KB · Views: 62
  • Untitled.png
    Untitled.png
    47.2 KB · Views: 62
Last edited:

mu1989

Senior Member
Feb 22, 2020
108
41
@Linux4
vielen vielen dank für die offizielle unterstützung und gute arbeit. Ich habe das Tablet von Black Friday gekauft.

Bisher läuft alles sehr gut, aber ich habe 4 Fehler gefunden:
  1. ota update kill root (magisk) -mit & ohne Online Recovery Update - das Wichtigste für mich!
  2. die Bildschirmdrehung lässt sich nicht ausschalten, der Bildschirm wechselt sofort ins Hochformat. Ich benutze meine Tablets nur im Widescreen! Ich benutze nur 90 + 270, auf anderen Geräten mit Lineageos funktioniert es ohne Probleme
  3. die auflösung der cam app ist nicht angepasst, daher ist der auslöser nur halb sichtbar
  4. Unter versteckte Apps kann man nur ausblenden nicht schützen (Schlosssymbol), Logos zum Schützen fehlen. Insekt?

Hey
1) this is a bug of Magisk and not of Lineage, magisk just can't bypass the shutter and JohnWu is not willing to implement the fix, so Lygisk was created, a fork of Magisk that works the same way as Magisk, just with implemented Fix
2) have tested it, runs great on my device
3) the camera is really not too good, but also not worse than on stick, since it was already miserable, but is just a tablet and not a smartphone or good camera.
4) works for me if I have set up a screen lock, without it of course it does not work and is also not displayed
 
  • Like
Reactions: R!ffRaff

R!ffRaff

Senior Member
Oct 21, 2019
256
54
Hey
1) this is a bug of Magisk and not of Lineage, magisk just can't bypass the shutter and JohnWu is not willing to implement the fix, so Lygisk was created, a fork of Magisk that works the same way as Magisk, just with implemented Fix
2) have tested it, runs great on my device
3) the camera is really not too good, but also not worse than on stick, since it was already miserable, but is just a tablet and not a smartphone or good camera.
4) works for me if I have set up a screen lock, without it of course it does not work and is also not displayed
Thank you for your answer,

1. good tip, I've read that it occurs with the A / B devices. with my old Moto x play (Lux) magisk works with lineage recovery without any problems.
2. the automatic rotation works, but you could switch off the slide switch up to LOS 17, that was also possible in the drop down menu, the automatic rotation did not have to be activated there. this is the case with all of my LOS18.1 devices!
if you only set it at 90 ° and turn off the slide switch, the screen rotates. but it works for now
3. I didn't mean the quality of the camera, not even the app. The app interface would have to be adapted to the tablet. see white button (only half visible)
4. You are right screen lock was not enable

you are a german (translation in quote)?
 

mu1989

Senior Member
Feb 22, 2020
108
41
2) okay, I don't know now xD
3)
Thank you for your answer,

1. good tip, I've read that it occurs with the A / B devices. with my old Moto x play (Lux) magisk works with lineage recovery without any problems.
2. the automatic rotation works, but you could switch off the slide switch up to LOS 17, that was also possible in the drop down menu, the automatic rotation did not have to be activated there. this is the case with all of my LOS18.1 devices!
if you only set it at 90 ° and turn off the slide switch, the screen rotates. but it works for now
3. I didn't mean the quality of the camera, not even the app. The app interface would have to be adapted to the tablet. see white button (only half visible)
4. You are right screen lock was not enable

you are a german (translation in quote)?

1) Yes, try it, I use it myself now on all devices and the OTA no longer freeze
2) Okay, I don't know now
3) Yes, the app has not been improved for exynos devices, but I didn't think it was a problem because I deactivated the app anyway and use opencamera there 😅

Yes, auto translate via the web browser xD
 

R!ffRaff

Senior Member
Oct 21, 2019
256
54
2) okay, I don't know now xD
3)


1) Yes, try it, I use it myself now on all devices and the OTA no longer freeze
2) Okay, I don't know now
3) Yes, the app has not been improved for exynos devices, but I didn't think it was a problem because I deactivated the app anyway and use opencamera there 😅

Yes, auto translate via the web browser xD
Sorry for the late reply

i am from Schwesig-Land :devilish:

lygisk works but this releas ist not the really release fpr magisk - ist the canary version, but it works on multiple devices

merry x.mas oder für Dich und Tim: frohe Weihnachten, dicken Sack und ein schöne Weihnachtstage
 

gap30

Senior Member
Aug 10, 2015
306
45
Thank you dev successfully installed this on my daughters new S6 Lite LTE/wifi version P610 absolutely no problems (LTE will never be used)

Installed LOS recovery/magisk/opengapps all went well
 
  • Like
Reactions: Linux4

samhhmobil

Senior Member
May 25, 2017
361
191
Hamburg
Hello,

please take my apologies if this behaviour was discussed earlier, but I'm a newbie to the Tab S6lite, and I've installed LOS18.1 two days ago yet (with OpenGapps pico and Magisk 23.0). I'm "only" familiar with LOS on several phones (HTC, Sony Xperia).

It's working on the S6lite as expected, so many many thanks to the dev!

The tablet is new, I bought it 10days ago.

But... charging stops now at 70%, and even if the cable is plugged in, it says: No Charging. When chargelevel is 69% or less, charging is working, but when it reaches 70%, it switches charging off (automagically). Sigh...

With stock rom (latest one) it did charge normally to 100%.

What's going on there? And what do I have to change in switches/settings/configuration for "normal" charge behaviour?

Thank you very much for any hint,
samhhmobil
 

R!ffRaff

Senior Member
Oct 21, 2019
256
54
Hello,

please take my apologies if this behaviour was discussed earlier, but I'm a newbie to the Tab S6lite, and I've installed LOS18.1 two days ago yet (with OpenGapps pico and Magisk 23.0). I'm "only" familiar with LOS on several phones (HTC, Sony Xperia).

It's working on the S6lite as expected, so many many thanks to the dev!

The tablet is new, I bought it 10days ago.

But... charging stops now at 70%, and even if the cable is plugged in, it says: No Charging. When chargelevel is 69% or less, charging is working, but when it reaches 70%, it switches charging off (automagically). Sigh...

With stock rom (latest one) it did charge normally to 100%.

What's going on there? And what do I have to change in switches/settings/configuration for "normal" charge behaviour?

Thank you very much for any hint,
samhhmobil
I have no problems here with 2 tablets - the battery charges normally
what is your stock or firmware version?
does the tablet charge when it is completely switched off?
do you use the originally supplied cable and power supply?
 
Last edited:
  • Like
Reactions: samhhmobil

samhhmobil

Senior Member
May 25, 2017
361
191
Hamburg
I have no problems here with 2 tablets - the battery charges normally
what is your stock or firmware version?
does the tablet charge when it is completely switched off?
It's on the really latest firmware (stockrom OTA update was done three days ago, before unlocking the bootloader; it was on security patch level of November,5th 2021).

And, yes, it charges to 100% when it is switched off. (So I expect it's any internal configuration switch... but which one and where?)

samhhmobil
 

ALELOCOOO

Member
Jan 8, 2015
33
3
@Linux4
many many thanks for the official support und good work. i bought the tablet from black friday.

So far everything is going very well, but I found 4 bugs:
  1. ota update kill root (magisk) -with & without online recovery update - the most important thing for me!
  2. screen rotation cannot be switched off, the screen changes immediately to portrait format. i only use my tablets in widescreen! I only use 90 + 270, on other devices with lineageos it works without problems
  3. the resolution of the cam app is not adjusted, so the shutter release is only half visible
  4. Under hidden apps you can only hide not protect (lock symbol), logos for protecting are missing. bug?
Having the same issue with screen rotation
 
  • Like
Reactions: R!ffRaff

samhhmobil

Senior Member
May 25, 2017
361
191
Hamburg
I have no problems here with 2 tablets - the battery charges normally
what is your stock or firmware version?
does the tablet charge when it is completely switched off?
do you use the originally supplied cable and power supply?
OK, I got it yet (but nevertheless I don't know what went wrong).

I did charge to 100% when completely switched off the tab, then I'd boot and it did show 100% even there. With "root-essentials" I did now reset the battery statistics, then I'd unplug the charging cable, let the battery go down until less than 5%, and plugged in the charging cable again. And — tadaaaa — now it charges to 100% as it should.

So... the file with the battery data (battery statistics) were corrupted during installation. I don't know why!

But the way described in "root essentials" did fix it.

samhhmobil

PS
...and greetings to Schwesig-Land from Günther-Land...
 

R!ffRaff

Senior Member
Oct 21, 2019
256
54
OK, I got it yet (but nevertheless I don't know what went wrong).

I did charge to 100% when completely switched off the tab, then I'd boot and it did show 100% even there. With "root-essentials" I did now reset the battery statistics, then I'd unplug the charging cable, let the battery go down until less than 5%, and plugged in the charging cable again. And — tadaaaa — now it charges to 100% as it should.

So... the file with the battery data (battery statistics) were corrupted during installation. I don't know why!

But the way described in "root essentials" did fix it.
for almost 10 years android devices i only had to calibrate the battery 1 or 2 times. I don't use an app for that, just let the device shut down by itself and charge it to 100% when it is switched off, repeat if necessary, that it worked but it's nice, have fun with it, I really like it, device & software !
...and greetings to Schwesig-Land from Günther-Land...
Beileid an uns beiden ;), Grüße zurück!
 

R!ffRaff

Senior Member
Oct 21, 2019
256
54
@Linux4
many many thanks for the official support und good work. i bought the tablet from black friday.

So far everything is going very well, but I found 4 bugs:
  1. ota update kill root (magisk) -with & without online recovery update - the most important thing for me!
  2. screen rotation cannot be switched off, the screen changes immediately to portrait format. i only use my tablets in widescreen! I only use 90 + 270, on other devices with lineageos it works without problems
  3. the resolution of the cam app is not adjusted, so the shutter release is only half visible
  4. Under hidden apps you can only hide not protect (lock symbol), logos for protecting are missing. bug?
  1. its a problem with crypted /data partition and LineageOS Recovery fix with Lygisk or use TWRP thx @mu1989
  2. its a bug, - disable rotation from top menu change the rotation (wide screen) @Linux4
  3. its ab bug - need adjustment @Linux4
  4. need enable screen lock thx @mu1989

@Linux4 please fix 2&3
 
Last edited:

samhhmobil

Senior Member
May 25, 2017
361
191
Hamburg
If you have an external SD card in the tablet, it also shows the LOS recovery (under the sideload) this can also read the recovery, as it is not affected by FBE. Under no circumstances would I recommend locking the bootloader again if you want a safety Net Pass, please flash magisk.


SafetyNet (LineageOS 18.1)

1) Enable settings MagiskHide
2) install MagiskHide Props Config(Magisk module)
3) Open the terminal
4) su
5) Type "props"
6) Edit 1 fingerprint of the device
7) Choose a certified fingerprint
8) 21 Oneplus
9) Find an Android 11 device (OnePlus 8T global 44)
10) Follow the instructions
11) Restart
12) Clear Google Play Store Data
13) Check SafetyNet (should pass)
14) Open MagiskHide (Magisk -> Tap on the Shield symbol)
15) Check all apps that do not require root privileges
Thanks, I tried it (it did work with Magisk 23), SafteyNet passes and PlayProtect-Certification shows: Device is certified.

But... ...:
it does not work with Lygisk 23.0.15. "SafetyNet Test" even says: "Passed" and everything is on "success", but PlayProtect-Certification shows now: Device is NOT certified.

What's to do with that?

Thanks a lot,
samhhmobil
 

R!ffRaff

Senior Member
Oct 21, 2019
256
54
Thanks, I tried it (it did work with Magisk 23), SafteyNet passes and PlayProtect-Certification shows: Device is certified.

But... ...:
it does not work with Lygisk 23.0.15. "SafetyNet Test" even says: "Passed" and everything is on "success", but PlayProtect-Certification shows now: Device is NOT certified.

What's to do with that?

Thanks a lot,
samhhmobil
magisk 23 release? or lygisk 23.015 (canary)
magisk doesn't work with ota and you have to manually install magisk again afterwards
better change now! you need maybe: Universal SafetyNet Fix

note the different versions for the old and new magisk variants!
 
Last edited:

mu1989

Senior Member
Feb 22, 2020
108
41
Thanks, I tried it (it did work with Magisk 23), SafteyNet passes and PlayProtect-Certification shows: Device is certified.

But... ...:
it does not work with Lygisk 23.0.15. "SafetyNet Test" even says: "Passed" and everything is on "success", but PlayProtect-Certification shows now: Device is NOT certified.

What's to do with that?

Thanks a lot,
samhhmobil
just clean the cache again from the Play Store
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Thanks, I tried it (it did work with Magisk 23), SafteyNet passes and PlayProtect-Certification shows: Device is certified.

    But... ...:
    it does not work with Lygisk 23.0.15. "SafetyNet Test" even says: "Passed" and everything is on "success", but PlayProtect-Certification shows now: Device is NOT certified.

    What's to do with that?

    Thanks a lot,
    samhhmobil
    just clean the cache again from the Play Store
    1
    Thank you dev successfully installed this on my daughters new S6 Lite LTE/wifi version P610 absolutely no problems (LTE will never be used)

    Installed LOS recovery/magisk/opengapps all went well
    1
    Hello,

    please take my apologies if this behaviour was discussed earlier, but I'm a newbie to the Tab S6lite, and I've installed LOS18.1 two days ago yet (with OpenGapps pico and Magisk 23.0). I'm "only" familiar with LOS on several phones (HTC, Sony Xperia).

    It's working on the S6lite as expected, so many many thanks to the dev!

    The tablet is new, I bought it 10days ago.

    But... charging stops now at 70%, and even if the cable is plugged in, it says: No Charging. When chargelevel is 69% or less, charging is working, but when it reaches 70%, it switches charging off (automagically). Sigh...

    With stock rom (latest one) it did charge normally to 100%.

    What's going on there? And what do I have to change in switches/settings/configuration for "normal" charge behaviour?

    Thank you very much for any hint,
    samhhmobil
    I have no problems here with 2 tablets - the battery charges normally
    what is your stock or firmware version?
    does the tablet charge when it is completely switched off?
    do you use the originally supplied cable and power supply?
    1
    @Linux4
    many many thanks for the official support und good work. i bought the tablet from black friday.

    So far everything is going very well, but I found 4 bugs:
    1. ota update kill root (magisk) -with & without online recovery update - the most important thing for me!
    2. screen rotation cannot be switched off, the screen changes immediately to portrait format. i only use my tablets in widescreen! I only use 90 + 270, on other devices with lineageos it works without problems
    3. the resolution of the cam app is not adjusted, so the shutter release is only half visible
    4. Under hidden apps you can only hide not protect (lock symbol), logos for protecting are missing. bug?
    Having the same issue with screen rotation
    1
    and please don't use that damn "Universal Safety Net Fix", it creates more problems than it helps
  • 20
    1607247455067.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions:
    Note: You may use Odin instead of Heimdall, for this you will need to rename the recovery image to recovery.img and pack it into a tar archive.

    Downloads:

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    Support
    Telegram group

    Contributors
    Linux4
    Source Code: https://github.com/LineageOS
    Kernel source: https://github.com/LineageOS/android_kernel_samsung_gta4xl
    5
    Should this tablet be supported by Lineage for some time or is it impossible to know?

    Generally, when it comes to custom ROMs, it's impossible to say just how long a device will be supported. Sometimes, the device maintainer moves on and no one is available to take up the slack; other times, official support from the device developer (Samsung, in this case) stops, and though future Android updates can often be made to work with the last available code, sometimes it reaches a point where nothing further can be done. Can't speak to how long Linux4 will remain "on the job," but it doesn't look like he's going anywhere any time soon. Also, the Tab S6 Lite is supposed to officially get Android 12 some time next year, so device support should continue for a good while longer (in fact, an unofficial A12-based Lineage 19.0 is currently available, and will probably move to "official" status at some point when Lineage 19.0 builds become officially available [at the moment, 19.0 is still in the "bring-up" stage, with the software evolving day by day as its features are slowly being brought up]).
    4
    This was said multiple times already, this is caused by samsung having released two new harware revisions with new light sensor and new audio lately.
    Support for these is already fixed and just waiting for some review/testing to be merged into official 18.1, for now you could use unofficial 19.0 tho which already contains everything needed for your hardware revision.

    @Mr.Yindo This applies to you as well.
    Support for these new hardware revisions will be included in the next build on Wednesday.
    2
    Pls more details.
    How to?
    I'm in Recovery Lineageos.
    And?
    Advanced - Apply update - Choose from sdcard ? and than give him Masgisk-xx.x(xxx100).apk.zip ?

    I see a fault message and a question: Error: 21
    Signature verification failed
    Install anyway?
    Yes, Install anyway, rename magisk-xxx.apk to magsik-xxx.zip and flash.