[ROM][OFFICIAL][gts4lv|gts4lvwifi][12] LineageOS 19

Search This thread


Senior Member
Apr 4, 2013
Xiaomi Mi 10T Lite
I was wondering here if someone had a workaround for it. Swapping keyboards each time it goes numeric is so painful.
It appears that there are still issues with the AOSP Keyboard (opening up to black screen, number pad not visible....). I'm using an alterative but it does not have "swipe-to-type" capability. Does anyone have a good alternative that uses swipetyping?
  • Like
Reactions: sw_strange


New member
May 3, 2017
I've got the same issue with Magisk and audio.
Then tried to re-flash TWRP and from now on unable to boot anything but TWRP.
Is there any way to boot without formatting data or some weird boot chain security stuff will never let me do so?


Senior Member
Jun 26, 2008
Anyone else had problems since updating Magisk to version: v25+
I lost bluetooth audio, rotation and seemingly a bunch of apps.

I just flashed firmware, factopry rest etc to get back to normal.
Yes, flashing 25.2 from within magisk (25.1) trashed recovery (which was twrp at the time, ftr), so I could no longer update.

Manually reflashing twrp from the twrp app got me back into recovery, but after that system would no longer boot.

Turned out to be some sort of corruption with the addons.d directory. (at least, I think.) Also prevented me from taking a nandroid backup.

Since I couldn't decrypt to find the right folder/file to manually delete, I eventually gave up, wiped everything, reinstalled the latest lineage recovery and os, gapps, and restored from combo of google backup and seedvault. Then reflashed magisk from recovery and it worked fine.

Reminder to keep up to date backups, everyone!
  • Like
Reactions: peetereczek


Nov 9, 2015

apologies if this has been mentioned before (thread search still doesn't work since the change of forum software), but the 2.4 GHz WiFi channels 12 and 13 don't seem to work, regardless of the regional setting of the tablet.

It's easily reproducable by switching the channels on the WiFi router, channels 1-11 work fine, but if channel 12 or 13 is selected, the tablet doesn't even see the WiFi AP any more. I'm not sure if this is a problem of the firmware or the ROM itself, but it does happen at least with the two latest firmware releases (T720OXM2DVC3 and T720OXM2DUL1) and the last three nightly builds of LOS 19.1 for the gts4lvwifi (didn't check other releases).
As those two channels are forbidden in North America, I assume either the firmware or the ROM just ignores the regional setting and uses North American or international settings instead.

Would be nice if anyone could look into this.

[EDIT] This was probably the cause for the problem I reported here for LOS17.1 already, so the problem might exist a lot longer than just LOS 19.1 or the latest firmware releases.
My apologies to Luk1337 that I apparently hadn't responded to his answer there, I have no idea why I didn't see this and in fact can't even remember to have reported the problem back then.. I must be getting old, sorry.
Last edited:
  • Like
Reactions: starbright_


Dec 22, 2017
I have wifi issues with this tablet. This already is an issue since I got the device. However as I instantly switched to LOS I have no experience with stock ROM.
The issue is that the connection breaks down if I am farer away from the wifi access point. Any other devices like smartphones still have a good wifi connection while the S5e disconnects. I would expect a tablet to even have a better antenna than any smartphone as there is much more room for a good antenna...so is this maybe just a software issue?
So is this a general hardware issue with this tablet or a LOS issue? What are you experiences regarding the wifi coverage with this tablet?

/EDIT: I am on the current LOS release but also had the issue during several month with several older releases
I heard that this is a hardware issue known with the s5e unfortunately


Senior Member
Sep 9, 2011
London, UK
OK, I'm stuck and not quite sure how to proceed.

I'm using a stock 64GB 4G unit, that has never previously been flashed as far as I can tell.

So the first thing I need to do, following the instructions, is flash the VBMeta.tar file.

I follow the instructions to do that, unlock developer and enable OEM in settings, power off, use both volume and power keys to reboot, get unlock bootloader option, try to flash VBMeta.tar and get a (paraphrased) "unable to flash non Samsung/Official firmwares" type message.

Looking at that screen I notice that prenormal is showing and that may be the issue, but the info around about prenormal seems a little confusing and disjointed (changing date/time manually, waiting 7 days after unlocking bootloader).

Could anyone with actual experience with this prenormal issue perhaps give me some pointers how to resolve it please.


Senior Member
Jan 26, 2011
Guys, i have an issue.

when ever i download files using torrent, the downloaded files wont showup until i restart the tablet.

how yo fix this please?



Senior Member
Oct 14, 2007
Guys, i have an issue.

when ever i download files using torrent, the downloaded files wont showup until i restart the tablet.

how yo fix this please?

Haven't you try to close (force stop) and than reopen the file manager ? Btw, does the button long press option to stop foreground app works ?


New member
Aug 19, 2022
When I try to format an SD card for use as internal storage (Samsung Evo Plus 256GB), around 40% formatting the tablet reboots and then enters into a bootloop where the lockscreen appears for a moment, then reboots. This keeps happening until the SD card is removed. If I insert it while the tablet is running it bootloops again. If I format it on the computer it again offers to format it, fails at 40% and bootloops.
Is this a known issue?


Senior Member
Oct 14, 2007
yes, I did close and reopen the file manager. not showing files.

sorry which button? is it long press power button?
You can use long press of the Back button after setting "close foreground app" from the functions list in buttons menu in the settings.Thiis option was present in settings but did not work iin 19.1 earlier. Did You apply exactly "force stop" to close the File manager rather than move it to background with pressing "exit" which does not really close app ? For example, the Mixplorer does not show (without additional settings) any new files in the most of directories except such as "Download" until you close and reopen it.
Last edited:


Senior Member
May 24, 2012
While setting up accounts in Microsoft Authenticator, realised that the camera doesn't work within the app which is a bummer as QR codes cannot be scanned.

Besides that the WireGuard App is not able to access the camera for a QR Code Scan. Maybe this is also a problem for other apps?

I've seen two other people mention that the camera doesn't work within an app. For example to scan a QR code in the authenticator app. The camera gives a black screen. I couldn't find a solution to this issue here but was hoping someone knows one. Do I need to install a different camera app or??? I have the newest firmware installed.


Dec 22, 2017
I have a case that triggers auto-screen off when closed. But if I leave it overnight or so, with wifi on, I'll come back with like 30-40% battery drained due to the wifi being on. Ideally, the wifi would shut off immediately when the screen off/sleep mode is activated, or at least have an inactivity timer. On googling I see settings from old android versions to set "keep wifi online during sleep mode - never" that would accomplish this, but I don't see any such setting in this version.

Can this be done - auto shut off on screen close/sleep, or auto timeout after disuse of tablet?

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    I just wanted to show my appreciation for the hard work done in supporting Lineage for the S5e. The Lineage support is the main reason I bought this model. Thank you! Runs great.

    LOS 20 would be great to see at some point. A microg version would be cool too, but I'm just happy this has any kind of support.
    forget "shut off on screen close" - how about just any kind of automatic shutoff while the tablet is inactive for x minutes. Is there REALLY no setting for this? Any known root solutions for this?

    Follow up to this: there's an app on f-droid called WiFi Automatic that does, word for word, what I was requesting. It even turns it on when the screen comes back on.

    It seems to be working for me and it seems to be in the google play store too. Some SEO Key words to help others searching to solve this problem:
    android 12, wifi, sleep mode, wifi auto-off, wifi auto-on, wifi off on sleep mode, "can I automatically turn off wifi in sleep mode in android 12"
    Anyone found a workaround for the AOSP Keyboard crashing in numeric mode?

    Not a true true solution but based on recommendations I installed OpenBoard as a replacement for AOSP default. I find it to be as good at least, better in many ways: it has a "split keyboard" option that puts a spacer down the center, making it easier for both thumbs to hit the keys rather than traveling all across the screen. It also allows for height percentage adjustment and other customizations.
    Thanks. I'll try that. Is their an easy way too switch boards on the fly? Or just in settings?
    not that I know of. I switched to openboard and haven't felt a desire to go back
  • 29

    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project, with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS GitHub organization. And if you would like to contribute to LineageOS, please visit our Gerrit Code Review. You can also view the changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel, or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    Next build should also have a taskbar toggle here, hopefully that makes people cry less...
    Hi Luk1337
    Donation sent

    170.00 PLN
    god bless
    Thanks for that. That is helpful. I'll wait then until it is resolved sometime.

    So is that not hiding issue on hold an issue with Android 12 issue or this rom?

    It is amazing there isn't much hands on reviews / videos online on the Android 12 version itself (the tablet version) on how to's for new features. I did find one article that mentioned the hold to hide, but as you mention above it didn't work (I guess I was getting uneven results and difficulties. Eg on remote desktop once I bought up keyboard it'd show and I'd have to rotate and rotate and maybe get it to disappear.
    It just seems very inconsistent on 12.1 in general on tablets. Sometimes, the task bar stays hidden for considerable periods of time. Some apps pop up to adjust whereas in other cases the task bar simply overlaps with the same apps.

    You can always make it go away with long press or swipe down gestures but that is needless effort. I am living with it for a month now and would just like it to be consistent in the sense that it should stay hidden unless I pull it up. Unfortunately, that is not the case.

    To me, it simply seems that Google made some changes for tablets without really having a product in mind and thus it is poorly implemented. Expect it to get better with time as it seems it is here to stay.
    I haven't unlocked the bootloader of a device in a while...
    Does Netlix work Witz unlocked bootloader? What about widevine, is 1080p Playback still possible?
    Thanks in advance :)
    I got both working on my S5E Wifi.
    You have to use the latest Magisk Version 24.1. Activate Zygisk in the Settings, download the latest SafetyNet Fix for Zygisk from GitHub (https://github.com/kdrag0n/safetynet-fix/releases/tag/v2.2.1) and you need MagiskHidePropsConf (https://github.com/Magisk-Modules-Repo/MagiskHidePropsConf).

    I've set my device keys to some Samsung ones via "adb shell" and then "props" and followed the wizard steps.

    Got WideVine Level 1 with this ROM (full 1080p Support) and Passing all SafetyNet Tests (for now, i hope it will work for some time :D )

    Thank you a lot @LuK1337 for keeping this alive.