[ROM][OFFICIAL][gts4lvwifi][10] LineageOS 17.1

Search This thread

RagingHarry

Senior Member
Jan 8, 2012
825
328
Havelte
I was on 17.1 unofficial and just dirty flashed the official version. Worked fine for me. Not sure how long it's been since you've updated, but there was a new version of TWRP released back in February.
Also dirty flashed from unofficial 17.1, works indeed perfectly.

Sent from my gts4lvwifi using XDA Labs
 

Giorgo

Senior Member
Feb 14, 2008
65
1
Sorry to say, but no problems at all.
Are you on the latest Netflix app, a week ago Netflix crashed on starting to play anything, updated via apkpure solved that

Sent from my gts4lvwifi using XDA Labs

Hi, so you were right, I got the APK from apkpurve and it worked immediately.

I'd just gotten the APK from netflix and they wouldn't... now i can also update the store...


Thank you!
 

b3nji27

Member
May 12, 2014
34
13
Anyone else having issues with gaming on 17.1? Getting freezes/crashes and stuff not loading on a game that worked fine on stock?

On the official 17.1 Lineage, no magisk or anything
 

cowgaR

Senior Member
Oct 25, 2010
285
82
Londinium
Is it possible toch watch netflix in widevine L1 with this Lineageos Rom on my tab s5e?

This is an issue of unlocked bootloader rather than LOS. You will get lemon quality (SD instead of HD or 4k) of video on any DRM streaming website (Amazon, Netflix, Google) with any ROM or kernel - as your bootloader is not locked.
 
  • Like
Reactions: bovoro

Hubble666

New member
Jun 27, 2015
1
0
First of all much respect to luk!
I have a question about the sd card used as internal storage. is it not possible anymore? My system is encrypted. Couldn't find anything in this thread or duck duck.
 

yanom

Member
Jun 17, 2012
39
1
Anyone know how to turn off the smart cover wake/sleep feature in this ROM? I'm using a case that has a magnetic "smart" cover but I find that feature more annoying than useful because sometimes it triggers accidentally.
 

DreckSoft

Member
Oct 6, 2012
48
6
Does anyone know a way to change the boot logos? I wan't to get rid of the ugly unlocked warning. It easy on Exynos devices but for this one I haven't found anything. The other hints with /dev/...by-name/... are not working on this one. I'm fine with using dd, terminal and replacing the image within a binary, I just don't know where to look.
 

nsx2brz

Senior Member
Nov 4, 2014
71
33
Viper's Audio

I finally upgraded to LOS 17.1, everything is working great for me!

Here is how to get Viper's Audio working:

- Install Terminal Emulator, run "su", then run "pm disable org.lineageos.audiofx"
- Install Selinux Switch 7.1.3 from XDA labs, set PERMISSIVE
- Install Audio Modification Library 3.4 from Magisk, do not reboot
- Install Viper's Audio 2.7 APK from XDA Labs
- Run Viper's Audio, install driver, reboot
- Play an audio file
- Enable Viper's Audio for your output device, check the driver status, should be running and processing
- Set Selinux back to ENFORCING

Many many thanks to LuK1337 and the other devs!!!

(Edit - need to run Selinux Switch while doing this, but you can leave it enforcing once you are done...)
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Well… It was working. After a few reboots and installing among other things Magisk, afwall and EdXposed, I'm again with no sound and no screen rotation… full logcat from boot until unlock here https://paste.ubuntu.com/p/Cmmbf7kxqp/
    looks like /system/bin/audioserver crashes this may explains the sound problem but not the rotation one.

    Any one knows how to solve those issues?
    Uninstall EdXposed has to be the very first thing any sane person would do. It is known to be the source of endless headaches and badness.

    LineageOS does not just do random things and stop working without any reason. You need to reverse whatever you did that made things not work, and then figure out how to live without them.

    I would estimate that around 75% of all complaints about "this ROM has stopped working" are self-inflicted wounds. And it is quite frankly just pollution in the forums.
    1
    On my end flashing CTK1 did end up with :
    - no sound (volume rocker was fine though)
    - no rotation
    - no video decoding
    - long boot time
    was still on 17.1.
    Flashed 18.1, behavior did not change.
    Flashed CTI1, problems aforementioned disappeared. (while keeping 18.1, no userdata format)
    Was previously on what seems to be a mix of ATE3 and BTG3.
    Now I guess I'm ATE3/CTI1.
    Might be because of me flashing manually with TWRP (BTG3 and later) so not everything may be writable.
    You can't flash firmware with twrp.
  • 37
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][gts4lvwifi][10] LineageOS 17.1, ROM for the Samsung Galaxy Tab S5e

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2019-09-24
    Last Updated 2020-04-01
    18
    -- bit more friendly stock -> lineage instructions --

    1. Unlock the bootloader
    - Connect to WiFi network
    - Enable OEM Unlock in developer options
    - Turn off the tablet
    - Boot to download mode manually by plugging in USB and holding all the buttons for few seconds
    - Follow instructions on the screen
    2. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
    3. Flash custom VBMeta image ( https://dl.twrp.me/gts4lvwifi/vbmeta.tar.html ) in Odin ( use AP slot )
    4. After flashing VBMeta, boot to stock. It'll likely ask you to wipe data, if so do that
    5. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
    6. Now you can flash TWRP ( https://dl.twrp.me/gts4lvwifi ) in Odin ( use AP slot once again ), for convenience you can hold volume up while flashing it so that you boot to recovery right after it's flashed
    7. Install Lineage × whatever else you need ( gapps, addon-su, ... )
    8. Format data
    9. Reboot ( make sure to not install TWRP app when TWRP asks you to )

    ---

    Also Odin download for those who can't find it on their own https://build.nethunter.com/samsung-tools/Odin_3.13.1.zip
    ( sha1sum 1057496afa34bfdf7e77caf0b99207dca77fcb2d )
    7
    Builds 20200824+ depend on Android 10 firmware, and thus from now on the recovery will abort the installation if you're still on Android 9 one.

    You can update the firmware by flashing following Odin package: https://github.com/luk1337/gts4lv-fw/releases/tag/T720XXS2CUA3.

    After the firmware update you should be able to flash newer builds.
    6
    Hi, 20190928+ OpenGapps builds should work just fine without doing anything special. B-but there's a catch, you'll need to update to TWRP 3.3.1-4 or newer ^.^
    Have fun~!

    ---

    Also OpenGapps apparently moved their builds there ~ https://sourceforge.net/projects/opengapps/files/arm64/beta
    5
    Do you think there is chance lineage based on android 11 will support this tab?
    No comment.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone