[ROM][OFFICIAL][gts4lvwifi][10] LineageOS 17.1

Search This thread

JJ2017

Senior Member
Jan 7, 2017
56
36
Huawei P20 Pro
Widevine L1 working fine after installing this ROM (checked using the DRM info app).
I've got Netfix installed and working in HD after installing the app via "https://help.netflix.com/en/node/57688" web page (it's not visible in Google Play Store)
I also used the "MagiskHide Props Config" module in Magisk: not sure if this step was essential - it might be!
Device still doesn't pass safety-net with Magisk but Netflix runs OK.
Hope that helps.
 

denisovich

Member
Nov 9, 2020
19
12
Using LOS 17.1 on S5e 720, I have found that all GCAMs I have tried give the viewfinder preview rotated by 90 degrees. The pictures at the end are fine, but it is hard to frame and focus when everything is sideways and wrong aspect ratio .... :)

Anyone got a fix?

Thanks
 

o muerte

Member
May 18, 2012
40
9
Widevine L1 working fine after installing this ROM (checked using the DRM info app).
I've got Netfix installed and working in HD after installing the app via "https://help.netflix.com/en/node/57688" web page (it's not visible in Google Play Store)
I also used the "MagiskHide Props Config" module in Magisk: not sure if this step was essential - it might be!
Device still doesn't pass safety-net with Magisk but Netflix runs OK.
Hope that helps.
Can you tell me what settings you're using in the props config module? I'm passing safetynet right now and drminfo shows widevine L1 support but netflix refuses to run.
 

JJ2017

Senior Member
Jan 7, 2017
56
36
Huawei P20 Pro
Can you tell me what settings you're using in the props config module? I'm passing safetynet right now and drminfo shows widevine L1 support but netflix refuses to run.
I only changed the device fingerprint (option 1) in the props config module - but I've since deactivated the whole module and Netflix still working normally. I've checked the 'magisk hide' option and I'm also using the 'systemless host' module (no idea if that's relevant but maybe worth a try?). Couldn't get Netflix working on 1st attempt but, as I wrote above, a bit of tinkering got me there eventually.
 

LuK1337

Recognized Developer
Jan 18, 2013
8,321
16,630
Samsung Galaxy S III I9300
Moto G 2014
I only changed the device fingerprint (option 1) in the props config module - but I've since deactivated the whole module and Netflix still working normally. I've checked the 'magisk hide' option and I'm also using the 'systemless host' module (no idea if that's relevant but maybe worth a try?). Couldn't get Netflix working on 1st attempt but, as I wrote above, a bit of tinkering got me there eventually.
Netflix app itself works out of box even without google apps. Altering device props with magisk may break it tho.
 

d0udQu0i

New member
Mar 14, 2021
3
0
@LuK1337

hello everybody
after installing lineage os as well as root with magisk, i have the following problem :
-the sensitivity of the microphone is really low, that is to say that unless you speak very loudly directly into the microphone, my correspondents cannot hear me
-in addition to my correspondents the full of an echo when i join the voice conversation
can you help me, please
thanks in advance
 

D4rkAn9el

Member
Dec 5, 2008
13
1
I'm getting a boot loop. I tried the instruction in the second post (with the vbmeta image and all) and also the rooting guide at the following link: https://forum.xda-developers.com/t/galaxy-tab-s5e-sm-t720-root-instructions-release-1-0.3947806/ installing TWRP by patching the image with magisk. In the first case, after I try to boot the system it reboots automatically to recovery. In the latter case, it just reboot in loop without getting to lineage boot loader image.

I had it almost working before with LuisROM. But I had no sound and screen rotation didn't work either. So I wanted to try to reinstall from scratch starting from stock but I cannot get to boot custom firmware :/

What could it be?
 

o muerte

Member
May 18, 2012
40
9
I'm getting a boot loop. I tried the instruction in the second post (with the vbmeta image and all) and also the rooting guide at the following link: https://forum.xda-developers.com/t/galaxy-tab-s5e-sm-t720-root-instructions-release-1-0.3947806/ installing TWRP by patching the image with magisk. In the first case, after I try to boot the system it reboots automatically to recovery. In the latter case, it just reboot in loop without getting to lineage boot loader image.

I had it almost working before with LuisROM. But I had no sound and screen rotation didn't work either. So I wanted to try to reinstall from scratch starting from stock but I cannot get to boot custom firmware :/

What could it be?
Did you explicitly "format data" after installing? I had boot loops after wiping data but not formatting, after formatting everything worked as expected.
 
  • Like
Reactions: pierro78

D4rkAn9el

Member
Dec 5, 2008
13
1
Did you explicitly "format data" after installing? I had boot loops after wiping data but not formatting, after formatting everything worked as expected.

Ouch that was that. I just wiped my data. Now if did format and it booted fine and also the audio and screen rotation is working! I wonder why the latter two things wasn't working at first.
 
  • Like
Reactions: pierro78

D4rkAn9el

Member
Dec 5, 2008
13
1
Well… It was working. After a few reboots and installing among other things Magisk, afwall and EdXposed, I'm again with no sound and no screen rotation… full logcat from boot until unlock here https://paste.ubuntu.com/p/Cmmbf7kxqp/
looks like /system/bin/audioserver crashes this may explains the sound problem but not the rotation one.

Any one knows how to solve those issues?
 

denisovich

Member
Nov 9, 2020
19
12
Well… It was working. After a few reboots and installing among other things Magisk, afwall and EdXposed, I'm again with no sound and no screen rotation… full logcat from boot until unlock here https://paste.ubuntu.com/p/Cmmbf7kxqp/
looks like /system/bin/audioserver crashes this may explains the sound problem but not the rotation one.

Any one knows how to solve those issues?
Uninstall EdXposed has to be the very first thing any sane person would do. It is known to be the source of endless headaches and badness.

LineageOS does not just do random things and stop working without any reason. You need to reverse whatever you did that made things not work, and then figure out how to live without them.

I would estimate that around 75% of all complaints about "this ROM has stopped working" are self-inflicted wounds. And it is quite frankly just pollution in the forums.
 

ghnue

Member
Apr 25, 2020
17
2
On my end flashing CTK1 did end up with :
- no sound (volume rocker was fine though)
- no rotation
- no video decoding
- long boot time
was still on 17.1.
Flashed 18.1, behavior did not change.
Flashed CTI1, problems aforementioned disappeared. (while keeping 18.1, no userdata format)
Was previously on what seems to be a mix of ATE3 and BTG3.
Now I guess I'm ATE3/CTI1.
That's because of me flashing manually with TWRP (BTG3 and later) so not everything is writable.
 
Last edited:

LuK1337

Recognized Developer
Jan 18, 2013
8,321
16,630
Samsung Galaxy S III I9300
Moto G 2014
On my end flashing CTK1 did end up with :
- no sound (volume rocker was fine though)
- no rotation
- no video decoding
- long boot time
was still on 17.1.
Flashed 18.1, behavior did not change.
Flashed CTI1, problems aforementioned disappeared. (while keeping 18.1, no userdata format)
Was previously on what seems to be a mix of ATE3 and BTG3.
Now I guess I'm ATE3/CTI1.
Might be because of me flashing manually with TWRP (BTG3 and later) so not everything may be writable.
You can't flash firmware with twrp.
 
  • Like
Reactions: ghnue

ghnue

Member
Apr 25, 2020
17
2
Currently diffing what's writable by twrp and what is not, will report back.
Might then try to flash with odin/heimdall/don't remember if there was a fork.
 
Last edited:

ghnue

Member
Apr 25, 2020
17
2
Currently diffing what's writable by twrp and what is not, will report back.
Might then try to flash with odin/heimdall/don't remember if there was a fork.
Code:
abl                READ-ONLY
aop                READ-ONLY
apdp            READ-ONLY
bksecapp        READ-ONLY
cmnlib            READ-ONLY
cmnlib64        READ-ONLY
devcfg            READ-ONLY
dtbo            READ-WRITE
hyp                READ-ONLY
keymaster        READ-ONLY
msadp            READ-ONLY
persist            READ-WRITE
qupfw            READ-WRITE
apnhlos            READ-WRITE
sec                READ-ONLY
storsec            READ-ONLY
tz                READ-ONLY
vk                READ-WRITE
xbl                READ-ONLY
xbl_config        READ-ONLY
so yeah not a whole lot
 

ghnue

Member
Apr 25, 2020
17
2
Did a proper flash of CTI1 with odin, got bad vbmeta, am dumb. flashed blank vbmeta : all good, new "powered by android logo" at boot screen.
Did a proper (odin) flash of CTK1 with blank vbmeta : same problems as before.
Slim chance of the problems being caused by magisk/lsposed.
Did not try further, CTI1 is nice :)
(everything here done on 18.1)
 
Last edited:
I've just installed it and I love it :)

  • Immersive mode still there (just had to install Zach's System UI Tuner) (in android 11 I had to install Xposed framework and App Settings Reborn)
  • It's mounting the ext4 partitions I have on my microsd (was not the case with the android 11 ROM (LuisRom CrDroid) I tried) ... now can start a linux distro on a directory on my microsd with Linux Deploy :) ... and to me this linux distro feels smoother than with the android 11 ROM I tried ...
    (also with the stock ROM some linux programs like "sudo", "top", etc ... were not working under Linux Deploy but they work fine with this ROM)
  • system_server only eats about 1.5-2% CPU when the tablet is idle (in the android ROM I tried it was more like 10% (maybe it was because of the Xposed framework I had to install)) ... it's probably why my linux distro feels smoother ...
  • I also like that it opens my "silent notifications" by default, so I can see the battery level of my keyboard (BatON app)

Seems like I need to install the Nova launcher again because the home grid for apps (icons) seems to be limited to 5x7 or 6x6 ... also didn't find how to augment the grid in the apps drawer ...
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Well… It was working. After a few reboots and installing among other things Magisk, afwall and EdXposed, I'm again with no sound and no screen rotation… full logcat from boot until unlock here https://paste.ubuntu.com/p/Cmmbf7kxqp/
    looks like /system/bin/audioserver crashes this may explains the sound problem but not the rotation one.

    Any one knows how to solve those issues?
    Uninstall EdXposed has to be the very first thing any sane person would do. It is known to be the source of endless headaches and badness.

    LineageOS does not just do random things and stop working without any reason. You need to reverse whatever you did that made things not work, and then figure out how to live without them.

    I would estimate that around 75% of all complaints about "this ROM has stopped working" are self-inflicted wounds. And it is quite frankly just pollution in the forums.
    1
    On my end flashing CTK1 did end up with :
    - no sound (volume rocker was fine though)
    - no rotation
    - no video decoding
    - long boot time
    was still on 17.1.
    Flashed 18.1, behavior did not change.
    Flashed CTI1, problems aforementioned disappeared. (while keeping 18.1, no userdata format)
    Was previously on what seems to be a mix of ATE3 and BTG3.
    Now I guess I'm ATE3/CTI1.
    Might be because of me flashing manually with TWRP (BTG3 and later) so not everything may be writable.
    You can't flash firmware with twrp.
  • 37
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][gts4lvwifi][10] LineageOS 17.1, ROM for the Samsung Galaxy Tab S5e

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2019-09-24
    Last Updated 2020-04-01
    19
    -- bit more friendly stock -> lineage instructions --

    1. Unlock the bootloader
    - Connect to WiFi network
    - Enable OEM Unlock in developer options
    - Turn off the tablet
    - Boot to download mode manually by plugging in USB and holding all the buttons for few seconds
    - Follow instructions on the screen
    2. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
    3. Flash custom VBMeta image ( https://dl.twrp.me/gts4lvwifi/vbmeta.tar.html ) in Odin ( use AP slot )
    4. After flashing VBMeta, boot to stock. It'll likely ask you to wipe data, if so do that
    5. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
    6. Now you can flash TWRP ( https://dl.twrp.me/gts4lvwifi ) in Odin ( use AP slot once again ), for convenience you can hold volume up while flashing it so that you boot to recovery right after it's flashed
    7. Install Lineage × whatever else you need ( gapps, addon-su, ... )
    8. Format data
    9. Reboot ( make sure to not install TWRP app when TWRP asks you to )

    ---

    Also Odin download for those who can't find it on their own https://build.nethunter.com/samsung-tools/Odin_3.13.1.zip
    ( sha1sum 1057496afa34bfdf7e77caf0b99207dca77fcb2d )
    7
    Builds 20200824+ depend on Android 10 firmware, and thus from now on the recovery will abort the installation if you're still on Android 9 one.

    You can update the firmware by flashing following Odin package: https://github.com/luk1337/gts4lv-fw/releases/tag/T720XXS2CUA3.

    After the firmware update you should be able to flash newer builds.
    6
    Hi, 20190928+ OpenGapps builds should work just fine without doing anything special. B-but there's a catch, you'll need to update to TWRP 3.3.1-4 or newer ^.^
    Have fun~!

    ---

    Also OpenGapps apparently moved their builds there ~ https://sourceforge.net/projects/opengapps/files/arm64/beta
    5
    Do you think there is chance lineage based on android 11 will support this tab?
    No comment.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone