[ROM][OFFICIAL][gts4lvwifi][11] LineageOS 18.1

Search This thread

dbxoneA

Member
Sep 15, 2014
9
3

That's a bummer. Maybe consider adding a few words to the first page every time you fix/improve something?
I installed a version from last month, and now I don't know if it's worth flashing over a newer version. Also, how would you go about flashing a newer version? Do you have to wipe everything in twrp, or can you install over the older one?
Thanks for working on this ROM, much appreciated!
 

LuK1337

Recognized Developer
Jan 18, 2013
8,295
16,605
Samsung Galaxy S III I9300
Moto G 2014
That's a bummer. Maybe consider adding a few words to the first page every time you fix/improve something?
I installed a version from last month, and now I don't know if it's worth flashing over a newer version. Also, how would you go about flashing a newer version? Do you have to wipe everything in twrp, or can you install over the older one?
Thanks for working on this ROM, much appreciated!
Just install and reboot. Don't wipe anything, don't install twrp app.
 

lewmur

Senior Member
Apr 30, 2011
1,726
365
My tablet has the latest version of stock Android 10 CTl1. What versions of vbmeta.img and TWRP do I need to flash in order to flash the LOS 18 ROM? Links?
 
Last edited:

IdroogI

New member
Mar 23, 2020
2
1
Thanks for this great ROM!
Unfortunately TWRP cannot decrypt User Data. So I wiped Data and installed latest Nov. 3 ROM. But as soon I setup a PIN/FP TWRP cannot decrypt Data.
I was on latest Stock ROM (OneUI 2.5) for German variant and I flashed latest vbmeta and TWRP.
What did I do wrong? :/

Thanks in advance!
 

LuK1337

Recognized Developer
Jan 18, 2013
8,295
16,605
Samsung Galaxy S III I9300
Moto G 2014
Thanks for this great ROM!
Unfortunately TWRP cannot decrypt User Data. So I wiped Data and installed latest Nov. 3 ROM. But as soon I setup a PIN/FP TWRP cannot decrypt Data.
I was on latest Stock ROM (OneUI 2.5) for German variant and I flashed latest vbmeta and TWRP.
What did I do wrong? :/

Thanks in advance!

Nothing, that's just how twrp is with Android 11 roms.
 

btonetbone

Senior Member
Thanks for this great ROM!
Unfortunately TWRP cannot decrypt User Data. So I wiped Data and installed latest Nov. 3 ROM. But as soon I setup a PIN/FP TWRP cannot decrypt Data.
I was on latest Stock ROM (OneUI 2.5) for German variant and I flashed latest vbmeta and TWRP.
What did I do wrong? :/

Thanks in advance!
Switch from a PIN lock to a pattern lock and TWRP will decrypt.
 
Is Google play certified on your device ? I tryed this firmware, was stable, but the ctsprofile wasnt good and no certification :(

http%3A%2F%2Fi.imgur.com%2FVvlZ9FP.jpg
 

btonetbone

Senior Member
Sorry but I read the whole thread. I Saw nothing about this certification problem. I was only wondering if I was thé only one. Nevertheless I was able to pass safetynet with magisk and sommes addons, but if s not enough for somes apps.

Google Play certification for LineageOS is a larger item than just for this device. Here's the writeup on the LineageOS website:
https://www.lineageos.org/Google-Play-Certification/
 

BAM1976

Member
Jul 12, 2017
44
30
Amsterdam
Wanted to test this version. I am on the latest official 17.1 (so using the ap+bl from post3) and using the latest twrp (purple one). When I want to 'apply' update the verification fails and get the choice to 'install anyway' but hesitate to do this. Is this normal? (Seems like not?)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    I just flashed it. It boots for now. I just wonder if there is a way to not have this screen when I start my tab ?
    Yeah...flash Samsung's original software.
    1
    How to see change log for every new version?
    Can't see something that does not exist.
    1
    Hi,
    Just wanted to share my experience.
    I had 17.1 installed, and didn't want to test unofficial 18, because I knew I'd have to wipe at some point.
    So yesterday, when official 18.1 came, I downloaded it along with MindTheGapss, and flashed those in TWRP.
    Everything went fine :)
    By the way, 18.1 fixed the GPS problem I (and I guess some other) had: no need to restart android to get a GPS fix, now it works fine right after a reboot.
    1
    Upgraded from unofficial 18.1 to official 18.1 without issues. FWIW I have a very basic install; no gapps or magisk.

    Thanks @LuK1337 for keeping this updated. Sent a small donation to say thanks.
    1
    Upgrade for me did not went well. That "not enough space" problem with MindTheGapps-11.0.0-arm64-20210328_143848.zip. Thanks for the warning, I run TWRP backup before.
    In first attempt I restored too many partitions, so ended with ugly loop. Reverted to stock, fresh install of 17.1, and then TWRP restore of *images only + Data. And I'm back to starting point.
    I will run update next weekend or so - please share your experiences and recommended gapps. Does previously installed gapps version matters? Would running some install/update of gapps on 17.1 via TWRP help with that mindthegapps problem while installing? It works on some devices, so I wonder what is difference or how one could catch it.
    Regaeds
    Jan
    ...maybe just use opengapps for now?
  • 10
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    6
    -- bit more friendly stock -> lineage instructions --

    1. Unlock the bootloader
    - Connect to WiFi network
    - Enable OEM Unlock in developer options
    - Turn off the tablet
    - Boot to download mode manually by plugging in USB and holding all the buttons for few seconds
    - Follow instructions on the screen
    2. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
    3. Flash custom VBMeta image ( https://dl.twrp.me/gts4lvwifi/vbmeta.tar.html ) in Odin ( use AP slot )
    4. After flashing VBMeta, boot to stock. It'll likely ask you to wipe data, if so do that
    5. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
    6. Now you can flash TWRP ( https://dl.twrp.me/gts4lvwifi ) in Odin ( use AP slot once again ), for convenience you can hold volume up while flashing it so that you boot to recovery right after it's flashed
    7. Install Lineage × whatever else you need ( gapps, addon-su, ... )
    8. Format data
    9. Reboot ( make sure to not install TWRP app when TWRP asks you to )

    ---

    Also Odin download for those who can't find it on their own https://build.nethunter.com/samsung-tools/Odin_3.13.1.zip
    ( sha1sum 1057496afa34bfdf7e77caf0b99207dca77fcb2d )
    5
    I downloaded the bleeding-edge canary, not sure if that's necessary.

    Its not necessary anymore. 21.2 works fine with Android 11, at least on all the devices I've tried so far. This one included. No need to run the canary builds.

    Regular Magisk Releases Here. (GitHub Link)
    4
    I just flashed it. It boots for now. I just wonder if there is a way to not have this screen when I start my tab ?
    Yeah...flash Samsung's original software.
    3
    Builds 20200824+ depend on Android 10 firmware, and thus from now on the recovery will abort the installation if you're still on Android 9 one.

    You can update the firmware by flashing following Odin package: https://github.com/luk1337/gts4lv-fw/releases/tag/T720XXS2CUA3.

    After the firmware update you should be able to flash newer builds.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone