• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][hotdog][11] LineageOS 18.1

Search This thread

Hw4ng3r

Senior Member
It's already enabled. You just need to have keybox provisioned with L1 key.
tl;dr if it doesn't work on unlocked stock rom for you then it won't work here.

On my phone HD1910 7T Pro, I had to update to OOS 11 with a locked bootloader (on OOS10) to get L1 to work. When I upgraded from OOS10 to OOS11 with an unlocked bootloader, it stayed L3.
 

HemanthPayne

New member
Jun 1, 2021
1
0
OnePlus 7T Pro McLaren
Flashed LOS 18.1 yesterday, everything seems great so far, nice work devs!

The only issue I'm seeing is that I can't play HD video on Amazon Prime (I can't even install Disney+, says the device is not compatible) even though DRM Info says I'm L1 certified.

Does HD streaming not work with an unlocked bootloader at all? Or is there something I can do to make it work? (apart from just going back to stock of course)
 

Bas-NL

Member
Jan 31, 2014
37
6
OnePlus 7T Pro

Attachments

  • Screenshot_20210616-042759_Instellingen.png
    Screenshot_20210616-042759_Instellingen.png
    339.7 KB · Views: 72
  • Like
Reactions: EugenStanis

Bas-NL

Member
Jan 31, 2014
37
6
OnePlus 7T Pro
With the latest update from june 15 I keep getting a installation error, imediately after starting the update, within a second, Then the update stops.
I don't see a way of checking the installation log, so I don't know what's causing the error.

(which is okay, I can easily wait for the next update)
 

Bas-NL

Member
Jan 31, 2014
37
6
OnePlus 7T Pro
With the latest update from june 15 I keep getting a installation error, imediately after starting the update, within a second, Then the update stops.
I don't see a way of checking the installation log, so I don't know what's causing the error.

(which is okay, I can easily wait for the next update)
I get exactly the same problem 2nd update in a row

Screenshot_20210623-062552_Updater.png


(NL) Installatiefout = Installation error (ENG)
 

x-pve

Member
Aug 30, 2020
19
9
Prague
Installation using Lineage recovery/fastbootd OK for me. Sideloaded the zip (signature verified OK) first and Magisk's patched boot.img. Works well. Maybe the updater itself is broken?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    FYI, next week you'll get the first official 18.1 build.
    Follow official installation instructions on https://wiki.lineageos.org for upgrade/install and https://wiki.lineageos.org/devices/hotdog/fw_update for firmware update as OOS 11 FW is needed.
    7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    3
    Just saw that LOS 18.1 was officially released today. Can we expect getting official builds starting next week?
    3
    What is your--
    LineageOS version: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog
    LineageOS Download url: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog.zip | by LuK1337 for OnePlus 7T Pro (androidfilehost.com)
    Gapps version: NikGapps-core-arm64-11-20201122-signed

    Did you--
    wipe: yes
    restore with titanium backup: yes but with swift backup (tested gps before doing that with just core gapps as well)
    reboot after having the issue: yes

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk only

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Problem is GPS doesn't work. Everything else is fine. Tried last 2 versions from one I linked, doesn't work. Also tried first version and it doesn't work.
    Icon appears calling for location but no app can get it including maps, weather etc.
    It does eventually get my location but only after waiting 10 mins or, its not live at all. And when it eventually shows location its where I was quite a while ago. Completely wrong.

    EDIT: GPS also not working on AICP. But does work on OOS and MSM-EXTENDED. So no clue what the **** is going on.
    2
    Thanks @ LuK1337

    For this ROM. It works nicely on my 7T Pro McLaren 4G. (y):)