• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][hotdog][11] LineageOS 18.1

Search This thread

m0d

Senior Member
Nov 3, 2010
1,060
419
I am having a problem sending photographs taken using snap, lineage camera.
When sharing image to whatsapp, I get a black image and trying to send gives the error "file is not a photo".
I tried enabling camera permission, but it did not change.
Opencamera photographs are shared fine, though.
And, taking photograph directly through whatsapp works.
It is just Snap causing issues.

It happens for other devices, too:
https://www.reddit.com/r/LineageOS/comments/mkxwv0/_/gtjtqc4

Seems to be a lineage issue:
 

ewong3

Senior Member
May 28, 2015
182
38
Anyone came across this:
1) updated firmware by mistake to op7 pro
2) now can only get to fastboot on reboot
3) flashing los recovery.img does not change status from 2)
4) now can't flash roms of any kind as getting error of:
FAILED (remote: 'Flashing is not allowed for Critical Partitions')

short of MSM unbrick, anyone has other solution?

tips much appreciated...

update: did unbrick in the end
 
Last edited:

tbart

New member
Dec 19, 2018
2
0
Regarding what @x-pve said in https://forum.xda-developers.com/t/rom-official-hotdog-11-lineageos-18-1.4177353/post-84343087:
Hi All,
today I experienced an issue (first for me) - corrupted JPEG file when sharing it from Gallery.

I took a photo, opened Gallery. Clicked on the share icon and chose K9 mail. And the received files was corrupted.

Simillar approach - open the file in Files app, share, K9-mail etc. and the file was OK.

I checked hash and hash of the file sent from Gallery differs from the correct hash.

For example Gimp says: Corrupt JPEG data: 134 extraneous bytes before marker 0xc0.
This will most like be https://gitlab.com/LineageOS/issues/android/-/issues/4000 and should be fixed with yesterday's nightly!
 

Ondřej Holomek

Senior Member
Nov 29, 2016
78
18
Hi, i know this is for LOS 18.1, but i do not know where else should i write you, so sorry for this. Had you tried to build LOS 19 for hotdog? I did, but i have problem with camera/flashlight it says (camera is being used by another app) and i can not use flashlight or camera. And i do not know where else should i look.@LuK1337
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    FYI, next week you'll get the first official 18.1 build.
    Follow official installation instructions on https://wiki.lineageos.org for upgrade/install and https://wiki.lineageos.org/devices/hotdog/fw_update for firmware update as OOS 11 FW is needed.
    8
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    3
    Just saw that LOS 18.1 was officially released today. Can we expect getting official builds starting next week?
    3
    What is your--
    LineageOS version: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog
    LineageOS Download url: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog.zip | by LuK1337 for OnePlus 7T Pro (androidfilehost.com)
    Gapps version: NikGapps-core-arm64-11-20201122-signed

    Did you--
    wipe: yes
    restore with titanium backup: yes but with swift backup (tested gps before doing that with just core gapps as well)
    reboot after having the issue: yes

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk only

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Problem is GPS doesn't work. Everything else is fine. Tried last 2 versions from one I linked, doesn't work. Also tried first version and it doesn't work.
    Icon appears calling for location but no app can get it including maps, weather etc.
    It does eventually get my location but only after waiting 10 mins or, its not live at all. And when it eventually shows location its where I was quite a while ago. Completely wrong.

    EDIT: GPS also not working on AICP. But does work on OOS and MSM-EXTENDED. So no clue what the **** is going on.
    2
    Thanks @ LuK1337

    For this ROM. It works nicely on my 7T Pro McLaren 4G. (y):)