[ROM][OFFICIAL][hotdog][11] LineageOS 18.1

Search This thread

tomatoketchup

Member
Nov 17, 2010
38
7
Veracruz
Weird thing though, why can't I dirty flash new updates over one or another? I've just flashed a new version and now I'm stuck in a boot loop.

this happened to me on the unofficial 17.1 images too until they became official
I'm precisely holding against this 18.1 in fear of this so thanks for confirming! I'll guess I'll have to wait until it's official or the dev posts how to not get stuck in a bootloop on each flash
 
I saw some news from XDA two days ago that LineageOS Is awailable already for OP7T Pro but In the links it didn't had any links to the builds
Maybe because he is still working on it? He already said, build will be available next week.

 

LuK1337

Recognized Developer
Jan 18, 2013
8,375
16,741
Samsung Galaxy S III I9300
Moto G 2014
Maybe because he is still working on it? He already said, build will be available next week.

Maybe not. Keep guessing.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    If someone wants to try open vibrator changes, here are files needed to test it:
    https://kremowka.xyz/files/vendor.qti.hardware.vibrator.impl.so -> /vendor/lib64/vendor.qti.hardware.vibrator.impl.so
    https://kremowka.xyz/files/VibeTest.apk ( only expect click, double click, tick, heavy click to work )

    Also, VibeTest source code if someone thinks I'm gonna hack their phone or something — https://github.com/luk1337/VibeTest
    1
    About my experience and search, we can't hide magisk on Android 11 for now.

    I tried magisk hide and change props and many other thinks.
    Uff. It started work. I used also instruction from here:
    As phone also select Google Pixel 4XL

    Thank you all for helping me.
    1
    Is anyone using EdXposed on this ROM?

    I am using AFWall+, BubblePnP Audio Cast and XprivacyLua modules it would be great if that works!

    Thanks!
    I use it, but I'm not using any of those modules you are. You just have to use the magisk hide properties config to pass safety net
  • 11
    FYI, next week you'll get the first official 18.1 build.
    Follow official installation instructions on https://wiki.lineageos.org for upgrade/install and https://wiki.lineageos.org/devices/hotdog/fw_update for firmware update as OOS 11 FW is needed.
    7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    3
    Just saw that LOS 18.1 was officially released today. Can we expect getting official builds starting next week?
    3
    What is your--
    LineageOS version: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog
    LineageOS Download url: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog.zip | by LuK1337 for OnePlus 7T Pro (androidfilehost.com)
    Gapps version: NikGapps-core-arm64-11-20201122-signed

    Did you--
    wipe: yes
    restore with titanium backup: yes but with swift backup (tested gps before doing that with just core gapps as well)
    reboot after having the issue: yes

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk only

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Problem is GPS doesn't work. Everything else is fine. Tried last 2 versions from one I linked, doesn't work. Also tried first version and it doesn't work.
    Icon appears calling for location but no app can get it including maps, weather etc.
    It does eventually get my location but only after waiting 10 mins or, its not live at all. And when it eventually shows location its where I was quite a while ago. Completely wrong.

    EDIT: GPS also not working on AICP. But does work on OOS and MSM-EXTENDED. So no clue what the **** is going on.
    2
    Thanks @ LuK1337

    For this ROM. It works nicely on my 7T Pro McLaren 4G. (y):)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone