[ROM][OFFICIAL][hotdog][11] LineageOS 18.1

Search This thread

mkostkiewicz

Member
Jul 23, 2012
19
1
OnePlus 7T Pro
Easiest way is to extract rom file with payload dumper, copy boot.img to your phone, open magisk and click install>select and patch a file. Copy this file to your computer, in fastboot mode do fastboot boot magiskpatched.img, reboot and go to magisk again, click install>direct install, reboot and viola.
when I try to do fastboot boot *.img I get this error:
Code:
Sending 'boot.img' (98304 KB)                      OKAY [  2.339s]
Booting                                            FAILED (remote: 'Unrecognized command boot')
fastboot: error: Command failed
 

LuK1337

Recognized Developer
Jan 18, 2013
8,366
16,725
Samsung Galaxy S III I9300
Moto G 2014
He means that you have to install oos11 first. You can use msm tool to go back to stock and then update to oos11 then install lineage.
He probably doesn't really have to anymore. I thought he couldn't use fastboot boot at all but he was just in fastbootd rather than bootloader mode. Also, that's a really meh way to update FW FYI.
Sorry. After reboot it disapear.
:( I hate this.
So maybe it is starting to think to back to stock - is any simple way to do this (without brick the phone?)
Yeah, that's what happens if you ignore half of the instructions someone gives you.
 

mkostkiewicz

Member
Jul 23, 2012
19
1
OnePlus 7T Pro
Use the Canary build.
Unfortunately it didn't help. I get:
IMG_20210420_075856.jpg
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    FYI official LineageOS 18.1 build & Lineage recovery for OnePlus 7T Pro (hotdog) are now available for download: https://download.lineageos.org/hotdog

    See the upgrade & installation links in https://wiki.lineageos.org/devices/hotdog

    Thank you LuK1337 for supporting this device. :cool: 👍
    ***
    2
    I installed the ROM last night. I installed it over OOS 11. Make sure to follow the install instructions and things will go smooth.
    The ROM itself is pretty smooth as you'd expect from LOS. Battery life is good enough.

    However, ROM still needs some work such as:
    Haptics doesn't work. It doesn't vibrate on the back gesture. doesn't work on email delete in Gmail.
    Charging shows "Slow charging". But it charges fast anyway.
    Screenshot_20210414-060218.jpg

    The volume slider is on the right side. Ideally, it should be on the left side where the volume button is.
    1
    do you have an estimated time window?
    Yeah, it's between April 11th and April 17th.
    1
    in case anyone need more clarity than OP instructions, this is very detailed:

    I'll replace op instructions with link to the wiki when 1st build is up just like I did with my other 18.1 devices.
  • 11
    FYI, next week you'll get the first official 18.1 build.
    Follow official installation instructions on https://wiki.lineageos.org for upgrade/install and https://wiki.lineageos.org/devices/hotdog/fw_update for firmware update as OOS 11 FW is needed.
    7
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    3
    Just saw that LOS 18.1 was officially released today. Can we expect getting official builds starting next week?
    2
    What is your--
    LineageOS version: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog
    LineageOS Download url: lineage-18.0-20201201_212539-UNOFFICIAL-hotdog.zip | by LuK1337 for OnePlus 7T Pro (androidfilehost.com)
    Gapps version: NikGapps-core-arm64-11-20201122-signed

    Did you--
    wipe: yes
    restore with titanium backup: yes but with swift backup (tested gps before doing that with just core gapps as well)
    reboot after having the issue: yes

    Are you using--
    a task killer: no
    a non-stock kernel: no
    other modifications: magisk only

    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Problem is GPS doesn't work. Everything else is fine. Tried last 2 versions from one I linked, doesn't work. Also tried first version and it doesn't work.
    Icon appears calling for location but no app can get it including maps, weather etc.
    It does eventually get my location but only after waiting 10 mins or, its not live at all. And when it eventually shows location its where I was quite a while ago. Completely wrong.

    EDIT: GPS also not working on AICP. But does work on OOS and MSM-EXTENDED. So no clue what the **** is going on.
    2
    Thanks @ LuK1337

    For this ROM. It works nicely on my 7T Pro McLaren 4G. (y):)
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone