[ROM][OFFICIAL][hotdogb][11] LineageOS 18.1

Search This thread

xdabushrang3r

Senior Member
Feb 14, 2016
331
82
OnePlus 7T
Redmi Note 8 Pro
any plan for lineages 19.1 official rom?

⇩⇩⇩⇩⇩⇩⇩⇩⇩⇩ Read the thread ⇩⇩⇩⇩⇩⇩⇩⇩

@LuK1337
hey buddy i know its a bad question but i will ask ;)

what time you think you will release los 19?

  1. next weeks
  2. wait for oos12
  3. i dont have any plans next time
  4. i dont know now

thanks you very much for your time. br

Yes, that is indeed a bad question.
 
  • Like
Reactions: dor_pauli

borisSweden

Senior Member
May 10, 2021
177
14
OnePlus 7T
Hi @LuK1337, this is not a dumb question. I know LOS doesn't do kernel up porting so I dont expect you to port Linux kernel 5.0+. Would Android 11 be more efficient if someone ported Linux kernel 5.0+ for SD855 phones?
 
Last edited:

koushik92

New member
Dec 1, 2019
4
1
Built for myself (LOS 19.1 for OP7T), I use it as daily driver ... No major issue so far.
Thanks @LuK1337

The latest file for this unofficial build does not seem to have Gapps included...If I want to try this, how can I install Gapps with this because Gapps are not yet available for Android 12. Please reply.

1653364467090.png
 

sam.28011997

Member
Oct 17, 2018
7
0
Auto brightness is fluctuating a lot and transition isn't smooth, can it be gradual. I want to resolve this problem, does anyone know something how to do it?
 

sam.28011997

Member
Oct 17, 2018
7
0
@Klen2 didn't say he/she had installed it. The reason he/she is asking is because there has been a lot of talk in this thread about LOS 19.1.
I find his/her question to be valid.
I also didn't assume that it is installed. I commented why would anyone install unofficial one and ask about it in an official forum discussion. Yes there is a lot of talk about 19.1, but it is only people asking for eta.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    FYI ... firmware 11.0.8.1:

    Baseband version (the same as fw 11.0.7.1):
    1.1-00007-SM8150_GEN_PACK-2.387049.1.399262.2

    About updating firmware on hotdogb:
    If needed, you can download the required files for updating your firmware here (unzip and follow the official instructions ... use LOS recovery in fastbootD mode)

    About Android 12:
  • 58
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    5
    Hey guys, for anyone who is interested in installing magisk and is finding it difficult to extract the boot.img, no worries, you can download the latest magisk patched boot images from this thread, ill be uploading the latest magisk boot images weekly for every new release of lineageOS 18.1 hotdogb.
    4
    For those unhappy about the camera app situation I've found that the stock Oneplus camera app can be installed and used with a few caveats. This was tested on the May 30th LOS build, below I list a few notes to keep in mind for anyone interested:
    1. In my limited testing, APKs with version number 3.X.X are the newest ones that can be installed and actually work. Specifically 3.8.116 is the most stable I've found. The apk can be download here (APKMirror link).
    2. The app will always crash upon normal launch. In order to use it you must long press on the app icon and select one of the popup shortcuts (Pro, Take a video, Selfie, or Portrait). Launching from any of these shortcuts the camera app will work and so far I believe all the camera features work.
    3. There might be occasional crashes mostly due to switching between camera modes too much (Most notable on other 3.X.X versions).
    4. In Photo mode (not Pro mode) the aspect ratio button works only on 4:3 and 1:1, switching to fullscreen will render photo mode unusable as the app will crash upon switching to it. Other modes will still function as normal and Pro mode can use fullscreen aspect ratio without issues. If you accidentally switched to fullscreen aspect ratio in photo mode then it can be fixed by clearing the app data.
    5. The gallery button does not work, likely due to the missing oneplus gallery apk. Probably it will work with it installed but I haven't tested that yet.
    6. Systemlessly installing the app to the system folder does not improve anything. So installing the apk as any other normal sideloaded app is probably the best option.
    I'm not sure if the rom can be tweaked to prevent the normal launch crash. Though I'm not expecting anything from the dev about this. The app works without much issue and I'm trying to workaround the launch issue with tasker. Hopefully I'm succesful with it.
    4
    Finally, thank you luk
    4
    Latest August 1st Update seems to have screwed up the fingerprint unlock.

    Re-scanning the fingerprint works, but the issue is unlocking the phone with the fingerprint.

    It almost always says "Not recognized".

    This was not an issue before this update.