[ROM][OFFICIAL][hotdogb][11] LineageOS 18.1

Search This thread


Senior Member
Sep 3, 2016
It's in the reset section of settings. There's a "factory reset" option, which will destroy your data, and a "network reset" option. Which will reset everything networking related, but not destroy your data. Although you will have to reenter your WiFi network, and maybe APN (but usually not).

This is the default fix for lots of networking issues. So you'll want to figure this out.
TU, I'm on it. Edit.. Actually, already I'm getting short codes, which I haven't been able to get in a long time! Back to Amazon shopping as I can now access my account because of this :)
Last edited:
  • Like
Reactions: thefanum


Senior Member
FYI ... firmware

Baseband version (the same as fw

About updating firmware on hotdogb:
If needed, you can download the required files for updating your firmware here (unzip and follow the official instructions ... use LOS recovery in fastbootD mode)

About Android 12:
Hey will you provide a migration zip to update if official 19.1 released? or can we use the old package from codeworkx? thanks



Senior Member
May 10, 2021
OnePlus 7T
Great ROM, must've took great time and effort, thanks. Only, gestures are a bit slower than oos, and 48mp and macro are in the wind("aux-fix" module works, but still..); Yet its a fair trade-off for a lighter and much better ROM.

An important request would be:
I would be very happy if it is possible to add Savitech's LHDC codec to it. I couldn't find a way to add it, it is beyond me. There are dev files in:


If I had known how difficult to come across a device which can use it, I wouldn't buy these bt headphones :/ they are not worth that much without LHDC function.
Thank you.
There are other phones that enabled this, example Xiaomi. If Oneplus isn't going to add support before November then the devs can port it. As of now LDAC, LHDC is the only options for HD sound. Qualcomm ApTX platform is chaotic and r2.0 isn't good. They cut out stuff that was promised. But I'm not sure if this is the correct thread for porting.


Senior Member
Nov 28, 2009
Does this rom allow you to modify/set iptables ttl value (for ttl mangling)?


Feb 5, 2012
I asked already, but the last time the answers seemed to be filled with lack of knowledge and confusion.
When is "updating to the newer vendor firmware" necessary? For example when jumping from LO17 to LO18 and not when going from the latest OOS to the latest LO?
Where is this firmware stored? Does it survive to formatting `/`?


Senior Member
Dec 27, 2011
Samsung Galaxy Tab S2
OnePlus 3T
I asked already, but the last time the answers seemed to be filled with lack of knowledge and confusion.
When is "updating to the newer vendor firmware" necessary? For example when jumping from LO17 to LO18 and not when going from the latest OOS to the latest LO?
Where is this firmware stored? Does it survive to formatting `/`?
I'm just an enthusiast and Linux admin, so full disclosure my answer might be wrong. But I think it's just before flashing a new version of LineageOS. Be it the first (18 like this) or second (19.1 for example) you'll want to be on the newest stock firmware before each. But it's not necessary between LineageOS updates from the same version. Or rarely is.


Senior Member
Dec 27, 2011
Samsung Galaxy Tab S2
OnePlus 3T
Hi, I'm not new to installing LineageOS but I've never really followed the official guides. Since I was thinking to move also my 1+7t to this ROM, for once I opened the official guide and to my surprise I found the entry about updating "updating to the newer vendor firmware".
Is this really necessary? I have always thought that it comes when available with an update of the custom ROM. Is this incorrect?
That's incorrect


Senior Member
Dec 27, 2011
Samsung Galaxy Tab S2
OnePlus 3T
Does this rom allow you to modify/set iptables ttl value (for ttl mangling)?
So, I finally got a chance to look into this for you, and while I'm still not 100% sure I tested correctly, it looks like it might. I followed these instructions to test, and it ran the iptables command without an error (and I think it should error out of that kernel feature/module isn't included... At least that's how it works on desktop Linux).

Thread '[Kernel][Pixel4a5g(bramble)] Iptables TTL/Tether LineageOS 18.1' https://forum.xda-developers.com/t/...e-iptables-ttl-tether-lineageos-18-1.4295601/

I did the follow up test of starting the hotspot, connecting a separate device, and testing the speed, and it looked great. Although that might just be my phone plan, so I'm not at all confident in my diagnostics here. It was faster than my previous baseline test by about 15%. But that's well within speed test's natural fluctuation.

I know, not super helpful.

That being said, I did want to share my diagnostics with you, so you can decide if this is worth investigating further.
  • Like
Reactions: HueyT
LOS auto updates these baseband. But you can flash the above latest baseband even before LOS integrates them(if you want to).

If you're on windows:
(Prereq: You need ADB installed on your machine and know how to use it

Download the release file's zip, currently labelled as "latest" and extract it to a folder you can access (possibly your Downloads folder).
Go to that folder, and right click on ih8sn.conf, and click "Open With" and select Notepad
Edit the configuration(attaching conf file contents for Oneplus 7T with this post, check below) with your desired results for your device and click save

Method 1: Run "push" windows power shell script file via windows power shell

Now you're ready to push the results. However, the push.sh is for linux, so right click on that file and open with notepad.
Now you can see the following, this is what you're going to type into your command prompt:
Method 2: (manually running the script)

adb wait-for-device root
adb wait-for-device remount
adb wait-for-device push 60-ih8sn.sh /system/addon.d/
adb wait-for-device push ih8sn /system/bin/
adb wait-for-device push ih8sn.rc /system/etc/init/
adb wait-for-device push ih8sn.conf /system/etc/

This calls adb root which requires ADB Root in the developer options on your phone (not providing details on that)
Then it remounts the system (if you have issues, review the other issues)
It then pushes the files from your local directory to their respective folders.

You're doing some pretty "advance" things and thats why this is not beginner-friendly and no one but yourself is responsible if anything goes wrong.

I'd recommend you NOT do this and instead wait for proper documentation.
Note: All credits to LUK and the person who had made this guide on github.

Conf file contents: (copy paste exactly everything below this into conf file and save)

BUILD_DESCRIPTION=OnePlus7T-user 11 RKQ1.201022.002 2110211506 release-keys

This worked for me!
Just wanna add that if you want to run the PowerShell script, you'll need to toggle the "run ADB debugging as root" option first.
  • Like
Reactions: vicky2131


Senior Member
Nov 1, 2009
Seattle WA
My device will move to max brightness or 25% brightness (or close) frequently. This is very annoying when I am in a dark room as it is either blinding or too dark to read clearly. It's almost like the light sensor takes one reading, it's way off, and then the phone maxes or zeros out the out the lcd.

A gradual / stepped increase or averaged reading seems like the code side solution if that doesn't exist currently.

Can anyone tell me if there are any known issues with the auto brightness adjust feature, or if there are any work arounds for this use case?
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 59

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    Hey guys, for anyone who is interested in installing magisk and is finding it difficult to extract the boot.img, no worries, you can download the latest magisk patched boot images from this thread, ill be uploading the latest magisk boot images weekly for every new release of lineageOS 18.1 hotdogb.
    For those unhappy about the camera app situation I've found that the stock Oneplus camera app can be installed and used with a few caveats. This was tested on the May 30th LOS build, below I list a few notes to keep in mind for anyone interested:
    1. In my limited testing, APKs with version number 3.X.X are the newest ones that can be installed and actually work. Specifically 3.8.116 is the most stable I've found. The apk can be download here (APKMirror link).
    2. The app will always crash upon normal launch. In order to use it you must long press on the app icon and select one of the popup shortcuts (Pro, Take a video, Selfie, or Portrait). Launching from any of these shortcuts the camera app will work and so far I believe all the camera features work.
    3. There might be occasional crashes mostly due to switching between camera modes too much (Most notable on other 3.X.X versions).
    4. In Photo mode (not Pro mode) the aspect ratio button works only on 4:3 and 1:1, switching to fullscreen will render photo mode unusable as the app will crash upon switching to it. Other modes will still function as normal and Pro mode can use fullscreen aspect ratio without issues. If you accidentally switched to fullscreen aspect ratio in photo mode then it can be fixed by clearing the app data.
    5. The gallery button does not work, likely due to the missing oneplus gallery apk. Probably it will work with it installed but I haven't tested that yet.
    6. Systemlessly installing the app to the system folder does not improve anything. So installing the apk as any other normal sideloaded app is probably the best option.
    I'm not sure if the rom can be tweaked to prevent the normal launch crash. Though I'm not expecting anything from the dev about this. The app works without much issue and I'm trying to workaround the launch issue with tasker. Hopefully I'm succesful with it.
    Finally, thank you luk
    Latest August 1st Update seems to have screwed up the fingerprint unlock.

    Re-scanning the fingerprint works, but the issue is unlocking the phone with the fingerprint.

    It almost always says "Not recognized".

    This was not an issue before this update.