[ROM][OFFICIAL][hotdogb][11] LineageOS 18.1

Search This thread

savage44

Member
Jun 13, 2012
12
4
OnePlus 7T
Hey,
Does anyone else experiencing some sluggish animations with this ROM? I mean, openning app drawer for example of notification panel from top. The animation is not that smooth as everybody should expect. I have 90Hz set.
 

vicky2131

Senior Member
Hey,
Does anyone else experiencing some sluggish animations with this ROM? I mean, openning app drawer for example of notification panel from top. The animation is not that smooth as everybody should expect. I have 90Hz set.
Yes i was facing this issue. And on 60Hz it was far more worse. So changed my rom back till its fixed. I flashed clean and tried many other methods of clean install even without gapps but the issue was on ROM side and i could not get it fixed. Hope @LuK1337 can take a serious look into this issue please.

Last when i asked many people had this issue but the topic was left behind without any solution.
 

savage44

Member
Jun 13, 2012
12
4
OnePlus 7T
Yes i was facing this issue. And on 60Hz it was far more worse. So changed my rom back till its fixed. I flashed clean and tried many other methods of clean install even without gapps but the issue was on ROM side and i could not get it fixed. Hope @LuK1337 can take a serious look into this issue please.
Thanks for confirmation. I remember I was using it some time ago and it was smooth af :) I will see if I can find a build which is not affected.
 
Hey,
Does anyone else experiencing some sluggish animations with this ROM? I mean, openning app drawer for example of notification panel from top. The animation is not that smooth as everybody should expect. I have 90Hz set.


Which build are you using? I think I'm on the Aug 28th build. No issues here, and in some cases, games run smoother than my 9 Pro on stock. Maybe the Sep 4th build introduced some issues.
 

vicky2131

Senior Member
Which build are you using? I think I'm on the Aug 28th build. No issues here, and in some cases, games run smoother than my 9 Pro on stock. Maybe the Sep 4th build introduced some issues.
I tried few builds from last 3 months and all builds had this issue( when ever a new security patch build was released). So i can confirm it isn't a new issue. Are you using Oneplus 7T or Oneplus 9 pro?
 

savage44

Member
Jun 13, 2012
12
4
OnePlus 7T
Hi @vicky2131
Today I installed latest build from 0904 on top of 0703 via Android Updater from system settings. It's weird, but it looks like it is more smooth than before. Maybe it's a placebo? Need more tests :)
 
  • Like
Reactions: vicky2131

vicky2131

Senior Member
Hi @vicky2131
Today I installed latest build from 0904 on top of 0703 via Android Updater from system settings. It's weird, but it looks like it is more smooth than before. Maybe it's a placebo? Need more tests

Wow, that's good news. I always reverted back to some other rom because of the stutters and never updated from the updater. Please do let me know after a day use if the stutter is gone or not.
 

savage44

Member
Jun 13, 2012
12
4
OnePlus 7T
Wow, that's good news. I always reverted back to some other rom because of the stutters and never updated from the updater. Please do let me know after a day use if the stutter is gone or not.
Unfortunately not :( I was too excited too fast. It was kind of better on the first look but after some usage it became so bad. I have no idea what happened to this ROM. I remember it from the beginning of the year when it was buttery smooth and now... it's barely usable. Let's cross fingers for LOS 19.1 for OP7T :)
 
  • Like
Reactions: vicky2131

vicky2131

Senior Member
Unfortunately not :( I was too excited too fast. It was kind of better on the first look but after some usage it became so bad. I have no idea what happened to this ROM. I remember it from the beginning of the year when it was buttery smooth and now... it's barely usable. Let's cross fingers for LOS 19.1 for OP7T :)
Yes, hoping LOS19.1 would be smooth. Lineage os was my go to rom always(but because of this stuttering i jumped to other roms). I hope the next version would not be having these issues.
 
  • Like
Reactions: savage44
Hi,
I tried both builds 0904 and 0814 and both are laggy :/ overall performance is great but you can see some slowdowns in system animations.


Try disabling system animations entirely. It might not seem that noticeable to me because I personally have them off.

I tried few builds from last 3 months and all builds had this issue( when ever a new security patch build was released). So i can confirm it isn't a new issue. Are you using Oneplus 7T or Oneplus 9 pro?

OnePlus 7T. See above regarding animations.
 
  • Like
Reactions: vicky2131

vicky2131

Senior Member
@vicky2131 I found build which works great. Unfortunately it's 1 year old... If you are interested let me know, I can share it :) However I'm fine with it and it works perfect for me.
Wow, you took such an effort to find that. But all those fixes past one year and security updates would be missing so i'll better stick with Pixel exp 12+ until lineage os 19.1 comes out.
 

LaPesteO_o

Member
Feb 5, 2012
10
1
Hi. I installed LOS 18.1 with microg a couple of days ago. I'm surprised how much every works but I noticed that the UI of the OS lags a lot, but everything is fine in apps. Reading around there could be something that could show up in the log of the phone.
Should I
Code:
logcat -b all
? Could it help to figure out if something went wrong during flashing?
 

HueyT

Senior Member
Apr 3, 2014
4,725
2,146
New Albany, IN
OnePlus 7T
Hi. I installed LOS 18.1 with microg a couple of days ago. I'm surprised how much every works but I noticed that the UI of the OS lags a lot, but everything is fine in apps. Reading around there could be something that could show up in the log of the phone.
Should I
Code:
logcat -b all
? Could it help to figure out if something went wrong during flashing?
Custom kernel like Dora 3.0 sdcardfs should smooth it out
 
  • Like
Reactions: GuyInDogSuit

orangepowerpokes

Senior Member
Sep 3, 2016
114
32
Hey,
Does anyone else experiencing some sluggish animations with this ROM? I mean, openning app drawer for example of notification panel from top. The animation is not that smooth as everybody should expect. I have 90Hz set.
No issues here. Love this. For several months no major issues, updating every 3 months or so with the in-house LOS update in system settings. It just works buttery smooth usually, with occastional hickups (sometimes can't access home/apps wile in a call).

I'm on zero google, total f-droid guy. I think that's the key. Back in the day, I used to switch roms every week. Since I went google & gapps free when going with LOS here, it's been super with 2 day battery life on a 2019 phone I've had for 2 years, app drawer and app launch butter smooth. Insane.

I do occasionally have cummincation issues, texting and calls. On prepaid TMO, so I tend to blame the carrier, idk.. Send text sometimes, won't send. reboot, send > sent. etc. But I contsantly go in-and-out of EDROAM wifii (university) all the time.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 59
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    5
    Hey guys, for anyone who is interested in installing magisk and is finding it difficult to extract the boot.img, no worries, you can download the latest magisk patched boot images from this thread, ill be uploading the latest magisk boot images weekly for every new release of lineageOS 18.1 hotdogb.
    4
    For those unhappy about the camera app situation I've found that the stock Oneplus camera app can be installed and used with a few caveats. This was tested on the May 30th LOS build, below I list a few notes to keep in mind for anyone interested:
    1. In my limited testing, APKs with version number 3.X.X are the newest ones that can be installed and actually work. Specifically 3.8.116 is the most stable I've found. The apk can be download here (APKMirror link).
    2. The app will always crash upon normal launch. In order to use it you must long press on the app icon and select one of the popup shortcuts (Pro, Take a video, Selfie, or Portrait). Launching from any of these shortcuts the camera app will work and so far I believe all the camera features work.
    3. There might be occasional crashes mostly due to switching between camera modes too much (Most notable on other 3.X.X versions).
    4. In Photo mode (not Pro mode) the aspect ratio button works only on 4:3 and 1:1, switching to fullscreen will render photo mode unusable as the app will crash upon switching to it. Other modes will still function as normal and Pro mode can use fullscreen aspect ratio without issues. If you accidentally switched to fullscreen aspect ratio in photo mode then it can be fixed by clearing the app data.
    5. The gallery button does not work, likely due to the missing oneplus gallery apk. Probably it will work with it installed but I haven't tested that yet.
    6. Systemlessly installing the app to the system folder does not improve anything. So installing the apk as any other normal sideloaded app is probably the best option.
    I'm not sure if the rom can be tweaked to prevent the normal launch crash. Though I'm not expecting anything from the dev about this. The app works without much issue and I'm trying to workaround the launch issue with tasker. Hopefully I'm succesful with it.
    4
    Finally, thank you luk
    4
    Latest August 1st Update seems to have screwed up the fingerprint unlock.

    Re-scanning the fingerprint works, but the issue is unlocking the phone with the fingerprint.

    It almost always says "Not recognized".

    This was not an issue before this update.