[ROM][OFFICIAL][hotdogb][11] LineageOS 18.1

Search This thread

morphvale

Senior Member
Sep 13, 2013
279
103
Sibiu
Google Nexus 4
Google Nexus 5
Do you recommend this for daily use as per my usage listed in post before yours?
What is props config? Did you install as per instructions given in opening post or in some other way.
Would you recommend waiting for the next release?

Can't recommend anything myself, it all depends on personal taste and what you wish to gain.
For me, I'll keep running it for a few days and see how it goes. I'm pretty sure at this point anything is better than OOS11.

I've already mentioned how to install: Sideload ROM, reboot recovery, sideload GAPPS, sideload Magisk, reboot system.

Props config is a Magisk module, but it's not as easy as installing it and you're good to go, it also requires configuration. Maybe read a bit on it, as I don't think this is the place for it.
 
  • Like
Reactions: jesrani

jesrani

Senior Member
Mar 29, 2011
1,010
73
Mumbai
Honor 20
OnePlus 7T
Can't recommend anything myself, it all depends on personal taste and what you wish to gain.
For me, I'll keep running it for a few days and see how it goes. I'm pretty sure at this point anything is better than OOS11.

I've already mentioned how to install: Sideload ROM, reboot recovery, sideload GAPPS, sideload Magisk, reboot system.

Props config is a Magisk module, but it's not as easy as installing it and you're good to go, it also requires configuration. Maybe read a bit on it, as I don't think this is the place for it.
Thanks for reverting. I am currently rooted with Magisk and the only module I have installed is Systemless Host for Adaway.
I am currently able to use:
1) Banking apps with Magisk hide, except BHIM UPI
2) Adaway
3) Bluetooth tethering
4) Titanium Backup for restoring apps data
5) Gcam
6) Device encryption
7) Gapps
Are all these possible with Lineage OS?
It's been more than a year since I last flashed anything using adb so I am bit unsure. Should I follow the instructions given by OP?
 

HueyT

Senior Member
Apr 3, 2014
4,011
1,899
New Albany, IN
OnePlus 7T
Im unable to install stock with adb sideload, im getting
E: Signature verification failed E: error 21.
and "Update package is older than the current build" error eventhough i downloaded the Oos 11(indian variant)from https://www.xda-developers.com/oneplus-oxygenos-11-stable-oneplus-7-oneplus-7t/
Then you're stuck with fastboot oos11 install using payload dumper extraction--though oxygen updater apk (from playstore) may let you download and install from current rom.
 

eamon0989

Senior Member
Jun 10, 2011
68
15
Limerick
It's been working great to be honest, battery life better than stock! I've had trouble with the ING banking app, I've removed root and factory reset, installed lineage again without root and it's still a bit iffy, it seems to think it's still rooted.

I've noticed opening the multitasking menu is a little buggy/slow, and the fingerprint reader is not as fast or as accurate as stock, but that's to be expected.

Other than that I haven't noticed any other bugs.
 

lil_kujo

Senior Member
  • Oct 29, 2015
    805
    442
    It's been working great to be honest, battery life better than stock! I've had trouble with the ING banking app, I've removed root and factory reset, installed lineage again without root and it's still a bit iffy, it seems to think it's still rooted.

    I've noticed opening the multitasking menu is a little buggy/slow, and the fingerprint reader is not as fast or as accurate as stock, but that's to be expected.

    Other than that I haven't noticed any other bugs.
    If rooted just use magisk hide props config mod to have it pass safety net.
     

    eamon0989

    Senior Member
    Jun 10, 2011
    68
    15
    Limerick
    If rooted just use magisk hide props config mod to have it pass safety net.
    I tried that. It passed safety net but ING still didn't work. After googling it it appears that they have their own extra checks. I tried everything including changing props, hiding magisk, etc.

    All my other apps worked fine, just ING which happens to be my main bank...
     

    morphvale

    Senior Member
    Sep 13, 2013
    279
    103
    Sibiu
    Google Nexus 4
    Google Nexus 5
    I tried that. It passed safety net but ING still didn't work. After googling it it appears that they have their own extra checks. I tried everything including changing props, hiding magisk, etc.

    All my other apps worked fine, just ING which happens to be my main bank...

    Is this ING Romania? If yes, that's a bit tricky to fool, but it does work for me.
    Enable Magisk Hide, hide the Magisk app (important, as the app detects the package name), hide ING from Magisk Hide menu, install Props Config and Select Oneplus (option 21) - Oneplus 7T EU (option 24) then reboot. Now try to open ING, and it should work. That's the workflow for me, at least.
     

    eamon0989

    Senior Member
    Jun 10, 2011
    68
    15
    Limerick
    Is this ING Romania? If yes, that's a bit tricky to fool, but it does work for me.
    Enable Magisk Hide, hide the Magisk app (important, as the app detects the package name), hide ING from Magisk Hide menu, install Props Config and Select Oneplus (option 21) - Oneplus 7T EU (option 24) then reboot. Now try to open ING, and it should work. That's the workflow for me, at least.
    I tried all of that :( it's strange because when I was on stock ROM I was rooted and I didn't have any problems, but with lineage I can't manage to fool it.

    It doesn't specifically say that it's rooted, it tells me to upgrade to the latest app and says it can't work. It's very strange. But I've got it working now, it's a pain to have to give up root but honestly I just need my banking app to work so I'm gonna leave it for now, if I have time some weekend I'll try your exact steps again. Thanks very much for the reply!
     

    pstnnn

    Member
    Aug 3, 2020
    7
    1
    I'LL SEND 20$ TO ANYONE WHO HELPS ME FIX THIS

    I installed this on a brand new HD1907 (unbranded) north american version.

    Everything works perfectly EXCEPT waze (the weird thing is that google maps works perfectly).

    Nothing in waze works, I can't search or even see the map. See the screenshot attached.

    Any idea what I could do to fix this?

     

    LuK1337

    Recognized Developer
    Jan 18, 2013
    8,418
    16,811
    Samsung Galaxy S III I9300
    Moto G 2014
    I'LL SEND 20$ TO ANYONE WHO HELPS ME FIX THIS

    I installed this on a brand new HD1907 (unbranded) north american version.

    Everything works perfectly EXCEPT waze (the weird thing is that google maps works perfectly).

    Nothing in waze works, I can't search or even see the map. See the screenshot attached.

    Any idea what I could do to fix this?

    install gapps lmao.
     
    • Like
    Reactions: santa leone

    LuK1337

    Recognized Developer
    Jan 18, 2013
    8,418
    16,811
    Samsung Galaxy S III I9300
    Moto G 2014
    gapps doesnt fix it. I have another phone with lineage, and without gapps and waze works perfectly.
    And that phone is on clean (no gapps, no microg, ...) 18.1? If so what phone is that because I tested a couple of different phones and none of them had working waze. What phone was that?
    EDIT: Try installing Waze 4.58, initializing it and then update to the latest one.
     
    Last edited:

    [email protected]

    Senior Member
  • Aug 27, 2010
    1,716
    1,228
    44
    Brooklyn, NY
    superstarmobility.weebly.com
    And that phone is on clean (no gapps, no microg, ...) 18.1? If so what phone is that because I tested a couple of different phones and none of them had working waze. What phone was that?
    EDIT: Try installing Waze 4.58, initializing it and then update to the latest one.
    Off topic but I see you maintain Mokee for Hotdog ... do you plan on getting a build up and running for Hotdogb?
     

    Solsun

    Member
    Oct 9, 2010
    18
    5
    OnePlus One
    OnePlus 7T
    Thanks to those who've helped get this phone supported by LineageOS.

    Hopefully VoLTE will get an icon displayed but happy with lineageOS so far. Battery has been great and no overheating. We do lose out on some of the Oxygen UI tweeks for the camera that I miss but knowing that I'll get an update regularly make it worth it.

    I'm on the hd9107 from B&H Photo. I purchased it without the T-Mobile firmware. Upgrading to LineageOS was easy following the instructions. The LineageOS updater in settings will update without using fastboot adb sideloading.
     
    Last edited:

    littlenoodles

    Senior Member
    Apr 30, 2011
    94
    12
    The installation instructions refer to linneage recovery. I know TWRP has had some issues on this phone, but I was under the impression that it was only a problem with OOS. Is it specifically *not* recommended to use TWRP with this?
     

    Lossyx

    Senior Member
    Jan 14, 2014
    1,476
    606
    OnePlus 7T Pro
    The installation instructions refer to linneage recovery. I know TWRP has had some issues on this phone, but I was under the impression that it was only a problem with OOS. Is it specifically *not* recommended to use TWRP with this?
    Only decryption is specific to OOS, the other stuff is broken for custom ROM as well.

    Use LOS recovery and follow wiki to successfully flash this ROM.
     

    klaymaniaf

    Senior Member
  • Nov 27, 2011
    159
    39
    After installing the rom how much time it takes to boot?
    Because I waited for 30 minutes with the boot logo on screen and nothing happened.

    Edit: On my HD1907 T-Mobile unlocked version the LineageOS wiki is wrong. Vol down + Power does not work/take you to lineage recovery, Vol Up + Power does this after fastboot flash boot <recovery_filename>.img and better with phone powered off.
     
    Last edited:

    Top Liked Posts

    • There are no posts matching your filters.
    • 3
      For those unhappy about the camera app situation I've found that the stock Oneplus camera app can be installed and used with a few caveats. This was tested on the May 30th LOS build, below I list a few notes to keep in mind for anyone interested:
      1. In my limited testing, APKs with version number 3.X.X are the newest ones that can be installed and actually work. Specifically 3.8.116 is the most stable I've found. The apk can be download here (APKMirror link).
      2. The app will always crash upon normal launch. In order to use it you must long press on the app icon and select one of the popup shortcuts (Pro, Take a video, Selfie, or Portrait). Launching from any of these shortcuts the camera app will work and so far I believe all the camera features work.
      3. There might be occasional crashes mostly due to switching between camera modes too much (Most notable on other 3.X.X versions).
      4. In Photo mode (not Pro mode) the aspect ratio button works only on 4:3 and 1:1, switching to fullscreen will render photo mode unusable as the app will crash upon switching to it. Other modes will still function as normal and Pro mode can use fullscreen aspect ratio without issues. If you accidentally switched to fullscreen aspect ratio in photo mode then it can be fixed by clearing the app data.
      5. The gallery button does not work, likely due to the missing oneplus gallery apk. Probably it will work with it installed but I haven't tested that yet.
      6. Systemlessly installing the app to the system folder does not improve anything. So installing the apk as any other normal sideloaded app is probably the best option.
      I'm not sure if the rom can be tweaked to prevent the normal launch crash. Though I'm not expecting anything from the dev about this. The app works without much issue and I'm trying to workaround the launch issue with tasker. Hopefully I'm succesful with it.
      1
      Fingerprint sensor stopped working May 23rd update.

      Seems like a display brightness issue. I cranked up the brightness to max and it started working again.

      About 80% screen brightness seems to be where it starts to work.

      Screenshot_20210525-100501_Edge.png


      I'm gonna keep updating my reply with more info as I discover more.
      1
      Good catch! I noticed fingerprint issues as well, but hadn't thought to check screen brightness. Turned it back up and it started working again.
      It works properly on latest build with default kernel.
      1
      Uh oops, I linked the wrong post. Try quoting one above it.
      Confirmed the error.
      1
      i've installed the rom and all works just fine. The only thing i did not find in setting is "advance reboot". Am i just blind or it doesn"t exist?
      Settings > System > Advanced > Gestures > Power Menu > Advanced Restart

      Note that it will only show up once you choose restart in the power menu
    • 43
      2okPze5.png


      LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

      Instructions :
      Downloads :
      Reporting Bugs
      • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
      • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
      • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
      • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
      Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

      Code:
      What is your--
      LineageOS version:
      LineageOS Download url:
      Gapps version:
      
      Did you--
      wipe:
      restore with titanium backup:
      reboot after having the issue:
      
      Are you using--
      a task killer:
      a non-stock kernel:
      other modifications:
      
      Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
      3
      For those unhappy about the camera app situation I've found that the stock Oneplus camera app can be installed and used with a few caveats. This was tested on the May 30th LOS build, below I list a few notes to keep in mind for anyone interested:
      1. In my limited testing, APKs with version number 3.X.X are the newest ones that can be installed and actually work. Specifically 3.8.116 is the most stable I've found. The apk can be download here (APKMirror link).
      2. The app will always crash upon normal launch. In order to use it you must long press on the app icon and select one of the popup shortcuts (Pro, Take a video, Selfie, or Portrait). Launching from any of these shortcuts the camera app will work and so far I believe all the camera features work.
      3. There might be occasional crashes mostly due to switching between camera modes too much (Most notable on other 3.X.X versions).
      4. In Photo mode (not Pro mode) the aspect ratio button works only on 4:3 and 1:1, switching to fullscreen will render photo mode unusable as the app will crash upon switching to it. Other modes will still function as normal and Pro mode can use fullscreen aspect ratio without issues. If you accidentally switched to fullscreen aspect ratio in photo mode then it can be fixed by clearing the app data.
      5. The gallery button does not work, likely due to the missing oneplus gallery apk. Probably it will work with it installed but I haven't tested that yet.
      6. Systemlessly installing the app to the system folder does not improve anything. So installing the apk as any other normal sideloaded app is probably the best option.
      I'm not sure if the rom can be tweaked to prevent the normal launch crash. Though I'm not expecting anything from the dev about this. The app works without much issue and I'm trying to workaround the launch issue with tasker. Hopefully I'm succesful with it.
      2
      Finally, thank you luk
      2
      It's been working great to be honest, battery life better than stock! I've had trouble with the ING banking app, I've removed root and factory reset, installed lineage again without root and it's still a bit iffy, it seems to think it's still rooted.

      I've noticed opening the multitasking menu is a little buggy/slow, and the fingerprint reader is not as fast or as accurate as stock, but that's to be expected.

      Other than that I haven't noticed any other bugs.
      2

      LuK1337 thankyou so much​