• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][I01WD][9] LineageOS 16.0

Search This thread

nosb

Member
Jun 11, 2017
15
2
hello, i am on the latest q lineageos 17.1 (4.20.2020) and it works great so far but i would like to install the stock q camera app (i assume the 'camera addon' in the first post is just for the pie rom). i used the forum search and googled aswell but had no luck. i found a tool(classykitchen), extracted the asuscamera.apk from the stock q rom but i cannot figure out how to install it. neither in system or via adb. any help?

edit:// for anyone who is curious, couple days later i just tried to flash the provided 'camera addon' for the pie/9 version via recovery and it kind of works on q/10 but it wont save any images
 
Last edited:

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
Hello! Has anyone successfully flashed LineageOS 17.1? When i try to flash it I have an error: "Package is for product I01WD but expected ASUS_I01WD"

I get this exact same error. I tried flashing through TWRP too but it fails. In fact, with TWRP it won't boot 16 either! I have also tried fastboot flashing the recovery (lineage-17.1-20200423-recovery-I01WD.img) and can only get into fastboot mode with it and had to flash back the recovery from 16.
 

abx12

Member
Jul 2, 2019
9
2
Hi @luca020400 new .145 seems quite stable and battery seems to have improved. Would be great if you could do another build with updated blobs and drivers. Also if possible stock camera commits additions too.
 

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
I'm now running the latest build of 17.1. I'm not sure if it worked because the build has been fixed or because I upgraded to the official Asus 10 build first. However, there still doesn't seem to be a way to customise the smart key. It's the one thing missing that would make Lineage perfect on this phone. I've tried everything, from editing the Generic.kl file with mavisk to 5 different hardware button mapping apps and nothing will get rid of that damn google assistant!

If the dev that's worked on Lineage is listening, please please please please could we have smart key customisation, or at least a hint of what needs editing in the running system to allow for it!
 
  • Like
Reactions: springer.music

springer.music

Senior Member
Dec 15, 2010
545
301
Planet Earth
I'm now running the latest build of 17.1. I'm not sure if it worked because the build has been fixed or because I upgraded to the official Asus 10 build first. However, there still doesn't seem to be a way to customise the smart key. It's the one thing missing that would make Lineage perfect on this phone. I've tried everything, from editing the Generic.kl file with mavisk to 5 different hardware button mapping apps and nothing will get rid of that damn google assistant!

If the dev that's worked on Lineage is listening, please please please please could we have smart key customisation, or at least a hint of what needs editing in the running system to allow for it!

The dev is the OP, @luca020400
He wrote the following post about the possibility to customise the smart key back then:
https://forum.xda-developers.com/showpost.php?p=80109345&postcount=69

Isn't there any menu at all under Settings to configure the smart key in LOS17.1 ? Not even to disable it?

On a separate note, I'm itching to install LOS17.1 on my Z6 as well.

I'd just have a couple of questions:
Apart from the smart key issue, is everything else working fine?
How well is is performing overall?
Which Gapps did you install?

Cheers
 

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
Isn't there any menu at all under Settings to configure the smart key in LOS17.1 ? Not even to disable it?

There is a buttons section that has options to custominse the power button and volume buttons but nothing that I can find for the smart key yet.

Apart from the smart key issue, is everything else working fine?
How well is is performing overall?
Which Gapps did you install?

It's not 100% stable but then it is a nightly. I've had a few crashes, one of which I had to remove the battery to recover from. Having said that, there was a change in today's nightly that enabled the Low Memory Killer Daemon which might sort much of that out. I've also had a little bit of weirdness on phone calls where speaker phone would get stuck on. I can't speak for VoWifi or VoLTE as my network doesn't support them but I have heard that they may not work.

Other than those couple of things I love the rom, it has everything I want and the new customisation options in Lineage 17 are lovely. For me it blows the official Asus build out of the water.

I installed Open GApps nano (though it wouldn't install first go. I had to let it boot then wipe and install in recovery after that, restarting recovery on it's own might be enough though).
 
  • Like
Reactions: springer.music

springer.music

Senior Member
Dec 15, 2010
545
301
Planet Earth
There is a buttons section that has options to custominse the power button and volume buttons but nothing that I can find for the smart key yet.

I see. In the official Asus build the smart key settings are in a separate "Advanced" section. Have you tried searching for "key" in Settings to see whether the smart key options are buried somewhere else?

I've had a few crashes, one of which I had to remove the battery to recover from.
Ouch! Do you mean that you had to unglue the back cover and remove the battery just to recover from a crash?
 

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
I see. In the official Asus build the smart key settings are in a separate "Advanced" section. Have you tried searching for "key" in Settings to see whether the smart key options are buried somewhere else?

There's a section called additional buttons but it just goes to the section for power/volume buttons. Nothing but keyboard settings for a search for key. I'm sure it'll come in time, just keeping an eye on https://download.lineageos.org/I01WD/changes/ for now.

Ouch! Do you mean that you had to unglue the back cover and remove the battery just to recover from a crash?

I've had to do that a couple of times before (namely on Lineage 16 and once on Asus official) so it might just be my phone or I'm just very impatient and it would have recovered eventually!
 

aleksander002

Senior Member
Apr 10, 2013
249
75
I believe the power button (or Power+Volume down) pressed for 10 seconds should kill the power and force a phone to reboot. Have you tried that? It would be insane to have a ROM from which you can't recover without a heat gun and a screwdriver.
 

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
I believe the power button (or Power+Volume down) pressed for 10 seconds should kill the power and force a phone to reboot. Have you tried that? It would be insane to have a ROM from which you can't recover without a heat gun and a screwdriver.

I'm pretty sure I tried that originally and it didn't work but since the back cover on my phone is barely glued on after having to remove it for something else long ago it just takes a fingernail to prise it off now so I haven't tried since. If it hangs again I'll see if I can recover without having to remove the battery! In todays nightly the weirdness with speakerphone appears to be fixed but then that could just be because I rebooted!
 

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
I had another hard-hang but power+volume down did fix the issue. Still getting weirdness with phone calls (and whatsapp calls). The volume is too loud and the other caller can hear a really bad echo of themselves. Speaker mode works ok but normal call mode does not. A reboot seems to fix the issue for a short time.
 

springer.music

Senior Member
Dec 15, 2010
545
301
Planet Earth
I had another hard-hang but power+volume down did fix the issue. Still getting weirdness with phone calls (and whatsapp calls). The volume is too loud and the other caller can hear a really bad echo of themselves. Speaker mode works ok but normal call mode does not. A reboot seems to fix the issue for a short time.

Good to hear that you didn't have to remove the battery again ;)

Quick question: are you on the latest nightly from 5th June? https://download.lineageos.org/I01WD
I can see that Luca Stefani - the dev supporting the Z6 - imported the latest Asus drivers from UL-ASUS_I01WD-ASUS-17.1810.2005.153 on 4 June, therefore I assume that the LOS build from 5 June includes them:
https://review.lineageos.org/q/I01WD
Could the new drivers help with some of the issues you bumped into?

I just wonder what happens with the radio/modem part: when Asus updates it in their official releases, does it get imported/updated in a subsequent LOS build? Or do we need to update it separately (and how)?

Last question (I promise ;) ): Assuming that you're rooted with Magisk, does LOS 17.1 pass the safety net test on the Z6?

Thank you!
 

snakeman65

Senior Member
Nov 8, 2008
167
43
Wendover
Good to hear that you didn't have to remove the battery again ;)
Just had a little more patience this time!
Quick question: are you on the latest nightly from 5th June? https://download.lineageos.org/I01WD
I can see that Luca Stefani - the dev supporting the Z6 - imported the latest Asus drivers from UL-ASUS_I01WD-ASUS-17.1810.2005.153 on 4 June, therefore I assume that the LOS build from 5 June includes them:
https://review.lineageos.org/q/I01WD
Could the new drivers help with some of the issues you bumped into?
Yes I'm on that build. I have been updating every time there's a new build. Still had the speakerphone issue and a hang on this build. It doesn't hang that often though but the speaker phone issue is pretty much all the time
I just wonder what happens with the radio/modem part: when Asus updates it in their official releases, does it get imported/updated in a subsequent LOS build? Or do we need to update it separately (and how)?
No idea i'm afraid.
Last question (I promise ;) ): Assuming that you're rooted with Magisk, does LOS 17.1 pass the safety net test on the Z6?

Yes I'm rooted with Magisk (though I probably don't need to be, I can't even remember why I rooted!). It passes safetynet fine but I did have to use the MagiskHide Props Config module. My banking app and google pay work perfectly :D
 

springer.music

Senior Member
Dec 15, 2010
545
301
Planet Earth
It seems data roaming isn't working with a German Zenfone 6 in the UK.

Roaming works fine with that SIM card in an HTC 10 with LineageOS 16 (unofficial build). The data roaming setting is enabled.
I've tried several different cellular networks, both SIM slots and wiping Dalvik. I've played around with the "preferred networ type", though GSM/WCDMA/LTE should be correct.
SIM status under "About" says mobile data network is unknown.

No roaming at all. Any country, any sim. Tried Zurich, all Portugal regions, Munich. Problem is just zf6 los16.
Luca answered:

Luca Stefani, [11/8/19, 11:15 AM]
I really don't have a way to test it

Luca Stefani, [11/8/19, 11:15 AM]
And if I do, it'll be hard to debug

No need to vote. Is a sad sad situation. :)
But AFAIR I had roaming troubles even with stock in august 2019.

@UsernameShortage , @trashographer , @luca020400 ,

Can you please confirm whether the roaming data issue is now fixed in LOS 17.1 ?

Thank you!
 

springer.music

Senior Member
Dec 15, 2010
545
301
Planet Earth
All right, I just went ahead and installed LOS 17.1 following the official guide at https://wiki.lineageos.org/devices/I01WD/install

Most stuff seems to be working properly.

I've just noticed a 2/3 issues (so far).

1. Similar audio issues during calls mentioned by @snakeman65
The first few calls after a reboot seem to be fine. After some running time (it can be between 30 mins and an hour) the caller's voice comes from the bottom speaker instead of the earpiece when a new call is placed or answered. When this happens, callers complain about hearing a strong echo of their own voice, making the phone call almost impossible.
Reported here: https://gitlab.com/LineageOS/issues/android/-/issues/2122

2. Wi-Fi Hotspot doesn't work. Tapping "Wi-Fi hotspot" under "Settings > Network and Internet > Hotspot and tethering" crashes Settings.
Reported here: https://gitlab.com/LineageOS/issues/android/-/issues/2121

3. One sudden reboot that ended in an endless loop of the LineageOS animation. Had to force reboot.
 
  • Like
Reactions: papete

Top Liked Posts

  • There are no posts matching your filters.
  • 31
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps/addons
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps/addons
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the ASUS ZenFone 6 (2019)

    Contributors
    luca020400
    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie

    Version Information
    Status: Nightly

    Created 2019-07-11
    Last Updated 2019-08-19
    14
    New lineage-16.0-20190801-UNOFFICIAL-I01WD.zip build is up
    Adds support for HDR and Wide Color Gamut and fixes AVRCP ( Bluetooth ) controls
    10
    New build lineage-16.0-20190722-UNOFFICIAL-I01WD is up
    Requires UL-ASUS_I01WD-ASUS-16.1220.1906.167-1.1.1-user firmware
    Updates kernel, improves audio, improves mobile data
    10
    New lineage-16.0-20190725-UNOFFICIAL-I01WD.zip build is up
    Improve support for Lineage Recovery, add FM Radio support, improves GPS performance ( enables IZAT )
    10
    New build is up
    Fixes some decoder issues ( Twitch/Reddit works now ), enables call recording for allowed countries and you can now force old apps to be displayed at full-screen ( 18:9 )

    Another build is up
    No real changes to end-user

    Starting from next build UL-ASUS_I01WD-ASUS-16.1220.1906.167-1.1.1-user firmware will be required.