[ROM][OFFICIAL][I01WD][9] LineageOS 16.0

Search This thread
D

Deleted member 10113280

Guest
Bugs in both LineageOS 16.0 and 17.1

I'd be okay going back to LineageOS 16 but @luca020400 still hasn't merged WW-16.1220.1909.194 which, apparently, fixes the flashing black screen issue during screen rotation.


https://github.com/LineageOS/android_device_asus_I01WD/commits/lineage-16.0


So we have LineageOS 16.0 and 17.1 and both of them have bugs which would've made me stay away from this device had I known about them before I bought this device.
 
  • Like
Reactions: SGH-i200

nuggeo

Senior Member
Oct 21, 2008
117
7
I'd be okay going back to LineageOS 16 but @luca020400 still hasn't merged WW-16.1220.1909.194 which, apparently, fixes the flashing black screen issue during screen rotation.


https://github.com/LineageOS/android_device_asus_I01WD/commits/lineage-16.0


So we have LineageOS 16.0 and 17.1 and both of them have bugs which would've made me stay away from this device had I known about them before I bought this device.

**** me, just got this device on the cheap with the single intention of finally getting back to LOS.
 

Slippy_K

New member
Jul 9, 2020
1
0
Hi everyone, I'm having trouble updating to LOS 17, I'd appreciate help.

I have the most recent ASUS firmware installed and I can install Lineage Recovery 17 just fine. I've followed the steps in the wiki, I've also tried via TWRP, and I've tried fastboot flashing the images individually, all with the same effect: I get just past the lineage logo to a black screen. If I push the volume buttons the volume slider appears, so it's doing *something* but nothing else loads. If I load GApps I get slightly further to a language selection, but it pauses on 'Just a sec' for a few minutes then restarts.

The only unusual thing I've noticed is that flashing the images individually, system.img is sent in only two parts - one ~750MB, the other ~700MB. This is way less than the 3.8GB the image should have. If I flash the ASUS firmware for example it is sent in 5 parts totaling 3.8GB, so I suspect something strange is happening here.

Any insight or suggestion would be great, especially if someone could clarify what's up with the system.img size.
 

vikashhero

Senior Member
Feb 17, 2011
486
177
London
Does anyone know which firmware I should be using for LOS 17? I have the CSC bundle for WW_ZS630KL_17.1810.2005.153_M3.18.40.16 and I'm not sure if that's too old or too new? Would I be right in thinking I should use Mauro's TWRP to flash the latest zip available from Asus' website and proceed from there?

NVM found it in the end.
 
Last edited:
Jan 14, 2021
3
1
Has anyone tried this rom since the latest firmware update last month? The official downloads have a build date of 12-20 so it looks like that may be incorporated now (hopefully with the T-Mobile VoLTE fix).
 

OmegaResNovae

Member
Aug 5, 2019
6
8

vikashhero

Senior Member
Feb 17, 2011
486
177
London
[deleted]
 

Attachments

  • 1612279555083.png
    1612279555083.png
    33.6 KB · Views: 107
Last edited:

atomicsnail

Member
Feb 14, 2021
6
5
Recently picked up a Zenfone 6... moving from an old LG G Pro (CM11) .. for the most part like the hardware and LOS is working fairly well so far.

Started off installing UL-ASUS_I01WD-ASUS-19.1810.2011.183-1.1.1-user.zip (twice).

Installed LOS 17.1-20210122 nightly, TWRP 3.5 and magisk.

Turned off the motor service by renaming
/system/priv-app/MotorService/MotorService.apk
to MotorService.zzz.

Never use front cameras and constant CPU usage during screen on isn't worth it.

Applied a patch found for another rom from micky387 to /vendor/etc/mixer_paths_tavil.xml to turn off the speaker while in a call in order to stop the crazy echo problems in call by adding line in bold to handset section of file.

<path name="handset">
<ctl name="TFA_Selector Receiver" value="1" />
<ctl name="TFA_Selector Speaker" value="0" />
<ctl name="DK Profile" value="receiver" />
</path>

There are a couple of issues I noticed I don't care about. The settings app crashes whenever VPN starts up but still works fine. LOS crashes when connecting to wifi screen casting.. I never use it.

Finally there is something weird going on that causes crashes / the system to flake out. It can be reliably reproduced here using following steps:

1. Boot phone
2. Play a video in VLC (3.3.0) with audio output to device speakers. Does not matter how long a few seconds before stopping is fine.
3. Receive a call.

After this audio does not play in LOS music app and eventually the UI will become unresponsive / go haywire.

Otherwise if you don't use VLC all seems to be fine.

Thanks for the ROM! Battery life is amazing on this device so far.
 
  • Like
Reactions: SGH-i200 and papete

atomicsnail

Member
Feb 14, 2021
6
5
Finally there is something weird going on that causes crashes / the system to flake out. It can be reliably reproduced here using following steps:

1. Boot phone
2. Play a video in VLC (3.3.0) with audio output to device speakers. Does not matter how long a few seconds before stopping is fine.
3. Receive a call.

After this audio does not play in LOS music app and eventually the UI will become unresponsive / go haywire.

Was able to isolate this a bit more. My zenfone is orientation locked to portrait.

VLC via wired headphones or BT worked so did VLC in portrait orientation from device speakers. A signal generator app which happens to run in landscape (org.billthefarmer.siggen on f-droid) causes the same behavior where system will go haywire if the app is run and then later a phone call is received.

Seems to be apps with audio sent to device speaker that run in a different orientation from device.

The problem can be worked around by changing ro.audio.monitorRotation to 0 in /vendor/build.prop. It prevents signaling of orientation changes to AudioService that seems to be causing this.
 
  • Like
Reactions: SGH-i200 and papete

GRöder

Member
May 18, 2021
12
2
Did anyone get the Asus Stock Camera to work on LOS 17 (latest update at the time of this posting) ?
I tried it by flashing the LOS 16-Asuscamera zip file, but had the same Problem as @nosb
[...]
for anyone who is curious, couple days later i just tried to flash the provided 'camera addon' for the pie/9 version via recovery and it kind of works on q/10 but it wont save any images
The Camera does work, as expected, until you try to save photo. When trying to save to internal storage, it just does not save the image (stays at "processing", and its gone when you open the recent pictures again). When changing the setting to save pictures to sdcard, the app instantly crashes.

Has anyone had more success ?

Edit:
Curiously taking a video (no matter if regular, timelapse, slomo) or shooting a photo in the manuel mode does work as expected, although only when using the main cam, not the wide-angel cam.
When trying to use the wide-angel cam, the app just doesnt react at all when the release button is pressed.
 
Last edited:

Zen_Fone

Member
Feb 5, 2021
19
2
Did anyone get the Asus Stock Camera to work on LOS 17 (latest update at the time of this posting) ?
I tried it by flashing the LOS 16-Asuscamera zip file, but had the same Problem as @nosb

The Camera does work, as expected, until you try to save photo. When trying to save to internal storage, it just does not save the image (stays at "processing", and its gone when you open the recent pictures again). When changing the setting to save pictures to sdcard, the app instantly crashes.

Has anyone had more success ?

Edit:
Curiously taking a video (no matter if regular, timelapse, slomo) or shooting a photo in the manuel mode does work as expected, although only when using the main cam, not the wide-angel cam.
When trying to use the wide-angel cam, the app just doesnt react at all when the release button is pressed.
@GRöder @nosb Can one of you tell me how I flash the app into LOS?

Also have either of you found a camera app (other than stock) that can do 4k/60 on the front cam?

Please help as I really need this, thank you.
 
Last edited:

GRöder

Member
May 18, 2021
12
2
@GRöder @nosb Can one of you tell me where I can get the stock camera app and how I can flash it into LOS?

Also have either of you found a camera app (other than stock) that can do 4k/60 on the front cam?

Please help as I really need this, thank you.
The asus-stock-camera (which only works with LineageOS 16 / Android 9, as it seems) is linked in the opener of this thread (ASUS Camera Add-On). Its a .zip-file, which must be flashed with a custom recovery (TWRP or Lineage Recovery) and will install the Camera as a system app.
 

Zen_Fone

Member
Feb 5, 2021
19
2
The asus-stock-camera (which only works with LineageOS 16 / Android 9, as it seems) is linked in the opener of this thread (ASUS Camera Add-On). Its a .zip-file, which must be flashed with a custom recovery (TWRP or Lineage Recovery) and will install the Camera as a system app.
I'm in recovery mode for LineageOS 17.1 and I have the zip file. What do I do from here? Sorry it's been a few months since I did this whole thing and can't remember much. Do I need to do something with adb?
 

GRöder

Member
May 18, 2021
12
2
As I wrote two times in the last 3 posts (last time just before your post) the asus-camera-addon does not work properly with LineageOS 17. It does not save the taken pictures and crashes when trying to change save location to sd card.
If you nevertheless want to waste your time by trying what I just tried, you need to go to "Apply Update" -> "Choose from disk" -> chose your file -> yes (ignoring that it isn't signed properly).
I'm assuming, that you're using Lineage Recovery, not TWRP, @Zen_Fone .
 

Zen_Fone

Member
Feb 5, 2021
19
2
As I wrote two times in the last 3 posts (last time just before your post) the asus-camera-addon does not work properly with LineageOS 17. It does not save the taken pictures and crashes when trying to change save location to sd card.
If you nevertheless want to waste your time by trying what I just tried, you need to go to "Apply Update" -> "Choose from disk" -> chose your file -> yes (ignoring that it isn't signed properly).
I'm assuming, that you're using Lineage Recovery, not TWRP, @Zen_Fone .
Thanks, but I'm not bothered about pictures. I need it for the video (assuming it can do and save 4k/60 on the front cam). Just flashed the app but I can't even get past the permissions page. Repeatedly asks for permissions even though they've already been granted.
 

GRöder

Member
May 18, 2021
12
2
Thanks, but I'm not bothered about pictures. I need it for the video (assuming it can do and save 4k/60 on the front cam). Just flashed the app but I can't even get past the permissions page. Repeatedly asks for permissions even though they've already been granted.
I had the same issue the first time I tried it. I then flashed the rom (more precisely the system and boot partitions, but the full rom should work, too) again, did a factory reset, tried again and it worked. It seems to be important that you accept all permissions the first time you start the app. I didn't do that at my first try and suspect it to be the cause for this behaviour (repeatedly asking for permissions, although it already has them).
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Thanks! Do you might also have the LOS 16 Version?
    Im trying to stay on Android 9 since they implemented deep tracking since Q.

    LineageOS 16:

    lineage-16.0-20200325-nightly-I01WD-signed.zip: download (sha256) | recovery (sha256) | torrent

    I also have archived some of the early builds. Check this page in case you need them.
  • 31
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (Pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps/addons
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps/addons
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    LineageOS, ROM for the ASUS ZenFone 6 (2019)

    Contributors
    luca020400
    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie

    Version Information
    Status: Nightly

    Created 2019-07-11
    Last Updated 2019-08-19
    14
    New lineage-16.0-20190801-UNOFFICIAL-I01WD.zip build is up
    Adds support for HDR and Wide Color Gamut and fixes AVRCP ( Bluetooth ) controls
    10
    New build lineage-16.0-20190722-UNOFFICIAL-I01WD is up
    Requires UL-ASUS_I01WD-ASUS-16.1220.1906.167-1.1.1-user firmware
    Updates kernel, improves audio, improves mobile data
    10
    New lineage-16.0-20190725-UNOFFICIAL-I01WD.zip build is up
    Improve support for Lineage Recovery, add FM Radio support, improves GPS performance ( enables IZAT )
    10
    New build is up
    Fixes some decoder issues ( Twitch/Reddit works now ), enables call recording for allowed countries and you can now force old apps to be displayed at full-screen ( 18:9 )

    Another build is up
    No real changes to end-user

    Starting from next build UL-ASUS_I01WD-ASUS-16.1220.1906.167-1.1.1-user firmware will be required.