ROM[OFFICIAL][instantnoodle][11.0]**crDroid**[V7.14]

Search This thread

NUNsLAUGHTER92

Senior Member
Dec 26, 2010
166
38
Crdroid is a very good rom. The things you complain about have nothing to do with the rom, but rather with the fact that your phone has only one slot populated with stock firmware, instead of the two.

You also don't need to flash an older version of the rom (again for the same reason - second slot not populated). That's why everything worked for you after an additional flash: simply, the second flash installed the rom into the working slot. Next time when you flash, you will again experience problems, because the rom will go into the non-working slot.

Why is this happening? Custom roms do not touch about 28 additional partitions that have stock firmware. These partitions are REQUIRED to be populated in both slots. No matter how many times you flash custom roms, these additional partitions won't change. To do that you need to flash the full stock rom.

Remember, MSM tool takes care of one slot only. You still need to either do a full stock OTA update (after a mandatory reboot) or a full flash, so that the firmware would go to the second slot. Or use Lineage's 'copy partitions' zip. Otherwise, you will only have one working slot, i.e., problems every second flash... .

Messages not showing is because you need to disable battery optimization for all your messengers. Without that, those messages won't show up until the app is brought into foreground.
My phone has this on both slots because I used the copy slot thing from lineage right after I got the ROM fully updated. Also using stock message app and that already comes without battery optimization.

The ROM was already working for me before I tried to update with the built in updater. So why did it only break when updating? You say I don't need to flash an older ROM but I didn't know how the hell to flash the current one when it says to use the bat file but the new ones don't have it and the bat file doesn't reference any of the files in the new versions of this ROM. So go ahead and teach me how I'm supposed to go from stock to the new versions if you want.
Edit: I forgot about one other problem I had. For some reason my contacts aren't imported by either contacts app, I thinks I have none on Google. I had to go to the website, export my contacts and then import them from the file. Since I got my first android phone (when android 2.1 was the most used) I have never had this issue. Very strange. Maybe someone knows how to solve this issue.
 
Last edited:

optimumpro

Senior Member
Jan 18, 2013
7,471
14,817
OnePlus 8
My phone has this on both slots because I used the copy slot thing from lineage right after I got the ROM fully updated. Also using stock message app and that already comes without battery optimization.

The ROM was already working for me before I tried to update with the built in updater. So why did it only break when updating? You say I don't need to flash an older ROM but I didn't know how the hell to flash the current one when it says to use the bat file but the new ones don't have it and the bat file doesn't reference any of the files in the new versions of this ROM. So go ahead and teach me how I'm supposed to go from stock to the new versions if you want.
Edit: I forgot about one other problem I had. For some reason my contacts aren't imported by either contacts app, I thinks I have none on Google. I had to go to the website, export my contacts and then import them from the file. Since I got my first android phone (when android 2.1 was the most used) I have never had this issue. Very strange. Maybe someone knows how to solve this issue.
Normally, you flash updates with recovery.

If you jumped to stock A12, and then back to Crdroid, your partition copying won't do you any good, as you had A12 firmware, which is incompatible with custom roms.

Your second slot still could be non-working, as after several unsuccessful reboots, the system will boot and set active the prior slot.

I personally would never use system update engine.
 

NUNsLAUGHTER92

Senior Member
Dec 26, 2010
166
38
Normally, you flash updates with recovery.

If you jumped to stock A12, and then back to Crdroid, your partition copying won't do you any good, as you had A12 firmware, which is incompatible with custom roms.

Your second slot still could be non-working, as after several unsuccessful reboots, the system will boot and set active the prior slot.

I personally would never use system update engine.
On my second attempt I did use recovery to update, sideload or whatever. I was on stock android 11.
Since that first alarm miss I haven't missed one, so it's whatever. I really don't feel like messing with all this anymore. Better battery life and no freezes unlike stock android 11 so I'm happy.
My contacts problem is apparently permissions not being granted. To what app, I don't know. Contacts app has no contacts but my phone app does.

Edit: Aaaand I found it. I don't get why contacts can't just sync by itself and instead I need to grant some other app the permission to sync inside of another app. Android has made things more difficult/annoying since 8 I guess.

Edit again: YouTube vanced (root) causes the screen to permanently darken until a reboot. Force closing it doesn't help. Using a quick 'rebooter' like fReboot doesn't help.
This doesn't happen on stock android with the same version. To cause this to happen all I need to do is watch a video and possibly go in and out of the app a few times. I had wondered why my screen was so much darker for a while. I noticed that I often had to have my brightness set to max in places I never had it that high. I finally noticed it happen after my fingerprint scanner icon completely disappeared. Without it, the screen won't become bright enough for it to scan a fingerprint. I have seen the fingerprint icon move to the upper left corner for a split second before but it always moved back, I figured it was because of the custom icon used and maybe a rotation bug. It's too bad that this ROM won't be getting any updates. Maybe stock YouTube doesn't have this problem, maybe revanced doesn't either. I'll have to give the second one a chance and hope for the best because I'm definitely not using stock YouTube.

Edit again again: no display issues when using YouTube Revanced (non root)
 

Attachments

  • Screenshot_20220715-175132563.jpg
    Screenshot_20220715-175132563.jpg
    164 KB · Views: 29
  • Screenshot_20220715-180407265.jpg
    Screenshot_20220715-180407265.jpg
    149 KB · Views: 28
Last edited:

Top Liked Posts