[ROM][OFFICIAL][instantnoodlep][11] LineageOS 18.1

Search This thread


Senior Member
Jun 28, 2018
OnePlus 8 Pro
Xiaomi Mi Pad 5
Ah. I could give that a try. The better question then, is there a way with root to make this change permanent? I recall that removing the SIM card or applying a system update undoes the changes to that XML file.

Additionally, can you elaborate on the "setprob sys.usb" part? I'm not sure what you'd mean by that since yeah we do now lack EngineerMode.
No idea how to make it permanent.

adb shell -> su -> setprob command
I don't recall what the command is exactly but try this: https://forum.xda-developers.com/t/diag-mode-qpst-functionality.4247843/post-85536271

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    This is probably for my own reference more than anyone else but this is the process I followed (step by step) for successful safety net attestation, MindTheGapps (for those that want to get away from google), and Location services provider:
    1) Download Latest L18.1 build from Luk1337 (https://www.androidfilehost.com/?w=files&flid=320828)
    1a) Unzip the build to some folder-DON'T DELETE THE ZIP FILE (probably be good to rename that Zip file "LineageOS18.zip")
    2) Download ADB/platform tools on computer (https://www.xda-developers.com/install-adb-windows-macos-linux/)
    3) Start phone and make sure it is on the appropriate Android OS version (for this version of lineage it should be 11)
    3a) If you are not on the correct version of android you need to update through your standard (Stock Rom) to the latest version (for oneplus 8 pro OxygenOS you can just click through the update prompts in settings and then you should be updated to Android 11)
    4) Enable developer settings (read the article on how to install ADB-it shows you how to enable dev settings)
    4a) Allow USB debugging (again refer to the guide above)
    4b) Allow OEM unlock (
    5) connect usb to phone/computer and ensure device is recognized by typing "adb devices" in the command prompt of the computer
    6) Type "adb reboot bootloader"
    6a) Verify that your computer recognizes your fastboot device-type "fastboot devices"
    6b) If your computer doesn't recognize then you need to manually select the driver for the android device in your device manager->universal serial bus device (https://visualgdb.com/KB/usbdebug-manual/) sorry if you run a mac
    7) Unlock the bootloader-type "fastboot oem unlock" (

    **Probably should reboot here if you want just to be safe and make sure you didn't mess up the bootloader unlock process/android version update**

    8) In the bootloader, you need to flash the LOS recovery.img found in that unzipped folder from step 1a-make sure you have the path to the recovery.img file correct! (if you need to get back to bootloader cause you rebooted just fire up that powershell/command line, connect the phone, and type "adb reboot bootloader") type "fastboot boot 'some/folderpath/tofile/recovery.img'"
    9) From the recovery menu you use the volume buttons to navigate (and power button to select) Factory reset -> Format data/factory reset -> Format data
    10) Then navigate and select Advanced -> Enter fastboot
    11) TIME TO INSTALL THE ROM!! Remember that ZIP file you downloaded way back in step 1? You'll need to grab that zip file path and use it for this command-type "fastboot update 'some/folderpath/tofile/LineageOs18.zip'"


    12) Should you choose to continue you will have to go through the setup(I recommend skipping through all the setup stuff if you can) on the phone and make sure you have MindTheGapps downloaded (http://downloads.codefi.re/jdcteam/javelinanddart/gapps)
    13) On the phone reenable developer settings and USB debugging. open powershell, connect phone and type " adb reboot recovery"
    13) Once in recovery use your volume/power keys to navigate to Apply update->Apply from ADB (this activates ADB Sideload)
    14) Once in sideload mode simply type "adb sideload 'some/folderpath/tofile/MindTheGapps.zip'"
    15) Once mindthegapps is installed then you can back out of the adb update menu and select "Reboot System now"


    16) For safety attestation (the ability to use google service framework required apps like Banking or Pokemon go) you can install Magisk (I am sure there are other ways but I did it this way). From your phone browser-download Magisk-v22.apk (https://github.com/topjohnwu/Magisk/releases) and install (you should be prompted if you want to install from unknown sources-just click yes and install)
    17) I will now just follow the installation guide from magisk (https://topjohnwu.github.io/Magisk/install.html)
    18) Connect phone and copy the boot image to your device. This is found in that unzipped folder from step 1a-the file is boot.img
    19) Press the Install button in the Magisk card
    20) Choose “Select and Patch a File” in method, and select the stock boot.img that you just copied
    21) The Magisk app will patch the image to [Internal Storage]/Download/magisk_patched_[random_strings].img
    22) Copy the patched image to your PC with ADB "adb pull /sdcard/Download/magisk_patched_[random_strings].img" (or you can just navigate to the file from your computer and place it somewhere you can find-you'll need to use this soon)
    23) Reboot to fastboot "adb reboot bootloader"
    24) Flash the patched boot.img file you copied to your computer "fastboot flash boot /path/to/magisk_patched.img"
    25) Reboot
    26) Open the magisk manager app that now has root access and click settings->enable magisk hide
    27) From your phone browser download the magisk module "Universal SafetyNet Fix" to force SafetyNet to use basic evaluation (https://github.com/kdrag0n/safetynet-fix)
    27a) In the magisk app go to modules (looks like a puzzle piece)->install from storage and select the Zip file you just downloaded (don't reboot just yet-simply use your back button at this point)
    27b) Add the magisk module "MagiskHide Props Config" from the Magisk repo (click the little magnifying glass)
    27c) Install some command line interface on the phone (I used Termux-https://termux.com/)
    28) Reboot ->open termux and follow the instructions from MagiskHide Props Config
    28a) in termux type "su" then "props"
    28b) edit the device fingerprint (1)->pick a certified fingerprint (f)->Oneplus(21)->Oneplus 8 pro europe IN2023 (40)->Android version 11 (2)->confirm (y) and then reboot
    29) Once your device restarts open the Magisk manager. There should be a button for "Check safetynet". Click it. You should see a "success" message

    ***At this point you have installed a custom rom with a minimal Gapps package, rooted your phone, and configured it to pass safetynet. This means you can now use all apps without restriction. I recommend installing Amazon App store, Aurora App store/Aurora services magisk module, and FDroid app store to get all the apps you need without providing a google account. IF YOU DON'T WANT LOCATION SERVICES YOU CAN STOP HERE***

    30) On your phone-download UnifiedNlp.apk from microg (https://microg.org/download.html). Do not install!
    31) In the magisk app module repository you can search and add the "App systemizer (terminal emulator)"
    31a) I also added the Magisk Module "Busybox for Android NDK" but I am not sure if this is required
    32) From Fdroid (or wherever) install (at a minimum) the MozillaNlpBackend, NominatimNlpBackend
    32a) you can optionally install SatStat (to check all your location data)
    33) In termux type "su" and then "systemize". Select "Systemize given APK (3)"
    34) If your browser default download location is the download folder then simply type /sdcard/download/unifiednlp.apk
    35) restart your phone
    36) Open the unifiednlp app and select "configure backends". You should see Mozilla locations service here. Check it
    37) Select "configure address lookup backends" and select "Nominatim"
    38) Select "self check" and Allow permission to access approximate location (I would suggest all the time but that is your choice).
    39) In phone settings->location make sure "use location" is on.
    40) Open sat stat (and give location permission). You should se a bunch of red and blue dots on a compass. You should now have location services. If you don't....sorry....

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    Hey is this rom maintained by official Lineage OS team?
    Yeah, a team of one person - me.
    Not technical enough to follow 4 easy steps...
    Berating neophytes is not a good look.
    I am sorry that you feel I am not giving you enough info to help me and might be following the wrong device model? I can assure you I am. 5. In the instructions wiki it says to flash recovery-recovery.img to your phone before proceeding and that is what I am trying to do. If you don't want to help me this is fine but please give me the exact cmd to get recovery on my device for the 8 pro though I am pretty sure I am already. Thx, Kevin
    Dear sir, please take a look at the attached image.