[ROM][OFFICIAL][kebab][11] LineageOS 18.1

Search This thread

LuK1337

Recognized Developer
Jan 18, 2013
8,575
17,188
Samsung Galaxy S III I9300
Moto G 2014
2okPze5.png


LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
Downloads :
Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:

Did you--
wipe:
restore with titanium backup:
reboot after having the issue:

Are you using--
a task killer:
a non-stock kernel:
other modifications:

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
 
Last edited:

sharkie405

Senior Member
Dec 22, 2008
2,771
1,887
Earth
Oh snap! LuK got an 8T! It's on! Much love and thank you! Will be flashing this weekend.

Sent from my OnePlus8T using XDA Labs
 
Last edited:

card13

Senior Member
Nov 27, 2008
414
124
32
Washington State
OnePlus 3T
OnePlus 5
Has anyone been able to get root working? Booting a manually patched boot.img (using canary magisk) gives me a Qualcomm Crash Dump Attempted to kill init! exitcode=0x0000000b do_exit. I need any way to run root long enough to restore my apps.

As for what has been tested and worked: WiFi, 5G, calls on 5G.
 
Last edited:
  • Like
Reactions: amplatfus

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Yea this is interesting. Maybe we can try to pinpoint things we have in common. What is your 8T device model, firmware model and version, etc? I downgraded my YouTube version to the last v16 version and it seems to have helped somewhat, although it's not completely gone (and this could be placebo effect, I'm not sure).

    I tried rewinding and replaying the video/audio when these drops/boosts occur, and it seems like it is occurring with the same pattern each listen, so I don't think this is some semi-random effect of another installed app interfering with the audio.
    I'm currently on a KB2000 on 11.0.13.13.KB05AA, but I wouldn't pay too much attention to that since this has been an issue for me since this ROM was first released. I've been back to it 3 times in the hope the issue was magically fixed, but alas no. So long story short, it's not firmware specific.

    It's also not Youtube specific for me, so I'm convinced you're right about the placebo effect. If I download a video from Youtube (using an external program) I experience the exact same issue when playing that video in VLC (or MXPlayer) and for me that points to something in the audio signal path. It's definitely something related to either auto-volume leveling or audio compression. Something designed to prevent sudden loud noises that's overcompensating.

    But yeah, it is really annoying and a dealbreaker for me. It's such a hassle to return to stock that I'm not going down the road of installing this again. Just wanted to add a +1 to your comment in the hope it helped it get noticed.

    Don't try Lineage Microg or CalyxOS builds either in the hope it'll be better-- They have the exact same issue. Just giving you a heads-up there.
    i had the same problem. I read somewhere that Dynamic Range Control could couse these issues and confirmed that it was active on the build for oneplus 8t. After i flashed this : https://github.com/Magisk-Modules-Alt-Repo/drc-remover which set drc to disabled, my issues with speaker volume is gone!
    3
    That's unbelievable! I felt like I searched *every* corner of the internet for a resolution, but never came across this. Thanks for the tip :)
    Does that actually work? If so, I can apply it to 18.1 builds. Hopefully, disabling DRC won't be necessary with android 12 stack.
    2
    2. When playing audio through the phone speakers (eg. YouTube videos, podcasts), the volume will often drop and shoot up wildly even though the phone volume setting is not changing, and the peak volume is far louder than it should be given the volume setting. It seems to drop in volume more often during quiet parts of the audio. These issues do not occur when using other speakers (eg. Bluetooth), and it is not responsive to turning off AudioFX settings. This is the biggest annoyance for me so far and I'm not sure where to start to fix it

    I also have this exact issue with this, and every other Lineage based ROM for the 8T. It's almost like an audio compressor with a slow release and yeah, it makes watching videos extremely difficult. I had to revert back to stock but I keep visiting this thread hoping it might get noticed and fixed.

    I posted about this a few pages back but it never gained any traction. There must be something that causes it to happen only on certain devices, because it's impossible to miss if you consume media using your phone speakers.
    2
    Not sure if its me but todays build seems to have sorted out the auto brightness problem.
    2
    After flashing lineage,my oneplus 8t only the main camera and the front camera can work well , other cameras all doesn't work,is there any way to use other cameras?

    Gcam is your best bet.


    Read the first post well because there are notes on which packages that can use all the sensors.
  • 45
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    11
    tomorrow afternoon 3 p.m 😆
    More like few weeks after OOS12 kernel source is out.
    10
    Yaay. The thread is back. :D
    5
    How do you do backups? What would be a good way to keep backups if I wanted to flash this ROM on a semi daily basis? I noticed after flashing the ROM it asks if I want to restore from a backup.

    Another observation as I flashed the GMS version last night is there was no gallery app. Maybe this is normal.

    I would suggest Swift Backup. Was a titanium user, but I find Swift Backup to be better performing on Android 11.
    5
    Yea this is interesting. Maybe we can try to pinpoint things we have in common. What is your 8T device model, firmware model and version, etc? I downgraded my YouTube version to the last v16 version and it seems to have helped somewhat, although it's not completely gone (and this could be placebo effect, I'm not sure).

    I tried rewinding and replaying the video/audio when these drops/boosts occur, and it seems like it is occurring with the same pattern each listen, so I don't think this is some semi-random effect of another installed app interfering with the audio.
    I'm currently on a KB2000 on 11.0.13.13.KB05AA, but I wouldn't pay too much attention to that since this has been an issue for me since this ROM was first released. I've been back to it 3 times in the hope the issue was magically fixed, but alas no. So long story short, it's not firmware specific.

    It's also not Youtube specific for me, so I'm convinced you're right about the placebo effect. If I download a video from Youtube (using an external program) I experience the exact same issue when playing that video in VLC (or MXPlayer) and for me that points to something in the audio signal path. It's definitely something related to either auto-volume leveling or audio compression. Something designed to prevent sudden loud noises that's overcompensating.

    But yeah, it is really annoying and a dealbreaker for me. It's such a hassle to return to stock that I'm not going down the road of installing this again. Just wanted to add a +1 to your comment in the hope it helped it get noticed.

    Don't try Lineage Microg or CalyxOS builds either in the hope it'll be better-- They have the exact same issue. Just giving you a heads-up there.
    i had the same problem. I read somewhere that Dynamic Range Control could couse these issues and confirmed that it was active on the build for oneplus 8t. After i flashed this : https://github.com/Magisk-Modules-Alt-Repo/drc-remover which set drc to disabled, my issues with speaker volume is gone!