• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][kebab][11] LineageOS 18.1

Search This thread

Pelagius73

Member
Apr 6, 2009
5
1
hello, excuse me my english is not very good. I have a problem with the slide button and it is that when I go up or down if the profile changes but the sound is still active and I have to manually put the vibrator on. Is there any way to fix it? Thank you so much
can i to do? any idea? thanks. Other cuestion, i don't connect to wifi 5 GHz, somebody know how can this solution? thanks
 

LeDiable

Senior Member
Feb 18, 2010
307
116
Mumbai
@LuK1337 There are reports of newer devices having LPDDR5, would buyers of a new device have issues with the ROM due to this silent manufacturer upgrade?
Has the ROM incorporated this change to prevent any probable issues?


 
  • Like
Reactions: Lz3807775t

LuK1337

Recognized Developer
Jan 18, 2013
8,469
16,913
Samsung Galaxy S III I9300
Moto G 2014
  • Love
Reactions: LeDiable

batpoil

Senior Member
Jun 27, 2018
69
9
Guys I was going to get he Mclaren 7T but there's a sale for the 8T at the same price. Can someone confirm me that everything works fine on LOS? Namely the root with magisk and banking apps, and the quality of the camera? Thanks a lot!
 
  • Like
Reactions: Lz3807775t

zBear

Senior Member
Oct 1, 2008
316
159
Chisinau
everything works fine on LOS?
no
I have a problems with autobrightness, fingerprint accuracy and several other issues

root with magisk and banking apps, and the quality of the camera
root is ok (via LOS recovery or TWRP)
no problems with banking apps also, Magisk Hide + safetynet-fix
camera depends on you, you have to test several of Google cameras and choose one

I'm not using LOS right now
comparing to my previous phone, LOS quality for this model is below average
 

OhioYJ

Senior Member
Feb 25, 2011
1,523
769
Guys I was going to get he Mclaren 7T but there's a sale for the 8T at the same price. Can someone confirm me that everything works fine on LOS? Namely the root with magisk and banking apps, and the quality of the camera? Thanks a lot!

I've been running LOS since day one, no issues. Great battery life as well. I unlock mine with the fingerprint sensor all the time, even have a screen protector on it, no issues. All my devices are rooted, on the 8T, still have L1, passes safety net. Banking apps work if you use them. The LOS camera... Well It's like all LOS builds, it's so-so. It works. You'll want to install GCam. I mention the one I prefer in this post.

Hello. Although it is not root, it gives root warning in banking applications. how do i solve this problem. I'm using LOS

Only way I know is to Root. See section 5 and 6 in my Installing LOS Guide. That's how I make them work.
 

OhioYJ

Senior Member
Feb 25, 2011
1,523
769
dpsetting.jpg


I've noticed changing the smallest width setting affects the fingerprint sensor. If I increase this value the fingerprint sensors effectiveness goes down. Shouldn't these two things be unrelated? Essentially why does the fingerprint sensor care what "resolution" the screen is?

Change that value to 600, you'll see what I mean. (600 happens to be the value many apps change over to "tablet" mode in case you were wondering why I would change this value anyways)
 

badsleep

Member
Aug 5, 2021
7
0
Does anyone got GPS working? Whatever I tried (PSDS and/or time data injection, setting exclusive permissions via adb shell pm grant or factory reset) so far doesn't get it to work with OsmAnd.
 

OhioYJ

Senior Member
Feb 25, 2011
1,523
769
I do get satellites listed on GPS Test but I don't intend to use GoogleMaps.

Does GPS Test get a lock or just see satellites? On devices with issues (doesn't necessarily mean hardware issues, can be software), it will see satellites, but never get a lock. In that case none of the other functions will work. (Like the speedometer).
 

badsleep

Member
Aug 5, 2021
7
0
Does GPS Test get a lock or just see satellites? On devices with issues (doesn't necessarily mean hardware issues, can be software), it will see satellites, but never get a lock. In that case none of the other functions will work. (Like the speedometer).
It doesn't get a lock. So in this case I should flash something else or even go back to stock?
 

firegate22

Senior Member
Apr 11, 2014
67
25
dpsetting.jpg


I've noticed changing the smallest width setting affects the fingerprint sensor. If I increase this value the fingerprint sensors effectiveness goes down. Shouldn't these two things be unrelated? Essentially why does the fingerprint sensor care what "resolution" the screen is?

Change that value to 600, you'll see what I mean. (600 happens to be the value many apps change over to "tablet" mode in case you were wondering why I would change this value anyways)
Interesting! I am fairly new to the device, having problems with FP (right now other rom) and changed that setting. What's the standard (and best?) value?

Any idea if this happens as well with overall "size" / dpi settings?
 
  • Like
Reactions: Lz3807775t

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Annnnd the latest LineageOS update just broke Magisk, tried flashing Magisk patched boot.img and phone is bricked.

    Wow. Another close to 30 hours lost setting up this phone thanks to bricking between LineageOS and Magisk.

    Does anyone know of a guide on how to create my own image after configuring my phone? I need to create a gold image of my phone's entire existence (profiles, apps, configurations, contacts, etc..).

    Seems like this is normal and coming from Apple, I'm not sure I can handle doing this bricking stuff once again. My tolerance is nill at this point.

    Well it didn't break anything for me. I have Magisk installed on LineageOS 18.1 and it works great.

    And to be honest, your tone is somewhat annoying and disrespectful. If you are happy with Apple then great, go back to Apple.

    Or maybe you could try something less intellectually demanding, like say ... knitting.
    2
    @LuK1337
    Re-posting this since it looks like it may not have been seen.

    I've seen this glitch for awhile and avoided to post it till things got pretty stable. The Network traffic monitor appears to be in a fixed location (sure you can auto-hide but I find that is an unreliable fix), which causes other indicator icons to show behind it. Meaning when the right side of the Status Bar fills then Network traffic monitor doesn't shift positions dynamically, it stays in place and everything else goes behind it.

    There used to be a setting to resize it or move it around. Is it possible to re-add some of it's movability without installing things like GravityBox or another ROM?
    I read all posts in my threads, if I don't reply to one it means I didn't want to, or I had no good (or funny in some cases) answer to it.
    1
    To pass SafetyNet you need the Magisk Hide Props Config module.

    With the camera I have no problem. Now I use this version: https://www.celsoazevedo.com/files/android/google-camera/dev-greatness/f/dl5/3/

    Do you have the Google Photos application installed?
    Yeah, I have Magisk Hide Props Config - unfortunately out of the box, still unable to pass Safety Check.

    So I decided to install Google Photos , after your post, and restricted (via XPrivacyLua) the entire app except for Use Camera.

    Thank you so much for the tip on google photos.. never crossed my mind!
    1
    Annnnd the latest LineageOS update just broke Magisk, tried flashing Magisk patched boot.img and phone is bricked.

    Wow. Another close to 30 hours lost setting up this phone thanks to bricking between LineageOS and Magisk.

    Does anyone know of a guide on how to create my own image after configuring my phone? I need to create a gold image of my phone's entire existence (profiles, apps, configurations, contacts, etc..).

    Seems like this is normal and coming from Apple, I'm not sure I can handle doing this bricking stuff once again. My tolerance is nill at this point.
    I use TWRP to backup my system. See https://forum.xda-developers.com/t/...ect-8t-kebab-2021-09-04.4302449/post-85422489
    1
    @LuK1337 I have an external drive formated BTRFS that I am trying to use - any chance you could compile the kernel with BTRFS turned on?
    It doesn't really make much sense to do so. LineageOS doesn't support mounting POSIX file systems automatically, so it'd only be useful from a rooted shell, if you mount it yourself that is...
  • 37
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    9
    Yaay. The thread is back. :D
    5
    How do you do backups? What would be a good way to keep backups if I wanted to flash this ROM on a semi daily basis? I noticed after flashing the ROM it asks if I want to restore from a backup.

    Another observation as I flashed the GMS version last night is there was no gallery app. Maybe this is normal.

    I would suggest Swift Backup. Was a titanium user, but I find Swift Backup to be better performing on Android 11.
    4
    You could try to run fastboot --version and ./fastboot --version in your platform-tools directory and compare the output.

    Adding ./ did it. Thanks! :cool:

    IMG_20210228_102128.jpg
    4
    Oh I know. Was just checking to see if it was installed in the ROM by default. Some LOS roms have them installed. I'm going to assume that they aren't and if I want to flash I can.

    Appreciate the help
    Official builds never ship with gapps.