• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][kebab][11] LineageOS 18.1

Search This thread

BillGoss

Senior Member
Sep 2, 2010
4,739
4,163
Sydney
OnePlus 3T
OnePlus 8T
Sorry If I am asking a lot of question. But where do I flash twrp exactly? Slot A or B? I'm still getting the hang of this new A/B mechanics.
So this is like a quick run up of what I know to do so far. Let me know if this is fine:
• once bootloader is unlocked, flast twrp in recovery using fastboot(not sure what slot and whether temporary or permanent)
• flash LOS, mindthegapps and magisk (still not sure what slot but I'm guessing the slot where I flashed twrp?)
All your question in the TWRP thread. How to use TWRP doesn't really belong in this Los 18.1 thread.
 

azoller1

Senior Member
Aug 4, 2011
1,848
1,751
My Room
OnePlus 8T
Might be a strange place to ask this, but has the fingerprint been working for people on recent builds? I built Sakura rom recently, they use lineage as a base with the device trees and vendor trees, so I assume something may be wrong within Sakuras own source. I would assume if fingerprint is working on lineage, then it should work on Sakura as the trees are similar. Sorry if this seems off-topic.
 

OhioYJ

Senior Member
Feb 25, 2011
1,529
778
Might be a strange place to ask this, but has the fingerprint been working for people on recent builds? I built Sakura rom recently, they use lineage as a base with the device trees and vendor trees, so I assume something may be wrong within Sakuras own source. I would assume if fingerprint is working on lineage, then it should work on Sakura as the trees are similar. Sorry if this seems off-topic.

Yes. I've been updating every week, fingerprint sensor is working fine.
 
  • Like
Reactions: azoller1

Grin59

Senior Member
Sep 5, 2018
607
209
OnePlus 8T
Might be a strange place to ask this, but has the fingerprint been working for people on recent builds? I built Sakura rom recently, they use lineage as a base with the device trees and vendor trees, so I assume something may be wrong within Sakuras own source. I would assume if fingerprint is working on lineage, then it should work on Sakura as the trees are similar. Sorry if this seems off-topic.
Lineage is the only rom that had a working fingerprint right away, other roms I tried didn't work. Had to do the restore persist.img deal, after that didn't work I tried just about everything else I could think of and nothing worked.
 
  • Like
Reactions: azoller1

thekubiaks

Senior Member
Nov 3, 2012
78
21
Got a question please, I'm not a newb so please be nice. I am new to a rooted LineageOS on my OP8T. I noticed that when Lineage comes out with a new nightly build it wants me to install it. Do I need to sideload the same img file for it to work properly? Will it kill my root and do I have to reload Magisk?? Thx
 

card13

Senior Member
Nov 27, 2008
398
113
31
Tacoma
OnePlus 3T
OnePlus 5
I've seen this glitch for awhile and avoided to post it till things got pretty stable. The Network traffic monitor appears to be in a fixed location (sure you can auto-hide but I find that is an unreliable fix), which causes other indicator icons to show behind it. Meaning when the right side of the Status Bar fills then Network traffic monitor doesn't shift positions dynamically, it stays in place and everything else goes behind it.

There used to be a setting to resize it or move it around. Is it possible to re-add some of it's movability without installing things like GravityBox or another ROM?
 

Attachments

  • Overlapped.png
    Overlapped.png
    43.5 KB · Views: 77
  • Non-Overlapped.png
    Non-Overlapped.png
    42.9 KB · Views: 76

squirrelsenpai

New member
Aug 27, 2021
2
0
OnePlus 8T
Flash fails ErrorCode 7

To reproduce:
1. OTA update to 10.10
2. Enable USB debugging
3. ADB reboot bootloader
4. fastboot flash 20210826 recovery
5. Reboot to recovery
6. Update via ADB copy partitions
7. Reboot to recovery
8. Format data
9. Reboot to recovery
10. Update via ADB lineageos image (failed)

Weirdly when I first tried this i forgot copy partitions and it flashed fine(fingerprint reader didnt work though). Then flashed the latest OTA, since then I tried following the instructions exact and it failed. Any help much appreciated.
 

NewUsar

Member
Feb 7, 2015
17
0
I have a question, actually two, but they are somehow related.

I installed Lineage on my 8t and at the beginning it would wake the screen for notifications, I found the settings for what to show on the lock screen (not showing sensitive information), that's the only option I changed as far as I remember. Nevertheless, after a day or so, the screen would stop from waking up when a message's received, but when I wake up the screen manually the notifications are there. I don't remember having changed anything but might have done that unknowingly. I didn't install any Lineage update, so that's definitely not a reason. Anyone can tell me what would have to be activated so that the screen would wake up when a message is received e.g.? I seem too stupid to find it in the settings. (I've had a phone with a notification led before, so this option is new to me.)

Second question related to it: is there anything that can be changed/installed so that the notifications on the lock screen would be in a simple black and white instead of the usual colors of the app? I'd fancy an all black lock screen where notifications would fit into that. But I have no idea what to look for if one wants such thing.
 
Last edited:

OhioYJ

Senior Member
Feb 25, 2011
1,529
778
Flash fails ErrorCode 7

To reproduce:
1. OTA update to 10.10
2. Enable USB debugging
3. ADB reboot bootloader
4. fastboot flash 20210826 recovery
5. Reboot to recovery
6. Update via ADB copy partitions
7. Reboot to recovery
8. Format data
9. Reboot to recovery
10. Update via ADB lineageos image (failed)

Weirdly when I first tried this i forgot copy partitions and it flashed fine(fingerprint reader didnt work though). Then flashed the latest OTA, since then I tried following the instructions exact and it failed. Any help much appreciated.

You have some extra reboots in there. LOS Instructions , don't know for sure that's your problem. The instructions don't have one after formatting data?
 

ccic2491

Senior Member
Jun 3, 2012
245
38
Charlotte
Running the latest build here with Magisk, no problems. Update every week and sideload Magisk. Are you sure ADB and Fastboot are up to date on your PC? You are sideloading LOS, rebooting to recovery, then trying to sideload Magisk right?
I installed an older version and then updated to the newest version through the Magisk app. Worked like a charm but I'm still not sure why I couldn't just install the newest version 🤷
 
Aug 31, 2021
34
4
I have been using LineageOS 18.1 on my 8T for ten days. I installed version 0422 following the instructions on the wiki (https://wiki.lineageos.org/devices/kebab/install). I updated to version 0429 via the built-in update app. And yesterday I updated to version 0506 also via the built-in update app, without any problem. Magisk remains, the same as the three modules I use: ACC, Webview Manager, and Props Config.

The device charges from 15 to 80% in twenty minutes. And I get at least five or six hours of screen time. According to Franco Kernel Manager: Active drain 7% per hour; Idle drain 0.4% per hour.

The fingerprint reader works really fast. As a camera app I am using GCam 7.3 (https://www.celsoazevedo.com/files/android/p/google-camera-oneplus-8-series/) and it works great. With the help of Magisk, I passed the SafetyNet test. And the device reaches security level L1 on Widevine.

The only problem I've found for now is that the device's Wi-Fi doesn't automatically turn on when I get home. I don't know if anyone else has this same problem and if anyone knows any solutions.

A huge thank you to the LineageOS team for their wonderful work.
I don't mean to go off topic...

But how did you manage to get SafetyNet to pass?

And GCam, when you take a picture or video and you click on the picture or video, does the viewer not crash to a black screen? I can take pictures and videos just fine, but I can't view what I just recorded/took a picture of directly from the GCam app. It goes to a black screen. I have to open the gallery app to view the images/videos.

My device info:

Device: OnePlus 8T (KB2003)
Android Version: 11
OS: LineageOS for microG 18.1 (Kebab)
Magisk Version: 23.0 (23000) (21)
Installed: f822ca5b (23001)
 

ivanperezcaro

Member
Feb 13, 2018
48
16
Utrera
Google Nexus 5
Nexus 6
I don't mean to go off topic...

But how did you manage to get SafetyNet to pass?

And GCam, when you take a picture or video and you click on the picture or video, does the viewer not crash to a black screen? I can take pictures and videos just fine, but I can't view what I just recorded/took a picture of directly from the GCam app. It goes to a black screen. I have to open the gallery app to view the images/videos.

My device info:

Device: OnePlus 8T (KB2003)
Android Version: 11
OS: LineageOS for microG 18.1 (Kebab)
Magisk Version: 23.0 (23000) (21)
Installed: f822ca5b (23001)
To pass SafetyNet you need the Magisk Hide Props Config module.

With the camera I have no problem. Now I use this version: https://www.celsoazevedo.com/files/android/google-camera/dev-greatness/f/dl5/3/

Do you have the Google Photos application installed?
 
Aug 31, 2021
34
4
To pass SafetyNet you need the Magisk Hide Props Config module.

With the camera I have no problem. Now I use this version: https://www.celsoazevedo.com/files/android/google-camera/dev-greatness/f/dl5/3/

Do you have the Google Photos application installed?
Yeah, I have Magisk Hide Props Config - unfortunately out of the box, still unable to pass Safety Check.

So I decided to install Google Photos , after your post, and restricted (via XPrivacyLua) the entire app except for Use Camera.

Thank you so much for the tip on google photos.. never crossed my mind!
 
  • Like
Reactions: ivanperezcaro
Aug 31, 2021
34
4
Hey guys,

Forgive my ignorance, still trying to learn how to navigate through XDA forum board.

I have two identical OnePlus 8T devices running LineageOS 18.1 for microG (kebab).

One of them I've been using as a source device, setting it up in a specific manner to meet our needs.

However, I can't find a reliable cloning app that will clone from the source 8T to the target 8T device.

Think of creating a gold image for Windows and then using that Gold image to clone or image a workstation. That's the goal, so that both devices have the same base, apps and configuration and from there we will back up our devices anytime we make our own exclusive/unique changes to our devices.

My original thought is to back up the source 8T using Titanium Backup and then install Titanium Backup onto the target 8T (fresh installation of LOS 18.1 for mIcroG) and restore the backup through Titanium Backup onto the target 8T.

This information is identical for both devices:

Device: OnePlus 8T (KB2003) Android Version: 11 OS: LineageOS for microG 18.1 (Kebab)

Can someone recommend a good cloning solution?

And if this is in the wrong forum section, my apologies, I'm new and still trying to understand the structure of this forum board.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 37
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    9
    Yaay. The thread is back. :D
    5
    How do you do backups? What would be a good way to keep backups if I wanted to flash this ROM on a semi daily basis? I noticed after flashing the ROM it asks if I want to restore from a backup.

    Another observation as I flashed the GMS version last night is there was no gallery app. Maybe this is normal.

    I would suggest Swift Backup. Was a titanium user, but I find Swift Backup to be better performing on Android 11.
    4
    You could try to run fastboot --version and ./fastboot --version in your platform-tools directory and compare the output.

    Adding ./ did it. Thanks! :cool:

    IMG_20210228_102128.jpg
    4
    Oh I know. Was just checking to see if it was installed in the ROM by default. Some LOS roms have them installed. I'm going to assume that they aren't and if I want to flash I can.

    Appreciate the help
    Official builds never ship with gapps.