• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][kirin][10] LineageOS 17.1

Search This thread

munjeni

Senior Member
Jun 2, 2011
9,443
22,041
I didn't really patch anything. I just noticed that unlocked Android 9 stock rom had L1 out of box so I just copied blobs required to support L1 that I previously omitted to Lineage.

( also no, copying these blobs from A9 won't fix it on A10. Something in firmware just locks out L1 keys. )
So I need to flash bootbundle
and some more e.g. diag, persyst, vendor?
And need to replace oemcrypto lib, do I need any more libs? Please I need precise info if possible, its so simple giving me git status output or giving me link to your commit.
 

LuK1337

Recognized Developer
Jan 18, 2013
8,473
16,932
Samsung Galaxy S III I9300
Moto G 2014
So I need to flash bootbundle
and some more e.g. diag, persyst, vendor?
And need to replace oemcrypto lib, do I need any more libs? Please I need precise info if possible, its so simple giving me git status output or giving me link to your commit.

>So I need to flash bootbundle
>and some more e.g. diag, persyst, vendor?
>And need to replace oemcrypto lib, do I need any more libs? Please I need precise info if possible, its so simple giving me git status output or giving me link to your commit.
I have no idea which exact partitions you need to flash, I can only promise that you don't need to replace anything in 'boot', 'system', 'vendor' since:
- if i flash whole android P stock then copy-partitions + lineage I get L1
- if i flash whole android Q stock then copy-partitions + lineage I get L3

Also unmodified Android P stock gives me L1 too.
 
Last edited:
  • Like
Reactions: mirhl and munjeni

munjeni

Senior Member
Jun 2, 2011
9,443
22,041
Thats realy ineresting! But I dont know which libs to copy, can I get list please? Or I not need libs, just need to flash whole stock 9 rom and install lineage on top of it and I get L1?
 
Last edited:

munjeni

Senior Member
Jun 2, 2011
9,443
22,041
Thats interesting! I'm believing its related to bootbundle which have bug in xbl/abl probably

Edit;
got you, thanks for info!
Yes I can confirm this. Flashing bootbundle from android 10 on top of android 9 gives L3 level! I will try with android 10 and bootbundle from android 9, I'm believing it will bring L1 on android 10, let see

Edit:
Yes, I can confirm L1 on zndroid 10 too!
 
Last edited:

freebench

New member
Aug 17, 2020
1
0
sim no service

Device model is I4113

The issue is that both sim cards shows no service.

Originally I faced it when put both sim cards in. It seemed like constant loop one sim showed service - second no service and vice versa all the time. In the same time WiFi connection is lost and established.
I managed to defeat the thing by tweaking the "Preferred network type" option for both sims. Suddenly it somehow stopped looping.
That state lasted for a week or so. During that week a notification showed up, same as on the screenshot attached, which I ignored as both sim card showed service okay.
Today the service got lost for both sims for good.

All network configuration is being sent by the mobile network provider is being received as usual.

Any idea how to defeat the thing ?

Code:
What is your--
LineageOS version: 17.1
LineageOS Download url: https://mirrorbits.lineageos.org/full/kirin/20200804/lineage-17.1-20200804-nightly-kirin-signed.zip
Gapps version: None
 
Did you--
wipe: yes
restore with titanium backup: no
reboot after having the issue: yes
 
Are you using--
a task killer: no
a non-stock kernel: no
other modifications: no
 
Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

aqxK9oL.png
 
Last edited:

xdauserart

Member
Oct 13, 2020
41
2
Hi! Did anyone installed this ROM on Xperia 10 II, this is with the second mark? Do you think LineageOS will work on this device? I've bought this recently and wish to de-google it.
 

RodMyers

Senior Member
Jun 21, 2011
140
13
upgrade issue

I have use custom ROM’s before, but not since they went to the slot_a and slot_b setup

Something strange is happening during the 10.1 update.

Currently, the lineage rom sits in slot_a, I get the update notice, run through the upgrade, twice so far. When the update reboots the phone, it defaults to slot_b, which evidently has nothing on it, because I get the stock recovery menu.

I have to boot into bootloader(?) mode, holding the volume down button and plugging into computer. With fastboot I can set slot_a, but I then I get the update notice again.

What step(s) did I miss when installing the lineage ROM?

Thanks
 

Plague_CZ

Member
Dec 26, 2009
49
4
Thank you for this working ROM, I have not yet found any problems with it.

The Sony camera is a must, otherwise my pictures are too dark.

Although I do see some missing features, so I'm just asking to confirm that they are missing from the device and/or LineageOS in general (or I'm simply being stupid).

  1. I was using old lineaageos 14.1 on S4 Mini and loved Ambient display, i.e. wake the device after waving my hand over. I cannot find that setting, neither any sort of double tam on wake, though LineageOS 17 reviews show that.
  2. This device stock ROM has single hand mode, does LineageOS drop that?
  3. Originally Sony camera has the typical "circle" with the last photo. It is missing here. I thought it was due to missing the Sony Album app, but I cannot install it directly. Can it be solved by sideloading it (i.e. can you create a package for it)?
 

SethDove

New member
Sep 21, 2021
1
0
DELETED.
I see elsewhere that VoLTE discussion is off the table.
T-mobile ends 2G/3G October 1.
Good luck existing without VoLTE.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][kirin][10] LineageOS 17.1, ROM for the Sony Xperia 10

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2020-02-16
    Last Updated 2020-04-01
    2
    oh btw you might want to use this TWRP for flashing my builds.
    2
    So I need to flash bootbundle
    and some more e.g. diag, persyst, vendor?
    And need to replace oemcrypto lib, do I need any more libs? Please I need precise info if possible, its so simple giving me git status output or giving me link to your commit.

    >So I need to flash bootbundle
    >and some more e.g. diag, persyst, vendor?
    >And need to replace oemcrypto lib, do I need any more libs? Please I need precise info if possible, its so simple giving me git status output or giving me link to your commit.
    I have no idea which exact partitions you need to flash, I can only promise that you don't need to replace anything in 'boot', 'system', 'vendor' since:
    - if i flash whole android P stock then copy-partitions + lineage I get L1
    - if i flash whole android Q stock then copy-partitions + lineage I get L3

    Also unmodified Android P stock gives me L1 too.
    2
    @LuK1337 can you tell me how you patched L3 to L1, is there any git commit or anything which can help me back L1 on this https://forum.xda-developers.com/xp...tloader-53-t4138269/post83160123#post83160123

    I didn't really patch anything. I just noticed that unlocked Android 9 stock rom had L1 out of box so I just copied blobs required to support L1 that I previously omitted to Lineage.

    ( also no, copying these blobs from A9 won't fix it on A10. Something in firmware just locks out L1 keys. )
    1
    With unlocked bootloader on android 9 also give L1? And on lineage on top of stock 9 give L1?
    That's exactly what I just said.