• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][OFFICIAL][lemonadep][11] LineageOS 18.1

Search This thread

apelly

Member
Dec 13, 2009
8
0
Auckland
i can't find anywhere and recommendations for installing nightlies with magisk installed.

due to borking a 7t pro several times by updating with magisk installed I'm hesitant to install the lineage nighty updates on my 9 pro.

LuK1337 would say learn to live without root, but it's too handy for some things.

pointers gratefully received

edit:-

found this: https://www.reddit.com/r/LineageOS/comments/nzkucc
The advice there mimics my googling: all over the place.
 
Last edited:

apelly

Member
Dec 13, 2009
8
0
Auckland
i've found some oddness with antennapod: previewing podcasts is prevented by the error "read only filesystem"
Screenshot_20210715-102100_Trebuchet.jpg


Not sure if this is an antennapod issue or something i screwed up with lineage.

I've seen something similar in another app too... can't remember which though.

Thoughts?
 

acm1108

Senior Member
Jun 10, 2010
144
21
Having an issue receiving Google duo notifications when some tries to call me. Everything else notification-wise seems to be working.

Yes battery optimization for this app is turned off.
 

mgear356

Senior Member
Jun 13, 2008
1,405
165
I was using Nikgapps basic, and I try to adb sideload the full Gapps on LineageOS recovery but there was a problem/bug about full storage and the flash was incomplete. Same with only the Nikgapps AA addon.
I've changed my recovery to TWRP but there was the same problem.
I tried flashing mindthegapp recovery.
Then the dev from Nikgapps told me to set InstallPartition=/system in nikgapps.config and it solved the problem.
I flashed the full package again and now AA is working 👍👍
hey can i check that Android Auto for your vehicle audio unit is working perfectly for 20 Jul Build? Planning to try Lineage
 

Dr. MadMan

Member
Dec 7, 2010
21
1
OnePlus 9 Pro
I did a fresh
flash of 18.1 on my OP9Pro now location services doesn't work. GPS test is OK and app using GPS work OK but all other apps using location services doesn't work. I tried UnifiedNLP, tried Mindthegapps, tried opengapps nothing helps.
 
Last edited:
  • Like
Reactions: andacro

Dhayes99

Member
Nov 15, 2015
21
6
As someone who purchased a 9 (not the pro) and is returning it for the 8t due to the massive overheating issues I am curious on this groups take on the overheating problem on the 9 series. I suspect this does not happen under lineage on the 9 pro since I have not seen any threads. Just curious if you guys think this is related to oos and/or the sd888. I will be loading lineage right out of the box on my 8t tomorrow. But the 9/9 pro is such a nice device and I am a little sad. Just wondering. BTW I would get the 9 pro but I do not like the curved screen and larger size.
 

1NewbieRooter

Member
Jul 22, 2021
8
3
OnePlus 6T
OnePlus 9 Pro
After ROM (custom or official) boot & finishing setup.
enable USB debugging.
Reboot to bootloader
command: fastboot flash modem modem.img
replace modem with tmo one provided then flash, reboot enjoy TMobile service 😂 😊👍
*Flashing dirty KEEPS modem .....
OTA's will ERASE modem and need to be applied again .....

**edit: if non tmo variant then you shouldn't need this guide 🤔👍
This worked perfectly. Thank you!
 
  • Like
Reactions: Libra420T

Umgak

Member
Nov 24, 2017
32
19
Hate to see people writing this off for no warp charge. Sure, it's a bummer, but this is otherwise a fantastic and quite punctual release. I'm sure fast charging will arrive some time in the future. Other than that, everything seems to be working perfectly. Nothing but quality from the LOS crew👍
 
  • Like
Reactions: andacro

clavelm80

Senior Member
Jan 9, 2017
90
17
Annecy
OnePlus 9 Pro
I’ve just update from the 20210615 nightly to the latest 20210720.
My “recent apps” button is not working with this new build.
Am I the only one?
I wait for the 20210727 nightly, but my button was still not working, so I've format the data and the button is back working.
So it was a problem with my conf and not with the LineageOS build.
It's just a pity that not one has responded to my message by saying that the button was working on his system, maybe my question was not understandable?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    So just to be sure EVERYTHING is working fine on t-mobile versions with this?
    I've been running it for about a week now. Everything is fine, including 5G and all the other T-Mobile things
    1
    Love the change log with this build. Keeps improving every day with fixes. Updates are smooth through its updater as well. Will definitely keep. Thank you
    1
    Hi,
    You might try with TWRP, but at first don't forget to sideload the copy-partitions patch from the pre-install instructions on the official Wiki (https://wiki.lineageos.org/devices/lemonadep/install). It's a must to follow all the steps from the Wiki.
    But if you have a partition problem, that's very important to fix it before attempting anything (ie. https://forum.xda-developers.com/t/solve-fastboot-error-the-boot-partition-is-too-smaller.4258251/).
    TWRP worked. Everything seems to be working just fine. Still, don't understand what's happening with lineageos recovery.

    Thanks !
  • 29
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    4
    Anyone know why the builds are still called "nightly" when you're lucky if you get more than one a week now?
    There's always night somewhere in the world during the time they are compiled.
    4
    I noticed something in the wiki instructions. I think there's a mistake in section:
    View attachment 5381189
    To temporarily boot into Lineage Recovery it should be:
    Fastboot boot <recovery_filename>.img
    Please correct me if I'm mistaken @LuK1337
    This is not a mistake.
    4
    Working great on my LE2127. Yes after first flash, you will need to flash tmo modem. Runs great, just can't get gapps to side load...
    You need to flash the MindTheGApps package in this order:
    - Factory reset
    - Flash Lineage OS
    - Reboot to Recovery
    - Flash MindTheGApps
    - Reboot

    Starting Lineage before flashing gapps could cause issues
    3
    I noticed in the wiki that my LE2127 is not on the list of supported OP 9 Pro's. Any reason for this? Thanks
    We only claim to support retail devices. While carrier branded devices will likely work just fine, we don't have instructions for these nor do we guarantee them working.