• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][OFFICIAL][lemonadep][11] LineageOS 18.1

Search This thread

Umgak

Member
Nov 24, 2017
33
19
It always says rapidly charging and 1h24 remaining because OnePlus basically hardcoded everything that AOSP userspace reads to display data on screen.
That's also why I said earlier that I wouldn't trust Ampere on this device and that one should use a real power meter if they want to make sure warp charging is either working or broken.
EDIT: Attached a screenshot with slightly (not really) more info.
Why would they bother hard coding that, I'd prefer no eta over a blatantly wrong one.
 

vangry2020

Senior Member
Mar 18, 2020
80
19
@LuK1337
Can you please help me with this. After launching LOSRecovery.img i tried sideloading copy-partitions.zip file. But i'm getting no devices detected and it's not detected by windows either. I rried "enable adb" in advanced menu (it disappeared afterwards) how do i get my device to be detected?
Appreciate your help.
Did you install Oneplus USB drivers? It's in windows 10 optional updates.
 
  • Like
Reactions: andacro

IamTheBRAVE

Senior Member
I installed them the first time i plugged the OP9p and it was detected in adb up until i rebooted into custom recovery.
I'm on win7 btw.
Edit: SOLVED
My device was listed with a yellow ! under device manager. I updated the drivers like this:
-choose from a list of drivers
-choose oneplus.inc drivers (that i had installed the first time and reinstalled while in LOSRecovery)
-choose Oneplus Android ADB Interface
Device is now detected in LOSRecovery. Proceeded with sideloading Copy-partitions.
I think the problem might come from win7
I Hope this helps somebody.
 
Last edited:

Zenns

Senior Member
Apr 6, 2015
477
148
It nice to see this for this device, the only issue is that bank apps dont really work, It always detected as the Phone is unlocked or not secure, since when the bank apps were, anyway keep up the good work mate, hope in the future someone finds a solution for this bank apps it is annoying as hell
 

EugenStanis

Senior Member

Zenns

Senior Member
Apr 6, 2015
477
148
Screenshot_20210814-085454.jpg



I wonder what model is my Phone it is LE2120 with IND ? I can't even use 5G at all
 

Zenns

Senior Member
Apr 6, 2015
477
148
I wonder if I flash LineageOS will my 5G start working and another issue is my Banking app won't be working at all.. hope the developer can give some feedback
 

Umgak

Member
Nov 24, 2017
33
19
I wonder if I flash LineageOS will my 5G start working and another issue is my Banking app won't be working at all.. hope the developer can give some feedback
If your 5G doesn't work currently, it likely still won't after flashing LineageOS. You can, however, use your banking apps, Google Pay, etc. by using Magisk (be sure to enable MagiskHide in settings!) and MagiskHide Props Config (terminal emulator like Termux required) to spoof the device fingerprint back to the original one from OxygenOS.

It is not* possible to do so without rooting the device however.

* It is actually possible to pass SafetyNet and therefore use banking apps without root, but it's a large amount of development work and isn't really feasible.
 

Zenns

Senior Member
Apr 6, 2015
477
148
UOB mighty detects it from what I know and no idea how they are doing it

And the question why it isn't working ? Is it because I'm on India ROM as compare to the Global or EU Version and why won't flashing LineageOS make my 5G work just puzzle about this.
 

Umgak

Member
Nov 24, 2017
33
19
UOB mighty detects it from what I know and no idea how they are doing it

And the question why it isn't working ? Is it because I'm on India ROM as compare to the Global or EU Version and why won't flashing LineageOS make my 5G work just puzzle about this.
Just did some testing.
UOB Mighty works by detecting an installed package with ID com.topjohnwu.magisk (and possibly others such as SuperSU), as well as looking for the SU binary. It does not check for SafetyNet.

Be sure to add UOB Mighty to the MagiskHide list within Magisk Manager. This will prevent it from detecting the SU binary.
You will also need to go enter Magisk settings and select "Hide the Magisk app". The name you enter in the text field can be anything you want; UOB Mighty does not check this. This will reinstall Magisk Manager under a new package ID so that UOB Mighty cannot find it.
With these two defenses in place, UOB Mighty opens correctly on my device and does not detect root.
 
Last edited:

Zenns

Senior Member
Apr 6, 2015
477
148
Hi

Thanks for helping out did some testing as well but it does not detect at all reason being I'm using stock lineageos recovery with lineageos well this was what I wanted :) so yeah I got what I needed

Only issue is that there isn't any 5G on my Phone which is odd, but my sim card is 5G Enable and we are on n1 network so LE2120 should support it

Maybe the developer can explain more about this unless baseband controls this then I don't know what is wrong at all
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Y'all just gonna let this dude come in here and lie?
    Yes.
    1
    I'm having the same issue. It doesn't seem to cause a problem, just a very minor inconvenience.
    Someone on reddit said that because lineageos is a unified build they put "general" model numbers because all of them basically the same spec units that may have different OEM firmware. Basically, when going back it's important to select proper original OEM firmware but when using lineageos it's not and as long it's supported it'll just work. So no worries and disregard the incorrect model.
    1
    Btw why do you want to switch to LOS? It's not better than LOS. Unlike dead Cyanogenmod, LOS has no any additional features or additions.

    And you are getting worse launcher + worse camera app + some things not working.
    Y'all just gonna let this dude come in here and lie?
    1
    Disclaimer : sorry if this does not work for you ! It works for me but the update is a bit tricky...

    Just a small reminder for people trying to upgrade with TWRP : the LineageOS (both OTA and direct download) WILL reinstall the LineageOS recovery, whatever you tell the system not to do it. So, if your are upgrading, don't forget the following :
    * Place on the internal storage the LineageOS rom, and if you use them, the latest Magisk APK (or the APK renamed to ZIP), and the latest OpenGApps/MindTheGapps. This will prevent you from using adb sideload...
    * Backup everything. I backup data, system, boot... from TWRP and I use ad pull "sdcard" too... :)
    * If you're using Magisk and hiding it by renaming the package, flashing Magisk might be useless ; when you'll reboot, it will say it lost the root and needs to patch a file to root again. If so, try to reinstall the Magisk software from Android, then reflash the APK from TWRP. Once you're back in Android, Magisk should allow you to "direct install (recommended)". Itmight be a good idea to disable the package renaming before updating the system.

    * Update from TWRP only (and not the OTA), because you'll have the option "Automatically Reflash TWRP after flashing a ROM." If you don't, you will have to reflash TWRP using Installation method of the official thread (fastboot boot twrp.img then Flash Current TWRP from Advanced menu) - Reminder : NEVER try to flash anything if you missed the "Decrypt data" prompt...
    * Once done, wipe Dalvik, and reboot to recovery (not system !!!)
    * Flash the Magisk APK/ZIP (I need some help for that point, it makes the root weird)
    * Flash Open GApps or Mind The Gapps if you were using it.
    * Wipe Dalvik, and reboot the system... Hoping it will get you back home safely :)

    If you don't flash Magisk or the GApps, LineageOS will probably not boot.
    Hope this helps !
    1
    Alright, thanks. Then it seems opencamera works fine.

    Can't answer this question. The first thing I do after buying a new phone is los installing :)

    Here are the changes I made for opencamera if somebody is interested: https://github.com/kurnevsky/opencamera-oneplus9pro/commit/cdc76a252dcfc940107862978fed3530aeb3a0cd
    My first thing also :).
    Thank you for modifying opencamera, but I have no plan how to install it.
    Can you explain it :) ?
  • 30
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    5
    Anyone know why the builds are still called "nightly" when you're lucky if you get more than one a week now?
    There's always night somewhere in the world during the time they are compiled.
    5
    Y'all just gonna let this dude come in here and lie?
    Yes.
    4
    I noticed something in the wiki instructions. I think there's a mistake in section:
    View attachment 5381189
    To temporarily boot into Lineage Recovery it should be:
    Fastboot boot <recovery_filename>.img
    Please correct me if I'm mistaken @LuK1337
    This is not a mistake.
    4
    Working great on my LE2127. Yes after first flash, you will need to flash tmo modem. Runs great, just can't get gapps to side load...
    You need to flash the MindTheGApps package in this order:
    - Factory reset
    - Flash Lineage OS
    - Reboot to Recovery
    - Flash MindTheGApps
    - Reboot

    Starting Lineage before flashing gapps could cause issues