• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Development [ROM][OFFICIAL][lemonadep][11] LineageOS 18.1

Search This thread

giaur

Senior Member
Aug 27, 2013
4,079
1,174
Two things that bothers me: charging is slower than on stock OOS (It took me 1 hour to charge 9 Pro from 20 to 100℅ while on OOS device is charged from 0 to 100% in 40 minutes) and device shows me 1 hour and 24 minutes until fully charged all the time while charging
That's because Warp charge is not supported on LOS.
Btw why do you want to switch to LOS? It's not better than LOS. Unlike dead Cyanogenmod, LOS has no any additional features or additions.

And you are getting worse launcher + worse camera app + some things not working.
 

EugenStanis

Senior Member
That's because Warp charge is not supported on LOS.
Btw why do you want to switch to LOS? It's not better than LOS. Unlike dead Cyanogenmod, LOS has no any additional features or additions.

And you are getting worse launcher + worse camera app + some things not working.
Didnt know that warp charge is not supported on LOS. Had no issues with warp on my previous phone which was OnePlus 7T Pro running LOS 17.1 and 18
 
@LuK1337 Sorry to ask you directly but do you (or anyone else) have any idea what I'm doing wrong here?

PS C:\Users\Jay\Desktop\platform-toolz> adb reboot bootloader
PS C:\Users\Jay\Desktop\platform-toolz> fastboot flash boot lineage-18.1-20210914-recovery-lemonadep.img
target reported max download size of 805306368 bytes
sending 'boot' (196608 KB)...
OKAY [ 4.317s]
writing 'boot'...
OKAY [ 0.588s]
finished. total time: 4.936s
PS C:\Users\Jay\Desktop\platform-toolz> adb sideload copy-partitions-20210323_1922.zip
serving: 'copy-partitions-20210323_1922.zip' (~47%) * failed to read command:
PS C:\Users\Jay\Desktop\platform-toolz> adb sideload lineage-18.1-20210914-nightly-lemonadep-signed.zip
serving: 'lineage-18.1-20210914-nightly-lemonadep-signed.zip' (~0%) * failed to read command:
PS C:\Users\Jay\Desktop\platform-toolz>

Getting this and a couple of other errors whenever trying to flash my device since it returned from RMA...

Have tried different cables, 2 Win10 computers and a Ubuntu la[top each time I get errors and have to MSM back to stock and start over...
The first one is normal (stuck at 47% is expected), I had the second problem too but as I remember the recovery was problematic, so I used TWRP.
 
That's because Warp charge is not supported on LOS.
Btw why do you want to switch to LOS? It's not better than LOS. Unlike dead Cyanogenmod, LOS has no any additional features or additions.

And you are getting worse launcher + worse camera app + some things not working.
Had no charging problem. It takes about 40 minutes to charge, but the estimated charging is wrong.
Trebuchet does the work, camera app is supported by non profit people on their free time and almost everything works out of the box. You can change the launcher, the camera app or turn back to OOS easily 😀
 

557953

Senior Member
Jan 4, 2013
330
152
@LuK1337 Sorry to ask you directly but do you (or anyone else) have any idea what I'm doing wrong here?

PS C:\Users\Jay\Desktop\platform-toolz> adb reboot bootloader
PS C:\Users\Jay\Desktop\platform-toolz> fastboot flash boot lineage-18.1-20210914-recovery-lemonadep.img
target reported max download size of 805306368 bytes
sending 'boot' (196608 KB)...
OKAY [ 4.317s]
writing 'boot'...
OKAY [ 0.588s]
finished. total time: 4.936s
PS C:\Users\Jay\Desktop\platform-toolz> adb sideload copy-partitions-20210323_1922.zip
serving: 'copy-partitions-20210323_1922.zip' (~47%) * failed to read command:
PS C:\Users\Jay\Desktop\platform-toolz> adb sideload lineage-18.1-20210914-nightly-lemonadep-signed.zip
serving: 'lineage-18.1-20210914-nightly-lemonadep-signed.zip' (~0%) * failed to read command:
PS C:\Users\Jay\Desktop\platform-toolz>

Getting this and a couple of other errors whenever trying to flash my device since it returned from RMA...

Have tried different cables, 2 Win10 computers and a Ubuntu la[top each time I get errors and have to MSM back to stock and start over...

The first one is normal (stuck at 47% is expected), I had the second problem too but as I remember the recovery was problematic, so I used TWRP.
thanks for replying, but I can flash TWRP, but it wont let me sideload anything, I can do "adb devices" from in TWRP and is fine, I go into Sideload and it can no longer detect my device... Back out of sideload and ADB works again!!!
Really muffed up!
 

russiandivxclub

Senior Member
Feb 5, 2011
297
48
Brooklyn, NY
Quick question guys. I have lineageos installed and I am looking at the model number and it's showing LE2123 in the About PHone section. Problem is that I have OnePlus 9 Pro 5G LE2125 US 256GB 12GB model. So why is it showing an incorrect model number?

Thanks guys!
 

russiandivxclub

Senior Member
Feb 5, 2011
297
48
Brooklyn, NY
I'm having the same issue. It doesn't seem to cause a problem, just a very minor inconvenience.
Someone on reddit said that because lineageos is a unified build they put "general" model numbers because all of them basically the same spec units that may have different OEM firmware. Basically, when going back it's important to select proper original OEM firmware but when using lineageos it's not and as long it's supported it'll just work. So no worries and disregard the incorrect model.
 
  • Like
Reactions: galaxys

giaur

Senior Member
Aug 27, 2013
4,079
1,174
Ok, you want Google's Android without Google. That's the reason I can understand, but I want Google unlike you do.

Btw, Lineage without Gapps is not without Google. You rather want Replicant, not Android, did you know that?

 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Y'all just gonna let this dude come in here and lie?
    Yes.
    1
    I'm having the same issue. It doesn't seem to cause a problem, just a very minor inconvenience.
    Someone on reddit said that because lineageos is a unified build they put "general" model numbers because all of them basically the same spec units that may have different OEM firmware. Basically, when going back it's important to select proper original OEM firmware but when using lineageos it's not and as long it's supported it'll just work. So no worries and disregard the incorrect model.
    1
    Btw why do you want to switch to LOS? It's not better than LOS. Unlike dead Cyanogenmod, LOS has no any additional features or additions.

    And you are getting worse launcher + worse camera app + some things not working.
    Y'all just gonna let this dude come in here and lie?
    1
    Disclaimer : sorry if this does not work for you ! It works for me but the update is a bit tricky...

    Just a small reminder for people trying to upgrade with TWRP : the LineageOS (both OTA and direct download) WILL reinstall the LineageOS recovery, whatever you tell the system not to do it. So, if your are upgrading, don't forget the following :
    * Place on the internal storage the LineageOS rom, and if you use them, the latest Magisk APK (or the APK renamed to ZIP), and the latest OpenGApps/MindTheGapps. This will prevent you from using adb sideload...
    * Backup everything. I backup data, system, boot... from TWRP and I use ad pull "sdcard" too... :)
    * If you're using Magisk and hiding it by renaming the package, flashing Magisk might be useless ; when you'll reboot, it will say it lost the root and needs to patch a file to root again. If so, try to reinstall the Magisk software from Android, then reflash the APK from TWRP. Once you're back in Android, Magisk should allow you to "direct install (recommended)". Itmight be a good idea to disable the package renaming before updating the system.

    * Update from TWRP only (and not the OTA), because you'll have the option "Automatically Reflash TWRP after flashing a ROM." If you don't, you will have to reflash TWRP using Installation method of the official thread (fastboot boot twrp.img then Flash Current TWRP from Advanced menu) - Reminder : NEVER try to flash anything if you missed the "Decrypt data" prompt...
    * Once done, wipe Dalvik, and reboot to recovery (not system !!!)
    * Flash the Magisk APK/ZIP (I need some help for that point, it makes the root weird)
    * Flash Open GApps or Mind The Gapps if you were using it.
    * Wipe Dalvik, and reboot the system... Hoping it will get you back home safely :)

    If you don't flash Magisk or the GApps, LineageOS will probably not boot.
    Hope this helps !
    1
    Alright, thanks. Then it seems opencamera works fine.

    Can't answer this question. The first thing I do after buying a new phone is los installing :)

    Here are the changes I made for opencamera if somebody is interested: https://github.com/kurnevsky/opencamera-oneplus9pro/commit/cdc76a252dcfc940107862978fed3530aeb3a0cd
    My first thing also :).
    Thank you for modifying opencamera, but I have no plan how to install it.
    Can you explain it :) ?
  • 30
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    5
    Anyone know why the builds are still called "nightly" when you're lucky if you get more than one a week now?
    There's always night somewhere in the world during the time they are compiled.
    5
    Y'all just gonna let this dude come in here and lie?
    Yes.
    4
    I noticed something in the wiki instructions. I think there's a mistake in section:
    View attachment 5381189
    To temporarily boot into Lineage Recovery it should be:
    Fastboot boot <recovery_filename>.img
    Please correct me if I'm mistaken @LuK1337
    This is not a mistake.
    4
    Working great on my LE2127. Yes after first flash, you will need to flash tmo modem. Runs great, just can't get gapps to side load...
    You need to flash the MindTheGApps package in this order:
    - Factory reset
    - Flash Lineage OS
    - Reboot to Recovery
    - Flash MindTheGApps
    - Reboot

    Starting Lineage before flashing gapps could cause issues