Development [ROM][OFFICIAL][lemonadep][11] LineageOS 18.1

Search This thread

ryamoo

New member
Mar 9, 2022
3
0
Any tips for getting google pay working? First time I've attempted to flash a custom rom to any Android.
OnePlus 9 Pro, followed the instructions to the letter, and did the "apply update" with Open Gapps (Nano package).
Google Pay doesn't finish setup:
"Couldn't finish setup to pay in shops
This phone can't be used to pay in shops. This may be because it is rooted or altered in some other way."

Seems I may have decided to do this at a bad time? I've read stuff saying google stepped up their checks? and now magisk has changed, repo moved, and other stuff that just makes all the information I found seem to be outdated.
I've installed Magisk now (using a .img extracted from the firmware), added google pay and google play services to the deny list (after enabling zygisk), but still the same error.
 

samwhiteUK

Senior Member
Jul 1, 2012
166
63
Cambridge
OnePlus 9 Pro
Any tips for getting google pay working? First time I've attempted to flash a custom rom to any Android.
OnePlus 9 Pro, followed the instructions to the letter, and did the "apply update" with Open Gapps (Nano package).
Google Pay doesn't finish setup:
"Couldn't finish setup to pay in shops
This phone can't be used to pay in shops. This may be because it is rooted or altered in some other way."

Seems I may have decided to do this at a bad time? I've read stuff saying google stepped up their checks? and now magisk has changed, repo moved, and other stuff that just makes all the information I found seem to be outdated.
I've installed Magisk now (using a .img extracted from the firmware), added google pay and google play services to the deny list (after enabling zygisk), but still the same error.
Have you installed the safetynet hider module?


Use the Zygisk module
 

ryamoo

New member
Mar 9, 2022
3
0
Have you installed the safetynet hider module?


Use the Zygisk module
Yes, Magisk v24.2, zygisk enabled, used safetynet-fix v2.2.1 which is zygisk only.
I'm just about to start again, just in case I missed something.
 

ryamoo

New member
Mar 9, 2022
3
0
Have you installed the safetynet hider module?


Use the Zygisk module
I've gone through the whole process again. Back to stock, then installed Lineage again.
One thing I missed the first time round, was "vbmeta" image during magisk installation. I've done that this time.
Not sure though if I should have been using lineage's payload to extract the boot and vbmeta images, or the oneplus firmware's payload. I used lineage.
Also not sure if I was supposed to do anything with vbmeta other than extract, and flash, or if I was supposed to load it into magisk for it to patch (I just extracted and flashed it, but patched the boot.img).

Google Pay still doesn't work, same message as previous attempts.
 

apols

Senior Member
Feb 1, 2011
224
16
I'm running the latest microg release (from Feb 20th) and I seem to be having significant standby battery drain. The battery shows basically nothing consuming battery, but I'm losing about 6-8 percent an hour with the phone just sitting next to me. I don't recall this happening on the Dec 20th release. Not sure how to diagnose what the culprit is when the battery usage UI doesn't give me much clue.
 

tedsears

Member
Jul 26, 2011
7
1
OnePlus 9 Pro
Anybody else having issues with LTE data? I recently flashed this build of lineageos 18.1 on my oneplus 9pro. Currently running March 15 build. I am finding that after a couple times switching between LTE and wifi the LTE data becomes unresponsive. Wifi will still work if I turn it back on. If I need LTE back I have to reboot the phone.
As far as I can tell APN settings are correct (using StraightTalk / AT&T). Any brilliant ideas?
 

apols

Senior Member
Feb 1, 2011
224
16
Anybody else having issues with LTE data? I recently flashed this build of lineageos 18.1 on my oneplus 9pro. Currently running March 15 build. I am finding that after a couple times switching between LTE and wifi the LTE data becomes unresponsive. Wifi will still work if I turn it back on. If I need LTE back I have to reboot the phone.
As far as I can tell APN settings are correct (using StraightTalk / AT&T). Any brilliant ideas?
I was just getting ready to update when I read this... sorry it's happening to you but think I'll hold off until I hear more. Please update if you find a root cause or resolution.
 

apols

Senior Member
Feb 1, 2011
224
16
I can't tell if this phone is garbage or if lineageos is causing the problems with my battery drain. I can only make it about 3/4s of a day with 1 hour of on screen time before it needs recharging. I bought in January and immediately wiped and installed lineageos (the microg variant), so I don't have an Oxygen baseline comparison. I'm on the Feb 20th update but am waiting to update to the March version after what tedsears reported. I've installed GSam battery monitor with root to see if I can get any more insight, because the battery stats on lineage don't show any real culprit so far.
 

tedsears

Member
Jul 26, 2011
7
1
OnePlus 9 Pro
Apols,

My battery life is fine on lineageos. I am not sure that my LTE issues are connected to the ROM. I have been on straight talk wireless for years, and moved my sim to this phone. My sim is connected to the AT&T network (through straight talk). It appears that the GSM oneplus 9 pro is not totally compatible with AT&T which may be my issue. I am in the process of getting a new sim.
Overall I wouldn't necessarily hold off on trying a more up to date build of lineageos just because of my experience.
 
  • Like
Reactions: apols

optimumpro

Senior Member
Jan 18, 2013
7,398
14,763
OnePlus 8
Anybody else having issues with LTE data? I recently flashed this build of lineageos 18.1 on my oneplus 9pro. Currently running March 15 build. I am finding that after a couple times switching between LTE and wifi the LTE data becomes unresponsive. Wifi will still work if I turn it back on. If I need LTE back I have to reboot the phone.
As far as I can tell APN settings are correct (using StraightTalk / AT&T). Any brilliant ideas?
Your problems are related to AT&T. They simply don't support 'foreign' devices (that are not sold directly by them) for LTE and 5G. You must purchase their own phones (branded). In addition, AT&T has weird 5G frequencies. And finally, AT&T's mobile phone network is way behind T-Mobile and Verizon.

The reason you had LTE initially was that it took time for AT&T computers to catch you and block access to LTE.

Since you are on Straight talk, just switch to their sim card with T-Mobile service: you will have both LTE and 5G automatically.
 

RobbieL811

Senior Member
Oct 21, 2012
5,598
16,534
Savannah, Ga.
OnePlus 9 Pro
Your problems are related to AT&T. They simply don't support 'foreign' devices (that are not sold directly by them) for LTE and 5G. You must purchase their own phones (branded). In addition, AT&T has weird 5G frequencies. And finally, AT&T's mobile phone network is way behind T-Mobile and Verizon.

The reason you had LTE initially was that it took time for AT&T computers to catch you and block access to LTE.

Since you are on Straight talk, just switch to their sim card with T-Mobile service: you will have both LTE and 5G automatically.
This ROM will work out of the box with LTE and 5G on T-Mobile?
 

RobbieL811

Senior Member
Oct 21, 2012
5,598
16,534
Savannah, Ga.
OnePlus 9 Pro
Finally got the new phone flashed and up and running on one of your latest builds! Managed to get it rooted, passing safety net, and gpay working. Gotta say, bravo on the ROM! Running great for me! I do miss the OP gestures but other than that, it's better in every way! Thanks!
 

itwasgood

Senior Member
May 29, 2012
160
10
HTC Sensation XL
Lenovo A7000
Finally got the new phone flashed and up and running on one of your latest builds! Managed to get it rooted, passing safety net, and gpay working. Gotta say, bravo on the ROM! Running great for me! I do miss the OP gestures but other than that, it's better in every way! Thanks!
Does Gcam installed when flashing the ROM? Is there any way to get stock camera app?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    I feel something big is coming guys 😏

  • 32
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    8
    LineageOS 19/19.1 might be coming, just tried a repo sync and it's grabbing source for SM8350

    Screenshot from 2022-05-06 16-42-18.png


    Definitely not quite ready yet though...

    ~/android/lineage$ breakfast lemonadep
    In file included from build/make/core/config.mk:313:
    In file included from build/make/core/envsetup.mk:312:
    frameworks/native/build/phone-xhdpi-6144-dalvik-heap.mk:19: error: _nic.PRODUCTS.[[device/oneplus/lemonadep/lineage_lemonadep.mk]]: "vendor/oneplus/sm8350-common/sm8350-common-vendor.mk" does not exist.
    16:44:52 dumpvars failed with: exit status 1
    Device lemonadep not found. Attempting to retrieve device repository from LineageOS Github (http://github.com/LineageOS).
    Found repository: android_device_oneplus_lemonadep
    Default revision: lineage-19.1
    Checking branch info
    Checking if device/oneplus/lemonadep is fetched from android_device_oneplus_lemonadep
    LineageOS/android_device_oneplus_lemonadep already fetched to device/oneplus/lemonadep
    Syncing repository to retrieve project.
    Fetching: 100% (1/1), done in 0.303s
    Garbage collecting: 100% (1/1) finished LineageOS/android_device_oneplus_lemonadGarbage collecting: 100% (1/1), done in 0.004s
    repo sync has finished successfully.
    Repository synced!
    Looking for dependencies in device/oneplus/lemonadep
    Looking for dependencies in device/oneplus/sm8350-common
    Looking for dependencies in hardware/oneplus
    hardware/oneplus has no additional dependencies.
    Looking for dependencies in kernel/oneplus/sm8350
    kernel/oneplus/sm8350 has no additional dependencies.
    Done
    In file included from build/make/core/config.mk:313:
    In file included from build/make/core/envsetup.mk:312:
    frameworks/native/build/phone-xhdpi-6144-dalvik-heap.mk:19: error: _nic.PRODUCTS.[[device/oneplus/lemonadep/lineage_lemonadep.mk]]: "vendor/oneplus/sm8350-common/sm8350-common-vendor.mk" does not exist.
    16:44:54 dumpvars failed with: exit status 1
    In file included from build/make/core/config.mk:313:
    In file included from build/make/core/envsetup.mk:312:
    frameworks/native/build/phone-xhdpi-6144-dalvik-heap.mk:19: error: _nic.PRODUCTS.[[device/oneplus/lemonadep/lineage_lemonadep.mk]]: "vendor/oneplus/sm8350-common/sm8350-common-vendor.mk" does not exist.
    16:44:54 dumpvars failed with: exit status 1

    ** Don't have a product spec for: 'lineage_lemonadep'
    ** Do you have the right repo manifest?
    6
    Y'all just gonna let this dude come in here and lie?
    Yes.
    5
    Anyone know why the builds are still called "nightly" when you're lucky if you get more than one a week now?
    There's always night somewhere in the world during the time they are compiled.
    4
    I noticed something in the wiki instructions. I think there's a mistake in section:
    View attachment 5381189
    To temporarily boot into Lineage Recovery it should be:
    Fastboot boot <recovery_filename>.img
    Please correct me if I'm mistaken @LuK1337
    This is not a mistake.