Development [ROM][OFFICIAL][lemonadep][12] LineageOS 19

Search This thread

EtherealRemnant

Senior Member
Sep 15, 2007
3,756
1,176
37
Denver, CO
I have no issues with the dialer im specifically talking about whats app audio recording messages. Could be app related issue.
Try it and see if it works. My microphone was messed up system wide until I figured that out on my 9 on StagOS using C.48 base and I'm curious if it works for you guys too. Once I do this, the microphone works fine in everything until I reboot.
 

NeWONEx

Senior Member
Sep 29, 2014
716
164
@LuK1337
Thank you for your efforts and time, I would like to report an issues, after phone fully discharged and turned off. I connect to charger and it stuck in OP boot logo and to make it works I need to force turn it off by pressing on power button and Vol+&Vol-, and once it boot I can see battery level is above 50% already. I guess it is stuck in offline charging mode.
 

om22

Senior Member
Feb 4, 2013
1,323
640
Munich
Audio recordings on whatsapp and telegram are problematic in ROMs based on oos12. The audio is too low.
When this is fixed I will happily switch to lineage again. Currently on OOS 11 again only because of that bug, which is a bummer.

It's in every app that does audio recordings. Recorder app, stock cam filming, gcam filming, WA in-app cam filming, snapchat filming, WA oder Telegram voice messages.

However didn't get any complaints while being in calls that my volume was too low. Seems to be working all right in calls. The other apps, all unusable.

@LuK1337 Can I provide any log that could be helpful?
 

IAMHOBBES

Member
Jun 15, 2017
12
0
I've tried installing ADB drivers and even oneplus drivers, but the cmd always gives me "waiting for any device"
 

Psk.It

Senior Member
Mar 6, 2016
231
49
says the same thing. Are there any specific ADB drivers I need.
when you plug the phone to PC, do you hear the sound?
can you identify it on PC devices?


let's start from scrarches:
developer options enabled
usb debug on
oem unlock on

turn off your phone and (disconnected) reboot in fastboot mode
once you see the "fastboot mode" boot you can plug it to PC

if the device is noto recognized, click on in, update deivers, select google adb device
 
Last edited:

IAMHOBBES

Member
Jun 15, 2017
12
0
It pops up on my computer, and I can access the internal storage, but when I'm in the ADB cmd, and type "fastboot devices", nothing shows up, then "fastboot oem unlock" and it always tells me "waiting for any device".
 

Psk.It

Senior Member
Mar 6, 2016
231
49
It pops up on my computer, and I can access the internal storage, but when I'm in the ADB cmd, and type "fastboot devices", nothing shows up, then "fastboot oem unlock" and it always tells me "waiting for any device".
if you can access memory you are not in fastboot mode, maybe you are in recovery mode

go to reboot menu, select bastboot
It's a complet black screen with just white labels


but overall, if you are not able to reboot in fastboot mode, are you sure you want continue?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Ok, great! Do you have any instructions (or could point me to a link) on how to do this? Have been out of the custom ROM game for a couple of years. Thanks!

    Edit: Have found this guide on the lineage OS wiki and assume this is the way to go. https://wiki.lineageos.org/devices/lemonadep/fw_update
    This is the way
    2
    I can't speak for LuK1337, but I would imagine that unless a feature (like face unlock) is something that's destined to be implemented on all devices, it's not going to show up in an official LOS build. To date, the only time a special feature appears on LOS is if a device have a unique hardware feature (like a fingerprint sensor or, in the case of OnePlus phones, an alert slider) that needs to be supported. So, unless face unlocking is a hardware-specific feature (I don't know, I never really looked at it), I wouldn't expect to see it on stock LOS any time soon. You'd have to use a custom ROM that provides support for it, or worse, return to OxygenOS. ;)
    Real face unlock (android.hardware.biometrics.face) is device specific, and OnePlus only started implementing that with OnePlus 10 series. Prior to that, they used some custom software only implementation which was likely not that secure...
    Not sure about other ROMs here, but I remember that some of them were using face detection code that they had no redistribution rights for, see: https://github.com/github/dmca/blob/master/2020/05/2020-05-05-Megvii.md. It's likely they are still doing that, but just moved code away from GitHub.
    2
    Hello @LuK1337, have a nice day! Today will come weekly update, in changelog have vendor files OOS C. 61 india, I'm now in OSS global C. 48, maybe you recommend update to C. 61 india OOS vendor?
    And find small error in changelog OOS right 12 not 11 android version.
    >I'm now in OSS global C. 48, maybe you recommend update to C. 61 india OOS vendor?
    No, FW is now included with lineage builds.

    >And find small error in changelog OOS right 12 not 11 android version.
    Not a typo, see: https://community.oneplus.com/thread?id=1100713876246757380
    2
    @LuK1337 Lukasz, i find one interesting feature of the bug with automatic play YouTube, if I change quality video 720p or lower this bug don't work and video stopped normal, if I change quality video 1080p or higher this bug working.
    Maybe problem with video buffer size, or buferization procees errors?
    I hope this information helps to kill this bug :)This bug have all users.
    That'll also be fixed in the next build ^^
    1
    On the latest build (lineage-19.1-20220712) neither proximity sensor nor light sensor (automatic brightness) are working for me. Followed the install instructions to the T and have no other customizations whatsoever. Anybody else have that problem or know how to fix this?
    Which base did you use before flashing Lineage? Make sure it was C.47, not C.61.
  • 28
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    4
    This is pretty ****ing huge
    4
    Didn't notice mic volume issue some people are reporting since i don't use voip or whatsapp voice.

    I think you can dirty flash nightly but be aware if your testing the new experimental build.

    As LuK1337 mentioned.
    "exp builds don't support OTA updates, so you'll have to manually go back to this/next nightly build after testing.
    Everyone with mic issues just disappeared as soon as I dropped that build.
    4
    Unlike other AOSP 12 ROMs, does it have to be on the latest version of oos12 ?
    Yes! It's higlighted on lineage instructions page:

    WARNING: Before following these instructions please ensure that the device is currently using Android 12 firmware.
    If the vendor provided multiple updates for that version, e.g. security updates, make sure you are on the latest!
    If your current installation is newer or older than Android 12, please up- or downgrade to the required version before proceeding (guides can be found on the internet!).

    [SOURCE: https://wiki.lineageos.org/devices/lemonadep/install]
    4
    Added flashing dtbo to wiki ^.^