Development [ROM][OFFICIAL][lemonadep][12] LineageOS 19

Search This thread

ajolly

Senior Member
Aug 24, 2006
79
15
OnePlus 9 Pro
Not sure. I'd actually prefer to incorporate his changes into my own LOS fork and test it that way, as my 9 Pro is my daily driver and I'd rather just upgrade my current LOS fork than load a different version onto it.
Do you have a good workflow for keeping your fork/phone up to date? I'm thinking of building my own fork to modify the NotificationManager service.
 

D-Rod

New member
Dec 2, 2016
3
0
Hello everyone, im having an issue where my phones display wont wake up at times. is this rom related? the phone is still on and always on display still works but when i try to wake it up, the screen goes black. did i flash it wrong?
this happens 2-3 times a day. have to power cycle to temperary fix.
 

ctag

Member
Apr 7, 2011
37
11
OnePlus 5T
This ROM appears to work on LE2127. Is there a reason I'm missing that it is excluded as a supported model?

Screenshot_20221130-075056_Settings.png
 

ctag

Member
Apr 7, 2011
37
11
OnePlus 5T
Carrier variants support is not documented (e.g. no BL unlock instructions) nor guaranteed to work or continue working. That's why.

Thanks @LuK1337. Can you expand at all on whether that's coming from the OEM/Telcos (no unlock instructions from them?) or from the rom makers (no guarantee for the ROM because of available people, resources, etc). Or is not supporting vendor locked phones a rule that roms like LineageOS adopt?
 
  • Like
Reactions: osm0sis

LuK1337

Recognized Developer
Jan 18, 2013
8,799
17,747
Samsung Galaxy S III I9300
Moto G 2014
Thanks @LuK1337. Can you expand at all on whether that's coming from the OEM/Telcos (no unlock instructions from them?) or from the rom makers (no guarantee for the ROM because of available people, resources, etc). Or is not supporting vendor locked phones a rule that roms like LineageOS adopt?
It's strictly my own decision to not advertise support for carrier variants.
 

oneplus8user

Member
Aug 3, 2022
17
6
BUG: Display goes black when trying to wake from AOD

UPDATE/SOLVED?
: This had already been reported and a fix was included in the latest build: lineage-19.1-20221206-nightly-lemonadep-signed.zip which I installed yesterday. So far no more black screens (will report if that changes)

Problem description:
This happens about 0.5-2 times per day (started 40 days ago): When the phone is in Always-on-display (AOD) mode and the power button is pushed the display turns black and goes unresponsive for 10 second, then the AOD screen returns. This persists until you reboot the phone by long-pressing the power button or running adb reboot. After that the phone works like normal until the next occurrence.

LineageOS version: 19-20221129-NIGHTLY-lemonadep
Build number: lineage_lemonadep-userdebug 12 SQ3A.220705.004
Model: LE2123

Expected behaviour:
The display turns on and the lock screen is shown.

What I've tried:
- Unlocking with the fingerprint scanner, doesn't work.
- adb reboot userspace, doesn't work.

I have not tried wiping and re-installing and am hoping to avoid that!

Customisation
NikGapps-full-arm64-12.1-20220907
Magisk @a468fd94 (25205) (34)
Magisk Modules:
AOSP Mods @2.3.0, MagiskHide Props Config @6.1.2-v137, Shamiko @0.52(120), Universal SafetyNetFix @2.3.1, Zygisk-Sui @12.7.1, Zygisk-LSPosed @1.8.4(6609), Zygisk-Enhanced mode for Storage Isolation @28.0.1
LSposed Modules:
XPrivaxyLua @1.34
**No custom kernel**
**No task killer**

Logcat:
The included log file is 66k lines. Lines of note:
#31140 - power button pressed, AOD changes to Lock Screen. works
#31259 - power button pressed, locks phone and shows AOD. works
#53552 - power button pressed, display goes black. fail
~55774 - AOD screen comes back
#64191 - power button pressed, display goes black. fail
~55774 - AOD screen comes back


 
Last edited:

Aqq123

Senior Member
Aug 27, 2009
278
335
Google Nexus 4
Nexus 7
It doesn't bother me so much but this bug on lockscreen exist from first relase of this rom. It would be nice to see it fixed (wrong positioning of fingerprint unlock icon when rotating phone on lockscreen) @LuK1337
I ran into this too. I think this actually prevents fingerprint unlock from working in landscape (not that it's a common use case).

And while we're at it, there's another minor bug when using Night Light: the screen will momentarily switch to regular color temperature right after being switched on and just before going dark when being switched off.

Other than that, it's all solid. Kudos and Happy New Year to the developer(s) and the community! 🎉
 
  • Like
Reactions: EugenStanis

osm0sis

Senior Recognized Developer / Contributor
Mar 14, 2012
15,200
34,474
Halifax
GT-i9250
Google Nexus 4
The changelog post has lemonadep listed in the lineage-20 build roster. Pretty sure we just have to wait for the builds to start rolling.

I'm mostly curious whether it updates the vendor and such to OOS13-based.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 32
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    5
    Didn't notice mic volume issue some people are reporting since i don't use voip or whatsapp voice.

    I think you can dirty flash nightly but be aware if your testing the new experimental build.

    As LuK1337 mentioned.
    "exp builds don't support OTA updates, so you'll have to manually go back to this/next nightly build after testing.
    Everyone with mic issues just disappeared as soon as I dropped that build.
    4
    This is pretty ****ing huge
    4
    Unlike other AOSP 12 ROMs, does it have to be on the latest version of oos12 ?
    Yes! It's higlighted on lineage instructions page:

    WARNING: Before following these instructions please ensure that the device is currently using Android 12 firmware.
    If the vendor provided multiple updates for that version, e.g. security updates, make sure you are on the latest!
    If your current installation is newer or older than Android 12, please up- or downgrade to the required version before proceeding (guides can be found on the internet!).

    [SOURCE: https://wiki.lineageos.org/devices/lemonadep/install]
    4
    Added flashing dtbo to wiki ^.^