Development [ROM][OFFICIAL][lemonadep][13] LineageOS 20

Search This thread
No I'm talking about the feature where you can just slide the status bar itself without dropping down anything.

It probably had to be removed after the LOS team incorporated the latest Android 13 QSR patches recently. At least one other feature (the ability to unlink ringer and notification volumes) was also removed due to Google's shenanigans. There are probably others. You can "thank" Google for that.
 

Geoz

Senior Member
Nov 22, 2012
1,309
457
Do I need One plus F.20 firmware to flash LineageOS? Or should I ask what is recommended firmware?
 

D.u.G.

Member
Aug 17, 2021
8
0
Hello,

I was just curious if there is any update regarding getting the bluetooth issues fixed. I had to roll back to Lineage 18, as neither of my rather expensive business bluetooth headsets works properly. Both are bluetooth V4 devices, and have the same issues other people have discussed on this thread (aka completely glitchy for calls).

I realize these fixes take time, was just wondering if this one is in the works.

Thanks
 

lindahl85

Senior Member
Feb 9, 2011
1,121
155
Vetlanda
I have an issue with BT headset together with Crdroid. If I get it correct, it is based on LOS?
I use a lot of headset, but I see that my Volvo V60 and Jabra stealth headset turns of hd audio in developer options. This doesn´t happen on Oneplus 8 series but but Oneplus 9 an 9 pro. The developer says "your headset is not compatible with AOSP implementation, reason it falls back to what works". How could this be fixed?
 

tonoalber

Senior Member
Mar 7, 2018
52
2
how can i install magisk in this rom? With the tutorial anchored from the forum to install it on the F.75 it doesn't work for me, with which I did it lab for the first time in that rom... please help now I can't use apps from the bank if I don't hide the root permissions...
 

Zhono

Senior Member
Dec 6, 2012
161
47
Anyone else on this rom own the Nreal Air AR glasses? Are you able to use the Nebula app? Just got a pair, and the glasses work fine as an external display, but the Nebula app doesn't detect them at all, so they can't be used for the AR apps/games, or with their screencasting modes(needed if you want to shrink the image in the glasses to one corner, for wearing while working, which is what I need.)

The Nebula app detects the glasses fine on my Galaxy S9+ and on my tablet, so I know the glasses and cable are good. The OnePlus 9 Pro is listed as a supported device for the glasses, so I figured it might be something specific to the rom.

edit: Nevermind, the explanation is here, apparently. https://www.reddit.com/r/nreal/comments/yvupl1
Basically the answer is "sucks to be you, downgrade to an outdated OS."
 
Last edited:

Forsaked

Senior Member
Apr 12, 2012
1,209
416
Since the OTA from yesterday (30.05.2023), the stock camera and LMC crashes, if the OnePlus 9 & 9 Pro Camera Unlocker-Module is active.
Anyone else experiencing this?
 
  • Like
Reactions: worstenbrood

flyu37

New member
Jun 7, 2023
2
1
Hello, because English is not my mother tongue, this passage uses machine translation. Thanks for your contribution to this rom. I found two problems with this rom.

> 1、In Settings-Beep-Ringtones When you choose a custom ringtone to play here, there will be a broken sound phenomenon.

> 2、In the Chinese version of pubg, when the microphone is turned on when forming a team, the game sound effect will lag, which is similar to the delay when connecting a Bluetooth headset.

Are these two known issues?

Thanks again for your contribution

---

你好,这里是中文对两个问题的再次描述。

1、在 设置-提示音和振动-手机铃声 选择自定义铃声进行播放时会出现破音(仅在选择时播放铃声出现)

2、在玩和平精英时与组队好友开启麦克风交流,游戏音效出现滞后,类似连接蓝牙的延迟感。
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    The auto brightness seems not accurate compared with crdroid. Is it possible to merge the commits, such as https://github.com/crdroidandroid/a...mmit/cb0785e249a951e585bf7e52837ba48d3c3c6f0e
    2
    So i need to root the device to ?

    I`m not a fan of rooting phone's, but if that can get the contact less pay working i can try.

    I believe there are some ROMs that have some PlayIntegrity/SafetyNet hacks build-in, but Lineage isn't one of them so rooting is required for that. The flip side of that is I find Lineage to be a lot less buggy than other ROMs and the maintainers do a great job ensuring all is solid and up-to-date.
    2
    Hello 👋

    Any ideea how can I fix this vb meta partition problem?

    I just installed a firmware with Odin an after that I goat the bootloader locked and this message.
    You're posting in the wrong hood.
    1
    Hi,can You help me maybe there is any any package with all firmware/drivers that I would be able to flash in other to attemp to fix my battery leak maye it is modem relatated. |Maybe it weas related to recovering from soft brick once...

    I used the crdroid firmware package linked here > https://sourceforge.net/projects/crdroid/files/lemonadep/9.x/firmware/

    It also updates your modem.
    1
    I used the crdroid firmware package linked here > https://sourceforge.net/projects/crdroid/files/lemonadep/9.x/firmware/

    It also updates your modem.
    Hi and thank you!

    OnePlus 9 Pro 13.1.0.500(EX01) Firmware flasher.zip was the packaeg I used before to succesfully debrick

    Would you suggest flashing anything other than
    fastboot flash --slot=all modem modem.img
    fastboot flash --slot=all bluetooth bluetooth.img
    (if it comes to possible high battery usage)
    from
    OnePlus 9 Pro 13.1.0.590(EX01) Firmware flasher.zip
    ?

    I assume tthis was a proper method.
  • 14
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 13, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.

    Instructions :
    Downloads :
    GPL compliance :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
    8
    Some news regarding this longstanding problem and the fix described below:

    New suggestion from LuK1337 in the issue thread here
    Code:
    adb shell settings put global cached_apps_freezer disabled
    or I guess the equivalent setting in developer options. Remember to reboot after changing it.
    I'm trying it myself now, will update in a day or two with results...

    Edit: 12h in... I'm 99% sure this has solved the issue. Have not experienced Firefox crash message, Firefox input failure, media playback failure or games failing to load, all of which happened pretty reliably previously.

    According to the LOS Gerrit, this change has been merged into android_kernel_oneplus_sm8350. Also, the changes to move the OP9Pro to the OOS 13 firmware and binaries (in the kernel, android_device_oneplus_lemonadep, and android_device_oneplus_sm8350-common) are in the process of being incorporated (some have already been merged, others are still in code review). That should mean that when OP9Pro releases resume, it'll be with the requirement to finally update the necessary firmware to LE2125_11.F.20. And the peasants... rejoiced. 😁
    8
    Thank you for your work so far, and will there be any support plans in the future😉
    Depends on the outcome of this comment - https://gitlab.com/LineageOS/issues/android/-/issues/5384#note_1284136018
    5
    Thanks, yep been reading up on MSM tool. I used to be a big fan of TWRP when we were running with LG V20 and earlier days but seems like there are still various problems and gotchas with it for OP9Pro. Magisk doesn't play nice, or it does if you hold your mouth this way while you flash, etc.

    So we've stuck with Lineage recovery on this device. I do have good memories of TWRP though and hope it fully gets there someday for OnePlus 9Pro.

    Thanks for responses - appreciate it!
    Just for future reference, Android 12-13 TWRP is pretty much feature complete for OP9x: https://forum.xda-developers.com/t/...twrp-with-a12-a13-encryption-support.4523857/

    Will be made official soon. @der_akinator has done an amazing job, and in a remarkably short amount of time!
    5
    Okay, for those of you who'd like to switch back to LineageOS 19.1 until these problems are resolved (or just want to stay on 19.1 for whatever reason), I built an unofficial release right after the February ASB patches were merged. Links are provided below for the zip, sha256, and recovery image files (you'll probably have to flash the recovery image first since the LOS 20 recovery would consider it a downgrade and refuse to flash the zip; either that, or use TWRP). This is pure, unfiltered LineageOS, with absolutely no changes made by me. You should probably turn off system updates after installing so that you aren't pestered to upgrade to LOS 20, which would defeat the whole purpose. 😁

    This will be the only build I make available until the next ASB patches are available in March, or if there's a fix for any serious issues that are merged into the 19.1 tree in the interim, as the LOS team usually doesn't do anything other than minor fixes to previous releases (their major work is concentrated on the current release). Also note that I'm not providing any support, I'm just making 19.1 available to those who want it. 😉

    ROM: lineage-19.1-20230218-UNOFFICIAL-lemonadep.zip
    Checksum: lineage-19.1-20230218-UNOFFICIAL-lemonadep.zip.sha256sum
    Recovery: lineage-19.1-recovery-lemonadep.img

    Let me know if the links aren't working (they're on MediaFire for now, which I haven't used in a dog's age) and I'll try to fix them.