[ROM] Official LineageOS 14.1 for GT-I9305

Search This thread

JUX84

Senior Member
May 29, 2013
61
14
Thanks for your response! That's interesting. I wonder what that kernel does differently than the other ones. A quick Google search with some obvious keywords digs up this old changelog entry:

The other recommendation that pops up often is setting ro.ril.fast.dormancy.rule=0 in build.prop. Perhaps the AGNi kernel did just that?

Both seem easy enough for someone to try...

Another idea might be ask the person who made AGNi kernels available for what exactly they did to solve the problem.

Thanks for the search and find!

The config line is already set, but i'll try the fast dormancy rule for a day or two and give you feedback about it :)
 

e5g

New member
May 29, 2012
3
1
I flashed lineage-14.1-20170426-nightly-i9305-signed.zip and have the "No SIM Problem" :(

I done a clean install.

Any idea?

EDIT: I also flash boeffla-kernel-6.1-boeffla-stratonz-beta4-UBERTC-4.8-LOS14.1-i9305.recovery.zip but it doesn't help :(
 
Last edited:

stratonz

Senior Member
Jan 26, 2013
174
187
Pieris
I flashed lineage-14.1-20170426-nightly-i9305-signed.zip and have the "No SIM Problem" :(

I done a clean install.

Any idea?

EDIT: I also flash boeffla-kernel-6.1-boeffla-stratonz-beta4-UBERTC-4.8-LOS14.1-i9305.recovery.zip but it doesn't help :(

Changing selinux to permissive usually solves the problem. Try with beta3 version of the kernel (which is permissive at boot) or change from rom settings (I don't remember how...) :eek:
Bye!
 

altruizine

Member
Nov 2, 2011
14
6
Thanks for the search and find!

The config line is already set, but i'll try the fast dormancy rule for a day or two and give you feedback about it :)

I have been trying ro.ril.fast.dormancy.rule=0 as well, and it does not seem to make a difference. :( Unfortunately, the "mdm_hsic_pm0" wake-look issue is still present.

Thanks to everyone who responded!
 

JUX84

Senior Member
May 29, 2013
61
14
I have been trying ro.ril.fast.dormancy.rule=0 as well, and it does not seem to make a difference. :( Unfortunately, the "mdm_hsic_pm0" wake-look issue is still present.

Thanks to everyone who responded!

do you always have the wakelock ? it seems to be random to me, it appears rarely, and since i added this line it didn't appear (yet) but i don't know it fixed anything or it's just a coincidence.
If you often have the issue, maybe it's due to the modem, i have the latest one from my country, not the PE1
 

Top Liked Posts

Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone