• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL] LineageOS 14.1 for Nexus 5X (bullhead)

Search This thread

razorloves

Senior Member
Sep 19, 2007
3,116
14,961
Miami
Google Nexus 5
Nexus 9
15.1 oreo builds are now available. See new thread here:
https://forum.xda-developers.com/ne...rom-lineageos-15-1-nexus-5x-bullhead-t3724575



yUIn6TF.png

LineageOS is a free, community built, aftermarket firmware distribution of android, which is designed to increase performance and reliability over stock android for your device.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit our Wiki.





Important Info
Current lineage 14.1 bullhead nightlies are based on the N2G48C (August 2017) monthly update from google. So you should be using the vendor, radio and bootloader img from that update. They can be extracted from the factory image on google's site here. Or you can use the ones linked below that I already extracted:
Note: The radio and bootloader img is the same as what was in the previous monthly google update, so if you already have it you don't need to flash it.
* vendor-n2g48c.img
* radio-bullhead-m8994f-2.6.37.2.21.img
* bootloader-bullhead-bhz11m.img
The vendor img is flashable with twrp or fastboot. For the radio and bootloader img, use fastboot.

More information and installation instructions can be found on the LineageOS wiki here.

Download Links
LineageOS: https://download.lineageos.org/bullhead
Google apps: Beans GApps (recommend mini)
SU addon zip: Addon Install zip / Addon Removal zip NOTE: LineageOS does not come with root, so this is now provided for those that want it. The install zip is a one time flash, like gapps. Meaning, it persists when updating to a new LineageOS nightly. REF: https://download.lineageos.org/extras

Changelog
https://download.lineageos.org/bullhead/changes/

Stats
https://stats.lineageos.org/

Credits
Many thanks to the LineageOS team and all the contributors out there in the community :good:



Contributors
dcd1182, razorloves

Source Code:
Device tree: https://www.github.com/LineageOS/android_device_lge_bullhead/tree/cm-14.1
Kernel tree: https://www.github.com/LineageOS/android_kernel_lge_bullhead/tree/cm-14.1

ROM OS Version: 7.1.2 Nougat
ROM Kernel: Linux 3.10.73

Status: Nightly
 
Last edited:

maof_ke

Member
Oct 12, 2015
8
3
Košice
Issues with CM 14.1

Hello, today I tried to flash CM 14.1 but I had some issues like warning that my phone is corrupted or something and I have to contact manufacturer. I wasn't able to setup the device. I'm wondering if this can be flashed over purenexus 7.0 ROM with NBD90Z vendor image...or should I flash some newer vendor image ? Thanks for help community :)
 
Hello, today I tried to flash CM 14.1 but I had some issues like warning that my phone is corrupted or something and I have to contact manufacturer. I wasn't able to setup the device. I'm wondering if this can be flashed over purenexus 7.0 ROM with NBD90Z vendor image...or should I flash some newer vendor image ? Thanks for help community :)

Do not enable wifi or cellular data during setup, and it will not attempt the device setup part that you can't get past.

Otherwise pretty stable.
 

xatornet

Senior Member
Mar 14, 2011
65
45
I've flashed it, it had some problems booting, but now its working. Here's my guideline:

1-If you do not want to get the VENDOR message at first boot, start flashing last NRD91N factory image
2-Flash TWRP from fastboot, and do a "Fastboot erase cache" and "Fastboot erase userdata"
3-Reboot into TWRP, and do a DATA Format
4-Reboot into TWRP and do a Full Wipe
5-Flash CM14.1 and OpenGapps (i used nano)
6-Reboot. Give it about 5 min, mine got stuck at CM logo. If after 5 min it does not boot, keep power button pressed for a few seconds till it reboots. It should boot properly now.
7-If after booting, entering SIM Pin code DO NOT ENABLE WIFI OR DATA. It will cause a loop on the wizard. Let both be disabled till the end of the config.
8-Reboot and you should have CM14.1 official working.

Here's proof:Screenshot_20161109-140003.png

Sorry for my english. :angel:

UPDATE:

Ok, i've been doing some more testing with both official 7.0 and dev preview 7.1 and here are my results:

1-If you want, you can use 7.1 dev preview as base, using the same tutorial above. The only difference will be that after every reboot, right before PIN Code, it will tell you the VENDOR.img message. Nothing to worry about.
2-I don't know if it is a placebo effect or not, but I get better performance on the CM14.1 if I use 7.1 as base. I think it is more fluent.
3-Using 7.1 as base definetively changes something, there's a little "glitch" or graphical difference with 7.0. Here's proof:
photo_2016-11-10_10-42-47.jpg
As you can see, Menu item switch looks different from 7.0.
4-In my experience, I've decided to disable the stock Web Browser and install any other, because the one that comes with the build gives FCs some times, and I think it has some memory leak or something, that makes the OS lag. After disabling it, everything works fine.

Hope this helps to anyone.
Cheers:eek:
 
Last edited:

Carach_CZ

Senior Member
Sep 23, 2014
554
113
30
Liberec
Im unable to complete the initial settings.
After connecting to wifi or data, im prompted to copy data from another device with some error messages and i cant proceed, im always taken back to previous settings screens.
When i try to turn off the wifi and data, the phone tell me that "unable to connect" and im taken back to "choose how to connect" screen. So... any suggestions? I even tried "factory reset" but with no luck.
Im using the newest bootloader from 7.1.1 DP, is this a possible source of the issues? Thanks!
 

razorloves

Senior Member
Sep 19, 2007
3,116
14,961
Miami
Google Nexus 5
Nexus 9
Last edited:

Jsparta26

Senior Member
Aug 30, 2012
1,493
627
Detroit, MI
My impressions so far are exactly as mentioned above by others with the added addition that battery icons dont work when you switch landscape and circle. Hidden and text work. Other than that the rom is pretty stable.
 
Im unable to complete the initial settings.
After connecting to wifi or data, im prompted to copy data from another device with some error messages and i cant proceed, im always taken back to previous settings screens.
When i try to turn off the wifi and data, the phone tell me that "unable to connect" and im taken back to "choose how to connect" screen. So... any suggestions? I even tried "factory reset" but with no luck.
Im using the newest bootloader from 7.1.1 DP, is this a possible source of the issues? Thanks!

Do not enable wifi or cellular data during setup, and it will not attempt the device setup part that you can't get past.
 

Carach_CZ

Senior Member
Sep 23, 2014
554
113
30
Liberec
Do not enable wifi or cellular data during setup, and it will not attempt the device setup part that you can't get past.

Couldn´t sign in
You don´t have a network connection.

After pressing next i can either turn on mobile data or connect to wifi.
So.. sorry your advice really didnt helped at all. :crying:

PS: even got "CM stopped working". I even downloaded NRD91N factory image, used its bootloader, radio and vendor. With no luck. Im DEcrypted btw. How the hell you managed to make it work?

PPS: Should i use CM Recovery instead of TWRP? "Sigh" this is frustrating.. :D
 
Last edited:
Couldn´t sign in
You don´t have a network connection.

After pressing next i can either turn on mobile data or connect to wifi.
So.. sorry your advice really didnt helped at all. :crying:

PS: even got "CM stopped working". I even downloaded NRD91N factory image, used its bootloader, radio and vendor. With no luck. Im DEcrypted btw. How the hell you managed to make it work?

PPS: Should i use CM Recovery instead of TWRP? "Sigh" this is frustrating.. :D

I came from tupac4u's debloated Nought rom, but flashed an unofficial CM14.1 build before this official one. During that process I was prompted to encrypt. I used TWRP 3.0.2-2 throughout. I get warnings during boot, but I clear them with no ill effects.

Not sure what else to tell you. As far as the setup goes, there's instructions a few posts up on how to delete the wizard all together. I didn't need to do this however. Initially I was stuck on the copy from device screen (there's no forward or submit button), but was able to go back, long press and forget the previously saved wifi, uncheck mobile data, and proceed forward skipping the device sync part. When I first opened play store, I was asked for my google credentials and two-factor code.
 

Carach_CZ

Senior Member
Sep 23, 2014
554
113
30
Liberec
I came from tupac4u's debloated Nought rom, but flashed an unofficial CM14.1 build before this official one. During that process I was prompted to encrypt. I used TWRP 3.0.2-2 throughout. I get warnings during boot, but I clear them with no ill effects.

Not sure what else to tell you. As far as the setup goes, there's instructions a few posts up on how to delete the wizard all together. I didn't need to do this however. Initially I was stuck on the copy from device screen (there's no forward or submit button), but was able to go back, long press and forget the previously saved wifi, uncheck mobile data, and proceed forward skipping the device sync part. When I first opened play store, I was asked for my google credentials and two-factor code.


7-If after booting, entering SIM Pin code and WIFI, it gets stuck at "looking for another terminal" or similar, reboot to TWRP and go: MOUNT-->TICK SYSTEM. Then got to ADVANCED-->FILE MANAGER-->SYSTEM/PRIV-APP/CYANOGENSETUPWIZARD and press option button-->DELETE.

This helped A LOT. I got rid of bugged (i know, first nightly) CM settings wizard and got into AOSP settings wizard which was flawless. Im using the CM 14.1 now! Finally!
Thanks!
 

HyDRo1X

Senior Member
Jan 2, 2012
285
31
Costa Mesa
Hello, today I tried to flash CM 14.1 but I had some issues like warning that my phone is corrupted or something and I have to contact manufacturer. I wasn't able to setup the device. I'm wondering if this can be flashed over purenexus 7.0 ROM with NBD90Z vendor image...or should I flash some newer vendor image ? Thanks for help community :)
What I did to fix this is I did I clean install with no gapps so that you don't have to do Google setup at first boot. booted fine, then I rebooted into twrp and flashed gapps. When I booted back up I just went to settings and added my Google account. I am using mini open gapps
 

dominoeflux

Senior Member
Mar 9, 2016
147
32
40
Miami
ASUS ROG Phone 3
Im unable to complete the initial settings.
After connecting to wifi or data, im prompted to copy data from another device with some error messages and i cant proceed, im always taken back to previous settings screens.
When i try to turn off the wifi and data, the phone tell me that "unable to connect" and im taken back to "choose how to connect" screen. So... any suggestions? I even tried "factory reset" but with no luck.
Im using the newest bootloader from 7.1.1 DP, is this a possible source of the issues? Thanks!

someone posted how to get around the setup solution just a couple of post upwards, I was having that problem to, but followed his instructions and cm14 works fine now

@razorloves. the cm bug report keeps force closing.
 

HyDRo1X

Senior Member
Jan 2, 2012
285
31
Costa Mesa
Anyone else having problems with clock app? I can't open it at all, tried installing through aroma gapps and through app store, aside from that everything seems stable. Even my fingerprint unlock works again which makes me really happy, it stopped working during marshmallow and even after 7.0 it wouldn't work but somehow it's back and fully functional.
 

khanjui

Senior Member
Dec 1, 2012
1,461
754
22
Eskisehir
500px.com
Not booting with F2FS data and cache partitions. Booting fine with jolla kernel. As I see stock kernel that included in ROM also supports F2FS, but I don't know why it's not booting.
 
Last edited:
  • Like
Reactions: Metroba

Top Liked Posts