[ROM] [OFFICIAL] LineageOS 16.x ALL VARIANTS

Hawaiihemd

Senior Member
May 27, 2014
630
414
93
Homburg
I'm just starting with 17.1 coming from 15.1. A few aesthetic complaints aside it's running pretty slick I think. But I seem to have run into a bug with the camera app.

My setup is as follows:
ROM 17.1-20201018-NIGHTLY-klte
Build lineage_klte-userdebug 10 QQ3A.200805.001 1b83b07703
Baseband G900FXXS1CQA9
Recovery TWRP-3.4.0
OpenGapps pico 2020-Oct-21
Magisk 20.4

Clean install after formatting data.

When I take a photo with the standard camera app set to internal storage, the picture is taken and saved to /storage/emulated/0/DCIM/Camera as expected.

When I set the app to external storage, the app behaves as if it did take the photo, the snapshot in the lower left corner it's updated, but no file is saved to /storage/--id--/DCIM/ or any subdirectory.

App permission for storage is given. But the app did not ask for write permission to the external storage as other apps do the first time you try.

Any ideas? Can anyone reproduce?
Thanks in advance.
 
Last edited:

dcarvil

Senior Member
Apr 20, 2016
367
140
43
I will try that immediately!

This method should resist updates right?
Because actually I was successful in changing mixer_paths.xml yesterday night and wanted to report here: I used TWRP terminal to mount /system as RW, changed the file with vi and then remount /system as RO, but I guess this process has to be done after every update.
Yes, this method will survive updates, as long as the data partition is not wiped. The TWRP method will not.
 
  • Like
Reactions: curiousrom

kurtn

Senior Member
Jan 28, 2017
3,769
1,580
233
Small town in Bavaria
I'm just starting with 17.1 coming from 15.1. A few aesthetic complaints aside it's running pretty slick I think. But I seem to have run into a bug with the camera app.

My setup is as follows:
ROM 17.1-20201018-NIGHTLY-klte
Build lineage_klte-userdebug 10 QQ3A.200805.001 1b83b07703
Baseband G900FXXS1CQA9
Recovery TWRP-3.4.0
OpenGapps pico 2020-Oct-21
Magisk 20.4

Clean install after formatting data.

When I take a photo with the standard camera app set to internal storage, the picture is taken and saved to /storage/emulated/0/DCIM/Camera as expected.

When I set the app to external storage, the app behaves as if it did take the photo, the snapshot in the lower left corner it's updated, but no file is saved to /storage/--id--/DCIM/ or any subdirectory.

App permission for storage is given. But the app did not ask for write permission to the external storage as other apps do the first time you try.

Any ideas? Can anyone reproduce?
Thanks in advance.
There are many official bug reports about that behaviour. Workarounds are
- use internal storage
- use other camera app
- use other gallery app
 

curiousrom

Recognized Contributor
Jun 4, 2011
1,756
3,340
153
Costa Rica
www.reddit.com
17.1 Path of Taken Photos - External Storage

I'm just starting with 17.1 coming from 15.1...

When I take a photo with the standard camera app set to internal storage, the picture is taken and saved to /storage/emulated/0/DCIM/Camera as expected.

When I set the app to external storage, the app behaves as if it did take the photo, the snapshot in the lower left corner it's updated, but no file is saved to /storage/--id--/DCIM/ or any subdirectory...
Tap on the photo preview in the Camera app (thumbnail after taking a photo) then 3-dots > Details & you will see where the photo is saved when external storage is selected.

Same when viewing in Gallery > Files album > photo > 3-dots > Details.

Since LineageOS 16.0 the path was changed to /storage/{Micro SD Card ID}/Android/data/org.lineageos.snap/files/ .

S5 maintainer haggertk said in this bug report Snap (camera) when selecting SD stores somewhere where not visible in Gallery (after restart) "This storage location is on purpose for P: https://github.com/LineageOS/androi...mmit/9b4755c0ce090a14dfb7599a238b044dcdfd5ee4 ":

"...Android P not allow apps to write/read SD Card public area and
only allow apps to access the application private area. So save
to specific path."

I'm still on 16.0 so can't check that on 17.1 @ the present.
***
 
Last edited:

rootkitty

Member
Nov 3, 2013
48
6
0
Charging Problem / Battery % Usage

I went throght the calibration procedure and when I restart the phone it shows about 92%., so I guess the battery isn't 100%, but it seems to have a resaonable amount of life (several hours of run time and about what would be expected for a 2 year old battery).

The % remaining guage behaves strangely, the rundown seemed reasonable, but at the end I had about an hour of run time left at when the guage was showing <10%. In the past the phone would die fairly quickly once the level go that low. I was suspecting a calibration issue because it was looking like the % remaining number should have been about 8-10% higher.

When I have the phone sitting on my desk plugged in to the charger, I can get it to charge to 100% byusing caffine to keep the screen active, but if I let the screen blank and don't touch the phone, charging tends to stop when fully charged (as expected), but doesn't resume again. Previously the phone would intermittently apply short brusts of charge to keep the battery topped up. Now if I leave the phone on my desk overnight, in the morning I find that the battery is run down to about 50%. I have a charger that shows current draw and when I have been watching it it reads zero amps, which tells me the phone isn't trying to charge.

The problem seemed to show up when I updated in June, but I can't really tell since the phone has spent almost all it's time sitting on my desk plugged in due to the pandemic.

Is this likely the result of a dirty flash? Bad battery? Hardware problem?
 

Brhmnst26

New member
Sep 15, 2020
3
0
0
Bogor
There is no bug, just tricky one

I'm just starting with 17.1 coming from 15.1. A few aesthetic complaints aside it's running pretty slick I think. But I seem to have run into a bug with the camera app.

My setup is as follows:
ROM 17.1-20201018-NIGHTLY-klte
Build lineage_klte-userdebug 10 QQ3A.200805.001 1b83b07703
Baseband G900FXXS1CQA9
Recovery TWRP-3.4.0
OpenGapps pico 2020-Oct-21
Magisk 20.4

Clean install after formatting data.

When I take a photo with the standard camera app set to internal storage, the picture is taken and saved to /storage/emulated/0/DCIM/Camera as expected.

When I set the app to external storage, the app behaves as if it did take the photo, the snapshot in the lower left corner it's updated, but no file is saved to /storage/--id--/DCIM/ or any subdirectory.

App permission for storage is given. But the app did not ask for write permission to the external storage as other apps do the first time you try.

Any ideas? Can anyone reproduce?
Thanks in advance.

when you have changed the camera storage to external, also change the album to custom and cancel and change it back to deffault


Andddd...booom your pictures will be saved on External/DCIM/Camera/
 

TomInfo

New member
Nov 30, 2020
2
0
1
Patch for LineageOS 16.x

Hi,

Why has there been no LineageOS 16 Build since 04.10.2020?
I thought, when a new version is released, the previous version will be changed to weekly or monthly.

I don't want to switch to 17.1 yet, but I still want to have the latest security patches.

Thomas
 

kurtn

Senior Member
Jan 28, 2017
3,769
1,580
233
Small town in Bavaria
Hi,

Why has there been no LineageOS 16 Build since 04.10.2020?
I thought, when a new version is released, the previous version will be changed to weekly or monthly.

I don't want to switch to 17.1 yet, but I still want to have the latest security patches.

Thomas
Official lineageOS nightlies only get built for one android generation. There was an exception for a device but not for our S5.

You can switch without loosing data or setup.
 

TomInfo

New member
Nov 30, 2020
2
0
1
Official lineageOS nightlies only get built for one android generation. There was an exception for a device but not for our S5.

You can switch without loosing data or setup.
thx for the information.
So I have to wait a little bit. 17.1 seems to be a little bit buggy.
Is 17.1 slowing down s5 very much?
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone