[ROM][OFFICIAL] LineageOS 17.1 weeklies for Nexus 7 2013 (flox)

Search This thread


Dec 18, 2016
I have been running the official flox ROM for a few weeks now and updating weekly. Using this ROM has been remarkably smooth considering the age of the device. I encountered no issues during installation and I had previously repartitioned to run unofficial ROMs. I used both Lineage recovery and ROM this time. Just a couple of observations I wanted to mention.

First off, the weekly update downloads but fails to install using Lineage recovery. I just sideloaded as a workaround. Secondly, and more strangely, I get significant battery drain of 2-3% per hour with the screen off. Same result for all releases. The only way I can mitigate this is through using an app like Naptime to force the OS to doze. When that is active, the screen off drain reduces to 0.7% per hour. has anyone else experienced this behaviour and if so are they aware of any solutions? Thanks.
I have the same issue with Official Lineage 18.1... blank installation, still something drains my battery... (see here). Any ideas?
Last edited:


Senior Member
Apr 18, 2014
I've upgraded to 18.1, but cannot get past the lock screen - the PIN is valid as it errors on an incorrect PIN entry, but then only clears the screen as if to display the home screen of the launcher, but instead goes back to the Lock screen. Any insight would be appreciated.
Last edited:


Feb 7, 2018
First off - thank you for your effort!

Here is a part of my logcat, if my wifi problem is unknown to you:

If you have some idea I could test, tell me.
If you have telegram, to conversate easier, tell me.

Another thing I noticed is below.
I will look at it further - but I think some feature is missing (though, my AP has 802.11r disabled).

[   44.036895] wlan: [759:E :HDD] wlan_hdd_set_akm_suite: Unsupported key mgmt type 1027078
[   44.037017] wlan: [759:E :HDD] wlan_hdd_cfg80211_set_privacy: failed to set akm suite
[   44.037109] wlan: [759:E :HDD] wlan_hdd_cfg80211_connect: failed to set security params

edit2: Might be an upstream bug - I also have problems with my recently flashed Samsung Galaxy S2.

edit3: Definitely an LOS or android upstream bug - it is the 802.11w Management Frame Protection for wifi. No matter if it is on 'optional' or 'required', both of my LOS 17.1 devices don't connect with those settings.
I might do a bugreport - as soon as I've figured out where and how.
Thanks for the hint. I recently installed flox 18.1 20210614
I'm using OpenWrt 21.02 with WPA2/WPA3 Mixed mode, and those config sets 802.11w to "optional". I have to setup another SSID with only WPA2.


Feb 7, 2018
I couldn't find a post for official lineageos 18.1 for flox, but the links you posted as
"Official dowload links" are now for 18.1 , and btw the install instructions worked great upgrading from an old LineageOS 15.1.

In the official 18.1 i can confirm that encryption works ok.
The only problem that i can confirm is with using wifi with mixed mode WPA2/WPA3 (the same network in that the old 15.1 worked fine for the last year). For now, the workaround was to add in the router a new network offering only WPA2.

Thanks to the developers for their hard work, that allow us to keep this device updated, 8 years after buying it.
  • Like
Reactions: willymoto


New member
I've upgraded to 18.1, but cannot get past the lock screen - the PIN is valid as it errors on an incorrect PIN entry, but then only clears the screen as if to display the home screen of the launcher, but instead goes back to the Lock screen. Any insight would be appreciated.
I had the same issue with my Nexus6 when upgrading to lineageos 18.1. This seems to be a standard problem on first startup of android11 when you have a pin etc. configured.
Go back to your last backup, remove the screen lock and have a look at https://forum.xda-developers.com/t/remove-bypass-lockscreen-with-recovery.3530008/
The exact names and amount of files you find in /data/system varies depending from device and previously installed lineage versions. Delete files named *.key and *locksettings* before flashing lineageos18.1 etc.


Jun 2, 2015
Thank you for keeping the Nexus 7 alive! It is awesome that I could get an Update to Android 11 in 2021, 8 years after official release.


Aug 27, 2014
"From your Terminal/PowerShell, run adb sideload /path/to/flo-deb_clamor_repartition.zip, filling /path/to/ in with the path you downloaded the repartition zip to."
What needs to fill here /path/to/? Does it mean a place where this repartition.zip?
Last edited:


Senior Member
Oct 21, 2015
Any reason why you wouldn't go for an Official LOS 18.1 build for Nexus 7 2013 Flox...?

I've been using it for months with no problems. A bit of a dickabout getting it repartitioned as Flox, but if you've already achieved that, then why stick with an older, unoficial build?
I did achieve the Flox partition and am running an old 17.1 build but the only reason that stops me to jump to 18.1 is that Android 11 isn't too friendly about sideloading OBB based apps. For example, I can't get to sideload Respawnables (a game) if I download it from sources other than the play store.

If you happen to know a workaround for the same, please let me know!

Also, if you can drop the link to the last 17.1, I would appreciate that too!



Recognized Contributor
Feb 14, 2016
Google Nexus 10
Nexus 7 (2013)
"From your Terminal/PowerShell, run adb sideload /path/to/flo-deb_clamor_repartition.zip, filling /path/to/ in with the path you downloaded the repartition zip to."
What needs to fill here /path/to/? Does it mean a place where this repartition.zip?
Yes. ;)
It would be the full path to the zip file.
This is only needed if you are not in the same directory the zip file is in.

If you are using Windows, it would be something like this adb sideload C:\Users\YourUserName\Desktop\NameOfFolder\flo-deb_clamor_repartition.zip

If you added the adb command to your Windows $PATH.
or copy the adb.exe file into the same directory as the flo-deb_clamor_repartition.zip file.

You can just call adb from the directory the zip file is in.
adb sideload flo-deb_clamor_repartition.zip

Cheers. :cowboy:

There is no problem calling a full path, I do it quite a bit. ;)
Note: I have seen issues in different threads about using \User\Desktop\
Normally it was recommended to make a directory on C:\ and move the files there.


Senior Member
Nov 14, 2010
I'm trying to repartition my Nexus 7 (2013) using the repartition script but I'm getting some errors:

flox:/ # modify
2048+0 records in
2048+0 records out
1048576 bytes (1.0 M) copied, 0.034057 s, 29 M/s
dd: /tmp/backup/recovery.img: write error: No space left on device
umount: /mnt/system: Invalid argument
umount: /data: Invalid argument
umount: /sdcard: Invalid argument
umount: /cache: Invalid argument
/system/bin/modify[42]: can't write temporary file /tmp/shelg6qc.tmp: No space left on device
mke2fs 1.45.4 (23-Sep-2019)
/dev/block/mmcblk0p22 contains a ext4 file system
        created on Mon Jan 10 14:57:17 2022
Proceed anyway? (y,N)

Should I ignore the errors and just proceed? (I don't need any data from the device)

If I do proceed and attempt to flash the recovery image I get a different error:

E:\Tools\adb\platform-tools>fastboot flash recovery c:lineage-18.1-20220110-recovery-flox.img
target didn't report max-download-size
sending 'recovery' (10878 KB)...
OKAY [  0.347s]
writing 'recovery'...
FAILED (remote: size too large)
finished. total time: 0.353s


Mar 12, 2013
I just got a 32 GB Nexus 7 2nd gen. 2013 WIFI and decided to put LineageOS in it. I followed the instructions on Lineage's wiki at https://wiki.lineageos.org/devices/flox/install

But not everything went as in the instructions. First, only LineageOS 18.1 is available now. Secondly I got some errors during the installation steps. I try to describe them here in case it's useful for someone else.

So I followed the wiki page up until the re-partition part. The zip file installed fine but running it didn't go as it should have. The first time I ran the command 'modify' I got errors during the mke2fs lines: all of them said no such device exists, 4 times for all of the mmcblock0p* devices. After that the script continued and after the 'dd' lines hung up and not exiting properly (yes, I waited like 15 minutes). No errors though.

I decided to give it another try so I sideloaded the zip again and ran the 'modify' command again. This time the mke2fs lines actually created the filesystems but still the script hung right in the end and did not reboot to bootloader. Again force exited the script and continued with the installation.

Next was fastboot -w, which did not run properly but gave an error: "FAILED (remote: 'Bogus size sparse and chunk header')"

After some googling I found some threads that suggested that my platform tools were out of date. But they were not, I had just downloaded the latest tools. Then I found a reddit thread that suggested to use TWRP recovery instead. So I did: fastboot boot twrp-3.5.0_9-0-flox.img. I used the image found somewhere on this forum. When in the TWRP recovery, go to "Wipe" and "Format Data", then type yes. That completed successfully.

Next I continued with the installation by booting into LOS recovery and formatting system partition and then flashing the LineageOS recovery: fastboot flash twrp-3.5.0_9-0-flox.img. Everything after that went smoothly, installed the LineageOS 18.1 weekly, which was
lineage-18.1-20220328-nightly-flox-signed.zip and the corresponding recovery image.

The only weird thing with LOS 18.1 was that in the first boot wizard, wifi wouldn't connect but did connect later when installing software. Oh and I also installed OpenGapps Nano v. 11 for ARM before booting up LOS for the first time.
Last edited:


New member
Apr 26, 2022
Just thought I'd mention Slimport (hdmi via usb) doesn't work on this ROM: the Nexus 7 2013 just freezes (it does, however, work on a LG G2 with Lineage 17.1)


New member
May 14, 2023
Can anyone share flo-deb_clamor_repartition_20201203.zip with me? android file host tells me there are no mirrors available.

I found flo-deb_clamor_repartition.zip but I don't think it's the same


Feb 7, 2018
Just posting to say thanks the developers. My flox is celebrating 10 years, and now is running LineageOS 18.1 build from may 2023. I use it almost everyday, and it is, no doubt, the best tech purchase for longevity, price, and community support. I wish other devices could reach half this support.
  • Like
Reactions: glitchers and ipdev


New member
May 14, 2023
Here's a mirror: flo-deb_clamor_repartition_20201203.zip
Its md5sum should match the one listed on the old d/l page.
Thanks, I feel slightly bad now because I tried the next day and the download worked but I didn't update this thread.
I had all sorts of trouble installing though with various 'error' messages about missing things and commands seemingly hanging and never ending. But in the end I just ploughed on through and ignored all that and it somehow is working now 🤷‍♂️. It helps that I wasn't overly concerned about bricking it.

Top Liked Posts

  • There are no posts matching your filters.
  • 25

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github Repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.

    Device-specific source code:


    What works?

    • Wi-Fi
    • Bluetooth
    • Sensors (Accelerometer, Compass, Light, etc.)
    • Camera
    • Video (playback & recording)
    • Audio (playback & recording)
    • GPS
    • Everything else not listed under "known issues"

    Known Issues:
    • Nothing (?)
    • Follow instructions at Official wiki
    • NOTE: Users who have already performed repartition should only change recovery to Lineage recovery or to my TWRP build (see the post below)
    So, why flox?
    We use name flox to show the difference between installation method in new versions of LineageOS on this device, which is not compatible with older versions.
    If TWRP is a convenient installation method for you, then you can download and use my recovery build.
    Update found new build and downloaded but didn't reboot to recovery to install.
    I downloaded it manually and flash it.
    Where can I find the update download bluid to delete it?
    It will be fixed in the next update, you can find it after mount /data at:
    Hello, I can´t use the updater. It says "installation failed". Is this a known bug? Regards
    Fixed now
    I have created an alternative single-click re-partition script which safely and easily generates the "UA" /flox partitions...

    --- Go to to the CROSS thread and run lineage-install-2-flox.bat CROSS2 script to install everything automatically.