[ROM][OFFICIAL] LineageOS 17.1 weeklies for Nexus 7 2013 (flox)

MorpheusUK

Member
Mar 22, 2009
26
5
23
I have just dirty flashed from Pitrius' December unofficial build. Seems to have gone without a hitch. (I had previously partitioned via Clamor's script for the unofficial builds, used DiskInfo to confirm the 1.5gb System partition).
I followed the first three steps below (will decide if I need step four when I try to update for the next monthlybsecurity update as I have read the Updater doesn't install with TWRP but it didn't seem to be confirmed)

1. Flash the TWRP flox recovery
2. Flash official flox signed zip
3. Flash Open GApps
4. (Optional) Flash LOS flox recovery

SELinux is now enforcing under Trust and the Netflix and Disney+ said have updated from the play store to the current versions. I previously had to sideload both with a specific Netflix build to run on the unofficial build.

Thanks for creating an official build.

Edit:
Lost the camera app from my home screen and drawer on reboot, fixed it by going into settings->apps finding the camera app in the list and clearing the cache and storage.
 
Last edited:
  • Like
Reactions: taadow1030

AxelGom

Member
Jun 6, 2012
17
2
33
Mexico
First of all, thanks for all the work to get working LineageOs 17.1 in nexus 7 2013.

I want to report an issue:

- Screen mirroring via slimport HDMI adapter doesn't work.

When i connect slimport to my tablet charging from adapter works properly but when i plug hdmi screen freezes and the only way to respond is restarting it vía power button.
 

Jvino

Member
Dec 23, 2020
24
3
3
First of all, thanks for all the work to get working LineageOs 17.1 in nexus 7 2013.

I want to report an issue:

- Screen mirroring via slimport HDMI adapter doesn't work.

When i connect slimport to my tablet charging from adapter works properly but when i plug hdmi screen freezes and the only way to respond is restarting it vía power button.
Yes. This is a known issue and extremely difficult to correct. The slimport can only function with the OEM ROM, for now. As far as I know, all attempts to get it going have failed.
 

C Karthik

Member
May 11, 2020
21
5
3
The ROM is great. Is there a way to boot this rom with bootloader locked? I ask this as I don't want my files to be accessed by flashing a recovery like TWRP. Also, is there a way to get exFAT OTG support in this rom?
 

johndaog

Member
Nov 7, 2019
24
5
13
Durban
I am having trouble with my touchscreen especially the three bottom buttons. The home, back and apps buttons. They often glitch and are extra sensitive. I will try return to stock android to see if it is my device.
 

ajthecat

Member
Apr 21, 2020
5
0
1
I have been running the official flox ROM for a few weeks now and updating weekly. Using this ROM has been remarkably smooth considering the age of the device. I encountered no issues during installation and I had previously repartitioned to run unofficial ROMs. I used both Lineage recovery and ROM this time. Just a couple of observations I wanted to mention.

First off, the weekly update downloads but fails to install using Lineage recovery. I just sideloaded as a workaround. Secondly, and more strangely, I get significant battery drain of 2-3% per hour with the screen off. Same result for all releases. The only way I can mitigate this is through using an app like Naptime to force the OS to doze. When that is active, the screen off drain reduces to 0.7% per hour. has anyone else experienced this behaviour and if so are they aware of any solutions? Thanks.
 

morigero

Member
Mar 31, 2019
14
2
3
I had this battery drain in my last LOS with Android 7.1. Now with this its gone. After 7h I have 97% after wake up in the morning. So I expect, that have something todo with flashing. Maybe something isn't done well.
 

Spanking Time

Senior Member
Mar 5, 2018
50
7
18

ajthecat

Member
Apr 21, 2020
5
0
1
I had this battery drain in my last LOS with Android 7.1. Now with this its gone. After 7h I have 97% after wake up in the morning. So I expect, that have something todo with flashing. Maybe something isn't done well.
Yes I understand what you're saying. I did however do a clean installation of everything. I formatted everything, wiped data etc. to make it as clean as possible. Maybe just bad luck on my part. I was running Android 9 before without the screen off drain and the same apps installed. I actually have fewer apps installed now and my battery health seems okay for a device of its age.

I've been using GSAM Battery Monitor with enhanced stats enabled, but nothing jumps out. Just seems like something is preventing deep sleep or doze. Maybe I'll try resetting the battery using ADB.
 

C Karthik

Member
May 11, 2020
21
5
3
I am not well versed with encryption. So I wanted to know how exactly does encryption protect my data? I know that custom recoveries cannot access the data partition if it is encrypted. But what if someone flashes a custom ROM using adb or usb-otg? Any newly flashed ROM won't be having a lock screen. So won't it be possible to access my data?
 

LV198

Senior Member
Jul 16, 2017
68
16
8
I am not well versed with encryption. So I wanted to know how exactly does encryption protect my data? I know that custom recoveries cannot access the data partition if it is encrypted. But what if someone flashes a custom ROM using adb or usb-otg? Any newly flashed ROM won't be having a lock screen. So won't it be possible to access my data?
No, the only thing the newly installed ROM sees is data-rubbish.
 

bertans

Senior Member
Nov 13, 2009
259
163
73
Como
Hi, I am a very happy owner of a Flo(x) device... brought back to life thanks to the Lineage official builds! Thank you for your efforts.

I would like to confirm the automatic update problem by referring to these previous posts:

Update found new build and downloaded but didn't reboot to recovery to install.
It will be fixed in the next update
the weekly update downloads but fails to install using Lineage recovery
I never installed the modded TWRP (second post of this tread) but I always updated Lineage Recovery at every build and even with the last build of Jan. 25th, "update found new build and downloaded but didn't reboot to recovery to install".

In the previous builds I also experienced a problem with Trebuchet in landscape mode:
Screenshot_20210118-171324_Trebuchet.png

But it has been fixed with the last build!

Lineage mantainers, you're the best! Thank you again

A
 

ud4

Senior Member
Apr 9, 2013
129
196
83
Minsk
Hi, I am a very happy owner of a Flo(x) device... brought back to life thanks to the Lineage official builds! Thank you for your efforts.

I would like to confirm the automatic update problem by referring to these previous posts:





I never installed the modded TWRP (second post of this tread) but I always updated Lineage Recovery at every build and even with the last build of Jan. 25th, "update found new build and downloaded but didn't reboot to recovery to install".

In the previous builds I also experienced a problem with Trebuchet in landscape mode:
View attachment 5200221
But it has been fixed with the last build!

Lineage mantainers, you're the best! Thank you again

A
Thanks! I'll take a look at it (updates)
 
  • Like
Reactions: bertans

Morgs___

New member
Jan 7, 2018
2
2
3
Hello all,

Love the ROM and works almost perfectly, having the same issue as johndaog above, top and bottom edges of the screen are incredibly unstable.

Attached a vid with pointer location enabled to help show it off. Would there be an easy way of determining whether this is a software or hardware issue?

Thanks in advance

 
  • Like
Reactions: johndaog

user602

Senior Member
May 8, 2007
646
439
93
I am having trouble with my touchscreen especially the three bottom buttons. The home, back and apps buttons. They often glitch and are extra sensitive.
Love the ROM and works almost perfectly, having the same issue as johndaog above, top and bottom edges of the screen are incredibly unstable.

Attached a vid with pointer location enabled to help show it off.
I just enabled pointer location to test this. I cannot replicate the issue; the entire screen responds as expected.

For reference, I'll note that I was previously using unofficial 17.1 (also without any touchscreen issues), and performed a full wipe before switching to official. I am currently running the latest build.

Good luck.
 
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone