[ROM][OFFICIAL] LineageOS 17.1 weeklies [osprey/merlin]

Voha888

Senior Member
Apr 28, 2014
70
16
38
Dnipro
I have installed last version and its have bug from many custom ROMs from many devices - hidden wifi networks not works some time. Which version are stable?
 

Gordster

Member
Jan 18, 2018
31
8
8
I've noticed on the 2020/11/27 and later rom that I can no longer save camera photos to my SD card and must save them to the device internal memory. Even with Open Camera it doesn't seem to work. Why was this 'feature' taken out?
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
7,304
9,485
263
I've noticed on the 2020/11/27 and later rom that I can no longer save camera photos to my SD card and must save them to the device internal memory. Even with Open Camera it doesn't seem to work. Why was this 'feature' taken out?
Due to Google's implementation of scope storage in newer versions of Android photos were being saved to a location on external hard drive which was not accessible by either the native Gallery app or the camera app so attempting to access a picture saved to external SD from the preview in the camera app would take the user to the internal SD and the user might never know that were private pictures on the external SD which is not a secure location. A debate rages on about how some apps work around this but that is apparently something that LOS cannot do so save to external SD was removed. There are more details from developers in a ticket at the official LOS gitlab.
 

Silver Werewolf

New member
Dec 14, 2020
4
0
11
Due to Google's implementation of scope storage in newer versions of Android photos were being saved to a location on external hard drive which was not accessible by either the native Gallery app or the camera app so attempting to access a picture saved to external SD from the preview in the camera app would take the user to the internal SD and the user might never know that were private pictures on the external SD which is not a secure location. A debate rages on about how some apps work around this but that is apparently something that LOS cannot do so save to external SD was removed. There are more details from developers in a ticket at the official LOS gitlab.
Lol thats HORRIBLE, so the only solution is to download the version prior to that? the 20-11-2020 to be exact
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
7,304
9,485
263
Lol thats HORRIBLE, so the only solution is to download the version prior to that? the 20-11-2020 to be exact

To me the solution that IS to make the device safer by removing option to save to external SD. Also, some perspective on development: I'm interested in testing the software, not just acquiring it and agree with the decision. It's easy to work around; maybe this will spur a wave of development in simple apps that can move the pictures... if there are not already many of those, the broken spell check if far more limiting to me.
 

Silver Werewolf

New member
Dec 14, 2020
4
0
11
To me the solution that IS the solution; to make the device safer by removing option to save to external SD. Also, some perspective on development: I'm interested in testing the software, not just acquiring it and agree with the decision. It's easy to work around; maybe this will spur a wave of development in simple apps that can move the pictures... if there are not already many of those, the broken spell check if far more limiting to me.
This device has 4gb for the user, is barely enough for some apps, i don't want the photos and videos too there.... "safer" who cares really, its like the meltdown and spectre patch in windows, nobody cares and it only decreases performance, why i have to use a app to move the photos and videos after taking then... its has no sense.. you pick where you want to store your multimedia files and thats its, if you wanna be "safer" from who knows what you pick internal storage, else sd card :p
 

IronTechmonkey

Recognized Contributor
Feb 12, 2013
7,304
9,485
263
This device has 4gb for the user, is barely enough for some apps, i don't want the photos and videos too there.... "safer" who cares really, its like the meltdown and spectre patch in windows, nobody cares and it only decreases performance, why i have to use a app to move the photos and videos after taking then... its has no sense.. you pick where you want to store your multimedia files and thats its, if you wanna be "safer" from who knows what you pick internal storage, else sd card :p
It's clear that you don't understand the larger Google construct, (including policies and software) in which this development occurs, or the need for prioritization of privacy and safety over convenience. Additionally, this is a development thread where the point is to contribute to development of LOS17-Ocean; not to complain about the decisions that were made from an uninformed point of view having contributed nothing to the effort.
 

Silver Werewolf

New member
Dec 14, 2020
4
0
11
Hello, the camera is still broken, that bug that it opens and it only shows a black screen and you have to restart the phone is still there, happen to me two times in a row, it even rebooted my phone just now, and in google maps rebooted my phone too... also there is a notable battery drain compared to stock, i'm using the last nightly with gapps nano, nothing more. Greetings.
EDIT: lol no, i rebooted the phone for 3er time and the camera is still a black screen, i think this last nightly completely broke it XD
 

JuniorSPTUX

New member
Dec 26, 2020
1
0
1
I did a clean install of the latest version of osprey, and everything seems to work perfectly!!! One minor issue that bother me is related to wifi. For any reason, it drops frequently and then I need to switch off and on many times till it works. It show my network as saved, then when I try to reconnect it ignores that.
Did anybody faces this behaviour?

tks,
 

mumfordfan

Senior Member
Aug 6, 2013
142
29
48
I did a clean install of the latest version of osprey, and everything seems to work perfectly!!! One minor issue that bother me is related to wifi. For any reason, it drops frequently and then I need to switch off and on many times till it works. It show my network as saved, then when I try to reconnect it ignores that.
Did anybody faces this behaviour?

I don't have this problem, is there something wrong with your wifi setup maybe?

tks,
Hello, the camera is still broken, that bug that it opens and it only shows a black screen and you have to restart the phone is still there, happen to me two times in a row, it even rebooted my phone just now, and in google maps rebooted my phone too... also there is a notable battery drain compared to stock, i'm using the last nightly with gapps nano, nothing more. Greetings.
EDIT: lol no, i rebooted the phone for 3er time and the camera is still a black screen, i think this last nightly completely broke it XD
The camera is working fine here on my osprey.

Maybe faulty hardware?
 

domin144

New member
Dec 20, 2020
3
0
11
Hi all,

I have installed version lineage-17.1-20210101-nightly-osprey-signed.zip on my XT-1541. Everything works fine except mobile data connection. Phone and SMS work OK. Wi-Fi works OK, but mobile data not. What is even more interesting, when I insert my wife's SIM card (different provider) cellular data works correctly.
My SIM is not broken, it worked before update to lineage os, it also worked in other phone (Moto G5, I no longer have it) with unofficial build of Lineage OS 17.1 and still works in USB modem.

I tried erasing all APN's and putting only exact data provided by service provider, but it didn't help. The provider is plusgsm (ustaw.plus.pl)
Any idea what else I could check?
 

FredBirne

New member
Jan 16, 2021
1
0
1
Had the same issue with the mobile data connection.
I tried that modem fix as well but didn't really help. I also played around with the APN settings but no change.
As a workaround I was able to change the network type from 2G/3G/4G to 2G/3G. With that the Phone was connecting to the network. Afterwards I changed it back to 2G/3G/4G and it now works as well with LTE.
Not tested MMS as I don't use it.
Model: XT1541
Provider: Congstar (German Telekom)
 
Last edited:

cromfr

Member
Mar 3, 2012
21
1
23
hello and first of all thank you for this great work. I've just installed the latest (15/01/2021) version after 5 years of stock ROM.
the only problem i face ils the black screen during call (or listening voicemail message). It seems related to the proximity sensor, but i don't know if it's hardware related (broken ? Calibration ?) or software (i had similar behavior with stock rom but i just had to press power button to get back my screen on).
anyone experiences the same or could give me leads to correct this ?