[ROM][OFFICIAL] LineageOS 17.1

Search This thread


Dec 16, 2010
Great. I added that stuff to my post so the instructions are clearer without having to read the earlier posts.
  • Like
Reactions: KEB64

Top Liked Posts

  • There are no posts matching your filters.
  • 4

    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.


    This is the Official LineageOS 17.1 thread for the Moto Z3 Play, codename beckham.




    XDA:DevDB Information
    LineageOS 17.1, ROM for the Moto Z3 Play

    Source Code: https://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Android 9 (Pie) Firmware

    Version Information

    Created 2020-11-19
    Last Updated 2020-11-19
    So, it seems that the latest builds were buggy, and he decided to pull them until he can fix the issues. Seems like the phone will be back on download.lineageos.org soon.

    That's basically it, yes. Not everyone was effected, but enough were to recognize there was an issue. So to prevent the chance anyone else may experience the same, we had the builds pulled. New build will return next cycle and should include a proper solution.
    OK, going from memory and notes:

    Install Magisk and the MagiskHide Props module from within Magisk.

    Enable Magiskhide in the settings of the Magisk app. If it's enabled, then when you click that shield at the bottom you'll see an option at the top for Magiskhide. It will automatically check Google Services, so you don't need to do anything.

    You'll need a terminal app. Assuming you have gapps installed, I like Termux from the Play Store. (If you intend to use Termux in the future, they want you to use the Fdroid version) Without gapps and the Play Store, I think you can enable a local terminal from Developer Options that should work.

    Open a Termux shell. Type "su" and Magisk will open a permission box to give you superuser access.

    Then type "props" to run the magiskhide-props script. It will have some menus. Select the option to change the build fingerprint and then type in the fingerprint. The built in Motorola fingerprints didn't have the Z3P.


    Use the safetynet checker in Magisk and it should give a Success message.


    For reference:

    Edited to add installation of Magisk and Magiskhide Props module and for clarity.
    I have an XT1929-4.

    I installed lineageos 18.1 using the 2021-04-21 nightly. I installed OpenGapps from the arm64 android 11 pico test build dated 2021-01-30. I haven't had any problems but I don't use any mods and I haven't tested Bluetooth or Android Auto. Encryption is enabled.

    I wanted to get Google Play certification and to pass safetynet so I installed Magisk and the Safetynet-fix module. I still failed the cts profile, so I used termux and the Busybox-for-android-ndk and Magiskhide-props-config modules to change the fingerprint. I tried my android 9 stock fingerprint but it didn't work, so I tried the android 8.1 stock fingerprint and the Google Play store now shows certified and I can use Google Pay.
    You are a hero. I need to wait for my partner to transition from Z3 Play to G Power due to more battery. As soon as I get the Z3 Play, it will be go time for LOS :) Thank you!