• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL] LineageOS 18.1 for Galaxy S10e/S10/S10+/S10 5G Exynos

Search This thread

gandoo

Member
Aug 9, 2021
23
12
Noticed a minor bug
When connected to bluetooth, the bluetooth device volume bar displayed and the actual volume is not in sync. For example, if the + volume is clicked even after the displayed volume bar is max volume increases because it is not at max actually, same for decreasing the volume
 

vomad

Senior Member
Jun 8, 2017
119
45
Volgograd
I tried me too, no way.. the only function I can assign to the Biby button is the one to "wake-up" the screen, all the remaining functions listed in the menu (by short/long pressing the Bixby button) are not working🤷‍♂️
After what I did (I mean edited gpio.keys) I can't remap any setting on the Bixby at all. Even If I return to 703 key MENU again. When I press button no action. But before my manipulations it had opened context menu on Trebuchet. Strange thing.
 

woaloo

Retired Forum Moderator
Jun 23, 2006
451
45
Fairphone
Samsung Galaxy S10e
After what I did (I mean edited gpio.keys) I can't remap any setting on the Bixby at all. Even If I return to 703 key MENU again. When I press button no action. But before my manipulations it had opened context menu on Trebuchet. Strange thing.
Hi,
You can try this app : Key Mapper
I've installed it on my S10e and it works with bixby button. With double press, I can launch Opencamera.
 

zpunout

Senior Member
Aug 26, 2015
59
12
Samsung Galaxy S5
Moto G5 Plus
Anyone else having issues with 4G/LTE connectivity and not recognizing external sdcard? Doesn't seem to be any mention of it in this thread. I have tried resetting the network settings and tried going into recovery to format cache. Unless someone here has any other ideas, I'll be reinstalling stock OS and see if the issue persists. I haven't ruled out a hardware fault neither as the S10e I'm using was recently purchased in used condition. I should have tested it for a day or two before installing LineageOS. 😐
[RESOLVED] After flashing back to stock, LTE worked perfectly again and performed as expected in an internet speed test website. So, after installing LOS again for the second time, the LTE connectivity issue returned. For some reason, when I messed with the APN settings again and selected a different APN, it seems to have fixed it. Thought I'd tried this before but I guess I didn't.

About the external sdcard: The external sdcard slot seems to be broken at a hardware level I think. Don't know why. Perhaps the device had water damage or was dropped

Thought I'd share the feedback here in case anyone else encounters a similar LTE issue.
 

vomad

Senior Member
Jun 8, 2017
119
45
Volgograd

Mcgreygor

Member
Apr 12, 2015
23
2
Thanks again guys!
i would like to use google camera on my s10e (with lineage 18.1 of course and gapps installed), what you suggest me to do?
:) have a good day
 

CntrlAltDel45

Senior Member
May 7, 2015
132
18
Cape Town
You can also do that in lineage recovery by sideloading it just like you did with the ROM itself or you install it from external sdcard / USB otg (for this you'd need to rename it from .apk to .zip)

Both are in "Apply Update" menu.
1. Patched Magisk image requires that you flash AP which will overwrite recovery?
2. The method of sideloading fails (renaming apk to zip method).
 

vomad

Senior Member
Jun 8, 2017
119
45
Volgograd
You can also do that in lineage recovery by sideloading it just like you did with the ROM itself or you install it from external sdcard / USB otg (for this you'd need to rename it from .apk to .zip)

Both are in "Apply Update" menu.
I thought Magisk has survival addon script? For example when I install LineageOS' OTA on my second phone Xiaomi Mi note 2, Magisk run it's script in recovery after update.
 

Keule-Tm

Senior Member
Oct 3, 2016
377
145
Berlin
Samsung Galaxy S10
You can also do that in lineage recovery by sideloading it just like you did with the ROM itself or you install it from external sdcard / USB otg (for this you'd need to rename it from .apk to .zip)

Both are in "Apply Update" menu.
Is it possible to install it from the internal memory (i.e. not an external sdcard nor a usb device)? If not, there are certainly some thoughts behind that restriction. I would like to know them.
 

zpunout

Senior Member
Aug 26, 2015
59
12
Samsung Galaxy S5
Moto G5 Plus
Thanks again guys!
i would like to use google camera on my s10e (with lineage 18.1 of course and gapps installed), what you suggest me to do?
:) have a good day
Depends of whether you have a Snapdragon or Exynos variant of an S10e I think. Here's one link to the Exynos SM-G970 F compatible version called ZGCAM https://forum.xda-developers.com/t/gcam-zgcam-for-exynos-s10-e.4176265/
Since you added GApps to your LOS install, you shouldn't need a services spoof apk to get GCam to work, but here is the link to info about that anyway: https://www.xda-developers.com/google-camera-port-hub/
 
  • Love
Reactions: Mcgreygor

bertino

Senior Member
Oct 17, 2014
294
112
Depends of whether you have a Snapdragon or Exynos variant of an S10e I think. Here's one link to the Exynos SM-G970 F compatible version called ZGCAM https://forum.xda-developers.com/t/gcam-zgcam-for-exynos-s10-e.4176265/
Since you added GApps to your LOS install, you shouldn't need a services spoof apk to get GCam to work, but here is the link to info about that anyway: https://www.xda-developers.com/google-camera-port-hub/
He definitely has the exynos variant as snapdragon doesn't have unlockable bootloader and lineage. Also, the best gcam atm is BSG MGC (https://www.celsoazevedo.com/files/android/google-camera/dev-bsg/f/dl49/)
 

zpunout

Senior Member
Aug 26, 2015
59
12
Samsung Galaxy S5
Moto G5 Plus
He definitely has the exynos variant as snapdragon doesn't have unlockable bootloader and lineage. Also, the best gcam atm is BSG MGC (https://www.celsoazevedo.com/files/android/google-camera/dev-bsg/f/dl49/)
Thanks for the update. I just gave the 8.1 version a try with the latest GCam Services Provider spoof app because I don't use GApps nor MicroG but couldn't get it going after a short attempt. Version 7.4 works though

[edit: Now the app starts. I left the phone alone for about a minute after trying to open GCam 8.1 then it popped up. Cool!]
 

Mcgreygor

Member
Apr 12, 2015
23
2
hello guys! :) i have a question
voLTE and voWIFI is NOT working on s10e right?
is that a problem regards "quality of life"/ "daily use" in your opinion?
thanks a lot!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    ok, thanks, I guess no countermeasure can be adopted... (?)
    Try installing this as a system app, by making a folder /system/app/SamsungDAP and putting the APK inside
    3
    First off, thank you for making this.
    Been using the microg fork for a couple of days, so I thought I'd share a list of things that I had/have issues with or that don't work.
    Most of these issues should also be present on this official ROM, as it's just the google services backend that's different.
    I'm also new to modern smartphone ROMs, so please don't bash me if I say something dumb.

    Using on an S10+ Exynos. SM-G975F
    Installation went just fine on Arch Linux.

    Lockscreen/locked related:
    Always on Display doesn't shift the clock every minute, so there's a chance of burn-in.
    Always on Display has a clump of maybe 5 pixels next to the front cameras that constantly blink green.
    Wave to wake up doesn't work.

    Microg related, had to install DroidGuard Helper from FDroid to get the fingerprint sensor working. Works well and much quicker than on the stock Samsung ROM.

    Random issues:
    Status bar doesn't change to a dark font with a light wallpaper. Works just fine in apps.
    Adaptive brightness seems to be having issues actually doing anything, very often.
    There are no built-in torch intensity settings.
    Most likely microg related, doesn't automatically pick up auth codes from SMS as there's no daemon for it.

    Frequently asked about features:
    Wireless hotspot working just fine.
    5GHz wifi working just fine.
    Bluetooth working just fine. No issues with wireless earbuds, paired instantly.
    LTE working as expected, signal is fine. Central EU. TMobile network.

    Camera:
    Stock camera app doesn't let you change lenses or video framerate to 60 fps.

    Using the GCam fork mentioned somewhere above "MGC_8.1.101_A9_GV1r_MGC"
    Wide angle lens working, normal lens working, no telephoto.
    Both front cameras working
    Takes some time to switch between any of these.
    You can force [email protected] video with stabilization and all the nice things in the settings.
    No 4K video for the front cameras, it caps at [email protected]

    Not tested:
    NFC/Contactless Payments.
    Dual sim
    SD card slot
    USB hotspot.
    Sensor that checks for liquid in the charging port.
    Samsung's pointless oxygen levels in blood / heartbeat sensor.
    "Pedometer".
    Gyro/etc. for VR.
    2
    -z: enable compression with a specified algorithm (any, none, brotli)

    i.e. It compresses the data before sending it to reduce network backup time. Does not compress the final userdata image stored on the disk.

    There is no way to separate out the data because the partition is encrypted.

    The userdata.img will be big because it makes a complete clone of the userdata partition including internal storage.

    What I do to reduce backup size is to set the backup target folder flag (in Windows) to compress. This makes a massive difference to the file size and even the backup time. In my case the uncompressed userdata.img is 110GB, but the space used on the hard drive is 2.1 GB. Total backup time is around 12 mins.

    You can also use "dd" with "gzip" to make the backup and compress the data too.
    2
    First off, thank you for making this.
    Been using the microg fork for a couple of days, so I thought I'd share a list of things that I had/have issues with or that don't work.
    Most of these issues should also be present on this official ROM, as it's just the google services backend that's different.
    I'm also new to modern smartphone ROMs, so please don't bash me if I say something dumb.

    Using on an S10+ Exynos. SM-G975F
    Installation went just fine on Arch Linux.

    Lockscreen/locked related:
    Always on Display doesn't shift the clock every minute, so there's a chance of burn-in.
    Always on Display has a clump of maybe 5 pixels next to the front cameras that constantly blink green.
    Wave to wake up doesn't work.

    Microg related, had to install DroidGuard Helper from FDroid to get the fingerprint sensor working. Works well and much quicker than on the stock Samsung ROM.

    Random issues:
    Status bar doesn't change to a dark font with a light wallpaper. Works just fine in apps.
    Adaptive brightness seems to be having issues actually doing anything, very often.
    There are no built-in torch intensity settings.
    Most likely microg related, doesn't automatically pick up auth codes from SMS as there's no daemon for it.

    Frequently asked about features:
    Wireless hotspot working just fine.
    5GHz wifi working just fine.
    Bluetooth working just fine. No issues with wireless earbuds, paired instantly.
    LTE working as expected, signal is fine. Central EU. TMobile network.

    Camera:
    Stock camera app doesn't let you change lenses or video framerate to 60 fps.

    Using the GCam fork mentioned somewhere above "MGC_8.1.101_A9_GV1r_MGC"
    Wide angle lens working, normal lens working, no telephoto.
    Both front cameras working
    Takes some time to switch between any of these.
    You can force [email protected] video with stabilization and all the nice things in the settings.
    No 4K video for the front cameras, it caps at [email protected]

    Not tested:
    NFC/Contactless Payments.
    Dual sim
    SD card slot
    USB hotspot.
    Sensor that checks for liquid in the charging port.
    Samsung's pointless oxygen levels in blood / heartbeat sensor.
    "Pedometer".
    Gyro/etc. for VR.
    We already have camera libs which enables RAW... Linux is going to add them in his build soon.
    2
    I have used dd for years with Linux and never seen a corruption issue. In fact I've never heard of it before today. (bs=1000 is not much better than the default)

    With the restore: I haven't tried piping data to adb for a few years, but the last time I did, it didn't work. (A bug of some sort in adb)

    To test it I would make sure you get the latest version of adb, plus you will need a copy of gzip on your computer. The syntax will look like this:

    gzip -c -d boot.dd.gz | adb shell "dd of=/dev/block/sda14 bs=65536"

    p.s. Make sure you have the ability to restore the partition by other means before testing this.

    Alternatively you can do a three step process like this:

    adb push -z any boot.dd.gz /
    adb shell "gunzip -c boot.dd.gz | dd of=/dev/block/sda14 bs=65536"
    adb shell rm boot.dd.gz


    Yes I increased it albeit to 1000 with only a minute time saving on the larger partition. I read somewhere that there's an increased chance of introducing errors with larger block sizes, though it is tempting. Are my restore commands correct?
  • 31
    1607247455067.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions:
    Only the provided lineage recovery will be supported, using TWRP might result in a possible data loss!
    Note: You may use Odin instead of Heimdall, for this you will need to rename the recovery image to recovery.img and pack it into a tar archive.

    Downloads:

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    Support
    Telegram group

    Contributors
    Linux4
    Source Code: https://github.com/LineageOS
    Kernel source: https://github.com/LineageOS/android_kernel_samsung_exynos9820
    5
    Any way around it? I like this rom but if updater is gonna get stuck because I'm using magisk I had to change back kraken rom 🥲 not that I prefer aoskp

    You could join the telegram group to find some early access build of some magisk fork that has addon.d working with FBE (topjohnwu is not even willing to merge an already existing fix as seen here: https://github.com/topjohnwu/Magisk/pull/3037)
    Other than that you could install magisk by just patching boot.img in the app instead of sideloading it in recovery (for now) which should make it not install addon.d.
    5
    First of all, I appreciate your work a lot. I've been waiting quite a long time for an official lineageos build for the s10, and you nailed it, you're even fixing the few bugs remained.
    Anyway, why are you saying TWRP would brick a device? I followed your suggestions of installing lineageos recovery and it works great, but I had TWRP in my previous device for about 2 years and I never had a problem

    Hi Linux4,
    Just a bit curious about you thoughts on TWRP. Indeed, it has been around for a while, has many features and is very popular, and your statement looked quite strong for me, but probably for good reasons. Is it simply not adapted to your ROM, or is it not adapted to the s10 phones, or has it gone bad generally? I am still using TWRP for all the added features that the Lineage recovery doesn't have, but will switch based on your advice.
    TWRP is way too bloated for a recovery IMO - it's more likely to break something than help you nowadays
    Especially that it's heavily touching /data isn't good on devices with FBE, like on this ROM, TWRP randomly messes up FBE policy (especially on OTAs it seems) rendering the device unbootable without wiping (which is why OP says using TWRP = data loss) which is what I referred to with (soft)"brick"
    Not to talk about that crap not even properly formatting data on standard "factory reset" which makes it not boot on this ROM.
    Also applies to other devices using FBE encryption including Tab S6 Lite and S20 series.
    Older devices that use legacy FDE instead don't seem to have similar issues afaik.

    PS: TWRP looses most of it's "features" with encrypted userdata.
    5
    my safetynet fails, is there any way to make it pass? s10 exynos

    First you need to install magisk and then:


    1) Enable settings MagiskHide
    2) install MagiskHide Props Config(Magisk module)
    3) Open the terminal
    4) su
    5) Type "props"
    6) Edit 1 fingerprint of the device
    7) Choose a certified fingerprint
    8) 21 Oneplus
    9) Find an Android 11 device (OnePlus 8T global 44)
    10) Follow the instructions
    11) Restart
    12) Clear Google Play Store Data
    13) Check SafetyNet (should pass)
    14) Open MagiskHide (Magisk -> Tap on the Shield symbol)
    15) Check all apps that do not require root privileges
    4
    I do the same with every OTA: let the system install it, seeing that it does not finish in 2-3 or so minutes, reboot (but not to recovery, just a simple reboot via holding power&vol- for >7s) - and there's the viola! A hack for sure, but it works.

    Being stuck is caused by magisk's broken addon.d just in case you wonder why it happens