[ROM][OFFICIAL] LineageOS 18.1 weeklies for Xiaomi Poco F1

Search This thread

Retrial

Recognized Contributor
  • Jun 10, 2015
    1,104
    1,765
    Athens
    Samsung Galaxy S4
    Xiaomi Poco F1
    safty net not passing and device is not certified ...clean flashed how to solve this issue without rooting?

    Yes facing same issue. Developer can help.

    Lineage doesn't and will never use any hacks to pass safetynet. I am using a magisk module (props) to pass safetynet and its working well for me. You can also try using bitgapps as it has safetynet patch if you don't want to root. https://github.com/BiTGApps/BiTGApps/blob/master/docs/safetynet.md

    With magisk hide and magisk props not working for you ? I have moved to PE for the time being because of this issue.

    Check this out for SafetyNet
    Try latest Open GApps.
     
    Last edited:

    Demodroid

    Senior Member
  • Aug 1, 2017
    194
    95
    One possible bug is that exFAT support does not exist, can read the SD Card perfectly fine in TWRP and LineageOS 17.1.

    No 18.1 branch in:


    mkfs implementation on:

     
    Last edited:
    • Like
    Reactions: keypal and duttyend

    ilya_m

    Member
    Oct 28, 2010
    34
    8
    Upd about strange behavior: for me MX player working buggy displaying videos with HW+ decoder. I got like frame in 3 seconds. The HW works fine though
     

    mathew_ver1

    Member
    Apr 21, 2020
    8
    2
    Sadly the bug which I reported in 17.1 still persists in 18.1. We can't register fingerprint in 2 profiles. At first, I thought it could be an issue with FDE on my end and went on to clean flash 18.1 and switched to FBE. This bug still persists which indicates this is a device specific issue. I would be glad if you can take a look @bgcngm and thanks for all your invaluable work.

    My workflow involves 3 profiles and I have to enter password every time I switch to other 2 sadly. It's been bothering me since a year but I assumed it's my own device specific issue.

    Also found another bug related to profiles. Any type of media can't be played on secondary ones other than owner. Looks like it crashes the systemUI and locks the screen. This one is new to 18.1 and fingerprint bug is carried from 17.1

    Clean flashed everything from scratch. Just to be sure, reflashed MIUI and clean flashed LOS.

    People! test the above things and report if this affects you as well.

    Steps to reproduce-

    1. Create a second profile from Settings > multi users
    2. Play any video/music in 2nd profile. (It should crash and pause.
    3. try to enroll fingerprint (It shouldn't allow you unless you delete them in the first profile.)
     

    duttyend

    Senior Member
    Dec 18, 2012
    354
    196
    One possible bug is that exFAT support does not exist, can read the SD Card perfectly fine in TWRP and LineageOS 17.1.

    No 18.1 branch in:


    mkfs implementation on:

    The same thing happened to me after a clean flash (Lineage OS 18.1 kept saying the card was corrupt). I had to format it again to exFAT in TWRP and copy all my files back...
     
    • Like
    Reactions: Retrial

    fightforlife

    Member
    Oct 25, 2012
    32
    12
    I just checked my logs with the newest build 10.04. and found two things.
    I am not sure if this is worth a ticket, maybe someone can check this, then I can create some tickets.


    1. Quite often, around every 3 seconds I get the following error messages. I am not sure what the essService0 and cessService0 are for. Maybe someone knows?
    Code:
    04-11 22:06:18.244  6657  6668 E cessService0:8: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:18.332 16711 16722 E essService0:25: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:18.495 20907 20918 E essService0:39: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:18.582 19237 19249 E essService0:20: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:18.927 21399 21410 E essService0:39: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:18.961  6700  6712 E cessService0:9: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:18.985 23459 23470 E essService0:31: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:19.026  1461  1472 E essService0:19: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:19.026 23589 23600 E essService0:31: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:19.312  4500  4513 E cessService0:7: failed to create Unix domain socket: Operation not permitted
    04-11 22:06:20.253  6657  6668 E cessService0:8: failed to create Unix domain socket: Operation not permitted




    2. my Baseus 65W charger is not able to load the phone on simple 5V (on the USB C port). USB A with QC is working fine. Is this something that can be fixed in LOS? I am not sure who is the PD_VOTER and why he is asking for 5A. This value is not supported by the charger (Max [email protected] on USB C)

    Code:
    04-11 22:05:28.536     0     0 I PD_VOTER: val: 498000
    04-11 22:05:28.536     0     0 I USB_ICL : current vote is now 498000 voted by PD_VOTER,4,previous voted 498000
    04-11 22:05:28.536     0     0 I PL_ENABLE_INDIRECT: current vote is now 0 voted by USBIN_I_VOTER,0,previous voted 0
    04-11 22:05:28.536     0     0 I smblib_set_icl_current: set icl 498000
    04-11 22:05:28.557     0     0 I PD_VOTER: val: 5000000
    04-11 22:05:28.557     0     0 I USB_ICL : current vote is now 5000000 voted by PD_VOTER,4,previous voted 5000000
    04-11 22:05:28.557     0     0 I smblib_set_icl_current: set icl 450000
    04-11 22:05:28.557     0     0 I smblib_set_icl_current: set icl 5000000
    04-11 22:05:28.557     0     0 E PMI     : smblib_set_charge_param: usb input current limit: 5000000 is out of range [0, 3000000]
    04-11 22:05:28.557     0     0 E PMI     : smblib_set_icl_current: Couldn't set HC ICL rc=-22
    04-11 22:05:28.557     0     0 I PD_VOTER: val: 5000000
    04-11 22:05:28.557     0     0 I AICL_RERUN_VOTER: val: 425000
    04-11 22:05:28.557     0     0 I USB_ICL : current vote is now 425000 voted by AICL_RERUN_VOTER,13,previous voted 425000
    04-11 22:05:28.557     0     0 I smblib_set_icl_current: set icl 425000
    04-11 22:05:28.558     0     0 I PD_VOTER: val: 5000000
    04-11 22:05:28.558     0     0 I USB_ICL : current vote is now 5000000 voted by PD_VOTER,4,previous voted 5000000
    04-11 22:05:28.558     0     0 I smblib_set_icl_current: set icl 400000
    04-11 22:05:28.558     0     0 I smblib_set_icl_current: set icl 5000000
    04-11 22:05:28.558     0     0 E PMI     : smblib_set_charge_param: usb input current limit: 5000000 is out of range [0, 3000000]
    04-11 22:05:28.558     0     0 E PMI     : smblib_set_icl_current: Couldn't set HC ICL rc=-22
    04-11 22:05:28.560     0     0 W healthd : battery l=31 v=4223 t=30.0 h=2 st=2 c=-2637693 fc=3589000 cc=10 chg=a
    04-11 22:05:28.623  4500  4513 E cessService0:7: failed to create Unix domain socket: Operation not permitted
     
    • Love
    Reactions: duttyend

    HelmutK.

    Senior Member
    Jan 30, 2018
    75
    8
    How can I report a problem with the automatic brightness?

    My display turn automatic the to darkest but it doesn't regulate to more brightness although the controller is turn to it.
     
    • Like
    Reactions: Smultie

    duttyend

    Senior Member
    Dec 18, 2012
    354
    196
    Hello, I just freshly installed lineageos 18.1 on my Poco, but cannot find the mail application in lineageos
    Thanks for your help
    You're right, it is missing and I haven't read anything on that subject in this thread or in the release notes. The 'Exchange services' system app is present however...
     

    EinleVerNt

    Member
    Mar 30, 2021
    9
    4
    Also the "micro" version of Open G Apps didn't work properly

    You have to use MindTheGapps
    That did the trick indeed. Android Auto works again!

    Although it's not in the app drawer, but
    1. Here is how you can start it anyway, to edit the settings: https://www.androidguys.com/tips-tools/android-auto-missing-on-your-phone-heres-how-to-get-it-back/
    2. Once set up via (1), it's launched automagically when connecting your phone to your car
     

    Top Liked Posts

    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone