• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][OFFICIAL] LineageOS 18.1 - Xiaomi Mi 8

Search This thread

stepkas1

Member
May 7, 2019
6
1
upgraded from 16 to 17.1 Issues spotted:
1. bootloop when updating the nightly build after installing magisk, fixed by disbaling the force /data/ encryption. Which now means i cannot update nightly builds manually.. should patch disable force encryption every time the rom is updated... thinnking of putting that in addon.d if it's possible
2. "Ok google" is not working. Can't enable that in settings
3. Bluetooth audio is strange.. i have 70% for not playing the song, but if the song starts it works just great. Also sometimes headphones do not play sound
4. cts profile thing... fixed by magisk core + magisk hide
 
I suggest not to follow the official recommended adb-sideload method as described here:
https://wiki.lineageos.org/devices/dipper/upgrade
.. I. just copied both zips (17.1 / GApps for Android 10) to sdcard the folder where the cfg from LOS 16 installation was still located. Then I booted to TWRP and only installed both files together without any patition wipe or cache clearing over the existing installation.
It worked fine for me and my cfg-file worked too.

To confirm: You came from LOS 16 and did not install any new Firmware? Everything is working fine? Device encryption is used? Is Magisk present and if so, did you uninstall / reinstall or just flash 17.1 like a normal update with Magisk present and running its script after the LOS update?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    opengapps arm64 android11 is ready for download
    2
    Is there a reason why we didn't see an update after lineage-18.1-20210624?
    Yes:

    But they are running again:
    1
    @infrag
    BSG Cam log
    Maybe you can see the issue with last 18.1 from 24.6.
    1
    Thanks for update. Battery life looks very good... :)

    I see difference in color richness between LOS 17 and LOS 18. On LOS 17 colors was vivid but on 18.1 are like washed despite I set colors to 'Boosted" in Screen settings. It's only me? :oops:
    I can actually reproduce this, contrarily to others who stated it was not a ROM-related issue, but some steps are needed to trigger it (and probably it is not HDR-related)

    It's certain apps that, when viewing media content (even non-HDR content), cause the display color profile to get messed up. You can reproduce this by viewing any image on Slide for Reddit (open source Reddit client).

    It is also a problem which affected LineageOS some years ago, and now it's back. It did not affect LOS17.1.

    In the attached screenshot there are the only log lines seemingly related to this issue, which get written as soon as the app displays an image (and cause the color profile to get immediately messed up)
    1
    With the latest build i have massive camera problems. With BSG GCam Mod i can make a piture but HDR never completes. After a while the camera app doesnt open anymore. Also the Build in camera app says "Can't connect to camera" and also the flashlight is not working. I found an older thread that describes the Problem: https://gitlab.com/LineageOS/issues/android/-/issues/1769

    I switched back to 2021-06-17 Build an now the Camera is working fine.
    +1
  • 68
    https%3A%2F%2Fimg.xda-cdn.com%2Fy-LtXHGCDBH0KxFw9MxWAPF3guk%3D%2Fhttp%253A%252F%252Fi.imgur.com%252F2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    GPL compliance:


    Device tree source code: LineageOS/android_device_xiaomi_dipper
    Kernel source code: https://github.com/LineageOS/android_kernel_xiaomi_sdm845




    Compatibility:
    Compatible with Xiaomi Mi 8
    Builds are based off the Xiaomi's Android 10 firmware.
    Downloads:
    Official download links: https://download.lineageos.org/dipper

    Lineage 18.1 Kernels:
    15/06/2021

    Lineage 18.1 Unofficial builds:

    Build 15/06/2021



    Recommended firmware is latest MIUI stable firmware.



    Notice:
    No custom kernels are supported in this thread. Only stock kernel and official builds will be supported. No bug reports if that's not the case.

    Installation:
    Reboot to recovery (TWRP recovery for Mi 8)
    Format /system, /data and /cache
    Install MIUI firmware
    Install LineageOS zip package
    Install [optional] a Google Apps package of your choice

    Important notes:
    * Required * firmware version must be based on MIUI *-based builds.
    Formatting data (all user data is wiped, including internal storage) is a must if MIUI was previously installed and device was encrypted.

    All LineageOS team would like to thank everyone involved in helping with testing, coding, debugging & documenting! Enjoy!
    19
    so the newest build 04/11/2019 uses Xiaomi Q blobs.
    Therefore it has some bugs:
    I havent got bluetooth audio working yet. Bluetooth calls seem to work fine though.
    Sound: Speaker works if you make a phone call first and switch to speaker during the call. After that everything else starts working.
    Edit: fixed. - GPS all satellites should show up now.
    Android Auto fixes probably havent been added yet to lineage but when anything shows up I'll add it.

    The reason this build took so long to be released is that Q radio blobs kept causing a reboot when data was used and switched to low power mode. I believe I have fixed this.


    https://drive.google.com/open?id=1bhurP2zIyZf93jJzSN1IBbiMBhmbSd_h

    Edit: Uploaded the correct build now. Also added in gps fix
    17
    Also fyi I'd hoped to have anther build up by now but since lineage has changed to 17.1 branches instead of 17.0 my build system is a bit of a mess. Waiting for all the repos to be updated to 17.1 before releasing anything. Hopefully it wont be too long...
    15
    18/12/2019 finally a working q build with q blobs and working audio.
    havent tested it a lot so any bugs let me know. There will be a v2 of the audio fix/change. This fix was just to make it work. :)
    14
    new build in OP.
    For android auto users unless I say otherwise I have not fixed your problem yet. :|