• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][montana][10] LineageOS 17.1

Search This thread

JarlPenguin

Recognized Developer
Oct 16, 2018
983
879
Earth
github.com
Moto G5S
Moto G7
2okPze5.png

Code:
#include <std_disclaimer.h>

/*
* Your warranty is now void.
*
* We are not responsible for bricked devices, dead SD cards,
* thermonuclear war, or you getting fired because the alarm app failed. Please
* do some research if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at us for messing up your device, we will laugh at you.
*
*/

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

Instructions:
  • Download the latest build, official TWRP (3.3.1 and newer) and GApps (if you need them)
  • Flash the downloaded TWRP via fastboot
  • Boot to recovery
  • Format system, vendor, data, cache, and dalvik cache
  • Reboot to recovery
  • Flash the latest build
  • Flash GApps and any other necessary add-ons

What's working:
  • WiFi
  • Camera and Camcorder
  • Bluetooth
  • NFC
  • Fingerprint - Oreo firmware required
  • GPS
  • OTG
  • Video Playback
  • Audio
  • RIL
  • VoLTE/VoWiFi
  • USB tethering/audio
  • SELinux: Enforcing

Known issues:
  • You tell me

Downloads:
  • Official builds: Download
  • Recovery: Official TWRP
  • Google Apps: OpenGApps (nano package is advisable, but you definitely should avoid using stock/super packages)

Reporting Bugs
  • All bugs should be reported here: Issue Tracker
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:

Did you--
wipe:
restore with titanium backup:
reboot after having the issue:

Are you using--
a task killer:
a non-stock kernel:
other modifications:

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

Thanks to:
@GivFNZ for testing my builds
@wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
LineageOS team

Changelogs:

Code:
2020-11-19:
Updated kernel based on Moto's Moto One (deen) QPKS30.54-12-23 tag and CAF's LA.UM.8.6.r1-05300-89xx.0 tag
Updated Moto Actions UI
Improved boot animation speed and smoothness
Partially resolved perf HAL spam in logs

2020-11-15:
Added support for montana_retcn (XT1799-2)
Fixed a bug where the back flash wouldn't work properly when taking a photo using Snap
Fixed a bug where loudspeakers would crackle on some VoIP calls
Improved RIL stability
Improved Wi-Fi stability
Increased ZRAM to 1.33GB
Updated kernel based on Moto's Moto One (deen) QPKS30.54-12-22 tag and CAF's LA.UM.8.6.r1-04700-89xx.0 tag
Updated Moto Actions UI
November security patch

2020-10-11:
Added customizable vibration intensity in Settings > Accessibility
New FM radio app
Added support for factory reset protection (only partially effective)
Fixed boot with SELinux: Enforcing on GSIs
October security patch

2020-09-23:
Minor improvements and under the hood changes (check technical changes for more details)

2020-09-20:
Improved GPS stability
Fixed an issue where there would be random UI lag

2020-09-17:
Fixed an issue where you couldn't exit from offline charging mode

2020-09-16:
Fixed offline charging

2020-09-15:
Actually fixed random color inversion that could occur (Note: Color calibration in LiveDisplay is no longer available as a result of fixing the bug)
Fixed bootloop when enabling secure startup
Fixed manual network selection
Fixed dual SIM menu not appearing - needs testing
Mobile data settings now only displays 3 modes (LTE, 3G and 2G)
September security patch

2020-09-11:
Fixed random color inversion that could occur

2020-09-10:
Fixed Wi-Fi Display
Updated listen blobs to Q
Added support for Color profiles (Settings > Display > Colors)
Fixed an issue where you couldn't connect to certain Wi-Fi networks

2020-09-08:
Initial release.


Source code:
 
Last edited:

Dan Mornill

Senior Member
May 7, 2019
102
11
Just flashed it, working very fine, thanks a lot.
A minor bug I can't explain : some of the menus stay in English even if I select another language.
 
Last edited:

rakion99

Member
Mar 13, 2015
21
7
does this and lineage os 16 need something apart from oreo firmware? because i tried both with all twrp versions available and when rebooting after flashing zip it just always send me to the bootloader.
i have model xt1790
before i was on carbon rom and was working fine so i dont know what is wrong here, also tried lineage os from AsD Monio and works fine just the initial setup a bit buggy
recovery log: https://pastebin.com/Y0GjaHtZ
logcat right after reboting to recovery after wiping all then flashing this rom: https://pastebin.com/mvVQ12Zb
 

JarlPenguin

Recognized Developer
Oct 16, 2018
983
879
Earth
github.com
Moto G5S
Moto G7
does this and lineage os 16 need something apart from oreo firmware? because i tried both with all twrp versions available and when rebooting after flashing zip it just always send me to the bootloader.
i have model xt1790
before i was on carbon rom and was working fine so i dont know what is wrong here, also tried lineage os from AsD Monio and works fine just the initial setup a bit buggy
recovery log: https://pastebin.com/Y0GjaHtZ
logcat right after reboting to recovery after wiping all then flashing this rom: https://pastebin.com/mvVQ12Zb

No, but please make sure to use the latest TWRP version. You must also format data (not wipe). Also, recovery logs won't help due to them only showing what's happening in the recovery.
 

Dan Mornill

Senior Member
May 7, 2019
102
11
Just flashed v1.2 working also fine 😀

One question though : on the Moto Camera v6.2 app the HDR option is no more visible (it was on latest Pie builds).

Edit : persistent even when installing via the Moto Camera Thread tutorial
 
Last edited:

rakion99

Member
Mar 13, 2015
21
7
No, but please make sure to use the latest TWRP version. You must also format data (not wipe). Also, recovery logs won't help due to them only showing what's happening in the recovery.

rn im on latest 3.4.0-1 and i tried both format and wipe, dirty flashing from the other los 17.1 and other rom just to test but all end in always booting to bootloader menu its weird never happened something similar and only happen with your lineageos 16 and 17.1 roms
 

JarlPenguin

Recognized Developer
Oct 16, 2018
983
879
Earth
github.com
Moto G5S
Moto G7
rn im on latest 3.4.0-1 and i tried both format and wipe, dirty flashing from the other los 17.1 and other rom just to test but all end in always booting to bootloader menu its weird never happened something similar and only happen with your lineageos 16 and 17.1 roms
Do you have full Oreo firmware installed? Also can't do anything without logs
 

JarlPenguin

Recognized Developer
Oct 16, 2018
983
879
Earth
github.com
Moto G5S
Moto G7
Just flashed v1.2 working also fine 😀

One question though : on the Moto Camera v6.2 app the HDR option is no more visible (it was on latest Pie builds).

Edit : persistent even when installing via the Moto Camera Thread tutorial

It's because we use HAL3 now. Certain functions won't work because we use deen blobs instead of stock camera blobs
 

rakion99

Member
Mar 13, 2015
21
7
Do you have full Oreo firmware installed? Also can't do anything without logs

i didn't remember but looks like i got a old one or a fix fingerprint zip most probably, took me a day to find a working link to full 8.1 and after 2 updates from ota i got M8937_37.13.03.75R baseband and now worked perfectly your rom thank you for keeping alive our moto g5s
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    *
    */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Instructions:
    • Download the latest build, official TWRP (3.3.1 and newer) and GApps (if you need them)
    • Flash the downloaded TWRP via fastboot
    • Boot to recovery
    • Format system, vendor, data, cache, and dalvik cache
    • Reboot to recovery
    • Flash the latest build
    • Flash GApps and any other necessary add-ons

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • NFC
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE/VoWiFi
    • USB tethering/audio
    • SELinux: Enforcing

    Known issues:
    • You tell me

    Downloads:
    • Official builds: Download
    • Recovery: Official TWRP
    • Google Apps: OpenGApps (nano package is advisable, but you definitely should avoid using stock/super packages)

    Reporting Bugs
    • All bugs should be reported here: Issue Tracker
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Thanks to:
    @GivFNZ for testing my builds
    @wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
    LineageOS team

    Changelogs:

    Code:
    2020-11-19:
    Updated kernel based on Moto's Moto One (deen) QPKS30.54-12-23 tag and CAF's LA.UM.8.6.r1-05300-89xx.0 tag
    Updated Moto Actions UI
    Improved boot animation speed and smoothness
    Partially resolved perf HAL spam in logs
    
    2020-11-15:
    Added support for montana_retcn (XT1799-2)
    Fixed a bug where the back flash wouldn't work properly when taking a photo using Snap
    Fixed a bug where loudspeakers would crackle on some VoIP calls
    Improved RIL stability
    Improved Wi-Fi stability
    Increased ZRAM to 1.33GB
    Updated kernel based on Moto's Moto One (deen) QPKS30.54-12-22 tag and CAF's LA.UM.8.6.r1-04700-89xx.0 tag
    Updated Moto Actions UI
    November security patch
    
    2020-10-11:
    Added customizable vibration intensity in Settings > Accessibility
    New FM radio app
    Added support for factory reset protection (only partially effective)
    Fixed boot with SELinux: Enforcing on GSIs
    October security patch
    
    2020-09-23:
    Minor improvements and under the hood changes (check technical changes for more details)
    
    2020-09-20:
    Improved GPS stability
    Fixed an issue where there would be random UI lag
    
    2020-09-17:
    Fixed an issue where you couldn't exit from offline charging mode
    
    2020-09-16:
    Fixed offline charging
    
    2020-09-15:
    Actually fixed random color inversion that could occur (Note: Color calibration in LiveDisplay is no longer available as a result of fixing the bug)
    Fixed bootloop when enabling secure startup
    Fixed manual network selection
    Fixed dual SIM menu not appearing - needs testing
    Mobile data settings now only displays 3 modes (LTE, 3G and 2G)
    September security patch
    
    2020-09-11:
    Fixed random color inversion that could occur
    
    2020-09-10:
    Fixed Wi-Fi Display
    Updated listen blobs to Q
    Added support for Color profiles (Settings > Display > Colors)
    Fixed an issue where you couldn't connect to certain Wi-Fi networks
    
    2020-09-08:
    Initial release.


    Source code:
    8
    Hi all, in case you're wondering why there has been a lack of builds last month and this month, this is because we are awaiting official status, so if you could be understanding I'd appreciate it a lot!
    6
    First official build is up at https://download.lineageos.org/montana. Clean flash will be required when switching (because Lineage signs their ROMs with their own keys).
    2
    Thanks alot Jarl. official build is working way better than stock ever did.
    I just wish motorola would not have cheaped out on battery. My old sony have better SOT with similar capacity.
    @JarlPenguin you sir, are a one man army :cowboy:
    2
    I know that and I have, my fingerprintsensor is working fine. I'm talking about that extra MotoActions, here using on Moto G5S with the Rom mentioned before - I attached some screenshots

    Recent flashed this ROM, great experience!

    About finger gesture, try this
    System -> Button -> Enable/Disable navigation bar on screen (the first one in top)

    Buttons should be gone, and the finger print sensor should make the back, home, apps function again.
    (Block device from 2 tap is gone)

    PS - Sorry for bad english