[ROM][OFFICIAL][montana][10] LineageOS 17.1

Search This thread

YoShake

Member
Oct 8, 2020
12
1
Does anyone have a clue how to enable arrow keys in default aosp keyboard with enabled gesture navigation? Option seems to be available only with screen navigation stripe :\

Only solution is a 3rd party keyboard app?
 

quantum_espresso

New member
Feb 26, 2021
1
0
hello guys,
After today's 17.1 update, my battery percentage not showing the real situation and only after a few restarts it would show that the battery have lost quite a few % after a while.
Not sure if it's a bug.
I have updated it to the latest 17.1 version as usual.
 

mattdpollard

Member
Sep 9, 2020
13
2
Hi, last few builds thé média scanner stops working at some point after each reboot. New photos dont show in gallery or some other apps, unless manually trigger scan with a scantrigger app or reboot phone. Any ideas? Thanks!
 

Mirrorsluck

New member
Mar 14, 2013
1
0
Hi guys, I'm the only one that occurred in a boot loop? I unlocked bootloader, flashed TWRP 3.4.0-1 and successfully installed the .zip. Boot loop... Moto G5S montana. Always have the same boot loop, no matter which OS version!

LineageOS version: 16.1 UNOFFICIAL / 17.1 OFFICIAL signed / 18.1 UNOFFICIAL
LineageOS Download url: Github, LineageOS, Github
Gapps version: No Gapps, do not want Google play services!

Did you--
wipe: Dalvik, Data, Cache, System, Vendor
restore with titanium backup: NO
reboot after having the issue: YES

Are you using--
a task killer: NO
a non-stock kernel: NO, just OEM unlocked
other modifications: TWRP 3.4.0-1 / 3.4.1 / 3.5.0
Hello guys. I had the same problem as magio.dev and I managed to solve (at least it in my case, yours might be different).

No matter which version of LOS I flashed and how, it was stuck in boot forever. And I gave up on LOS and tried to flash some stock ROM. And then I realised that the problem might be in the fact that my G5S XT1794 was still running Android 7.1.1 Nougat as there was no official automatic update to 8.1.1 in my region (as far as I got to know).

Of course I knew about this before I decided to flash LOS, but I thought that it doesn't matter - we're flashing whole device, right? No, it turns out that it matters.

So I downloaded an appropriate stock 8.1.1 ROM for my region and while I was searching for a correct method to flash it, I found out about existence of Rescue and Smart Assistant form Lenovo.

As I was tired, resigned and scared of bricking my phone I decided to use this tool. It downloaded a ROM on it's own and worked pretty well (apart from the fact that you have to register to Lenovo and agree to some kind of weird stuff).

So after this thing flashed 8.1.1 into my Montana I installed LOS as before. It worked.

TLDR; If you have infinite boot after flashing LineageOS, make sure that your stock ROM is 8.1.1 - in my case it was 7.1.1 and it was the issue. After updating to 8.1.1 everthing worked fine.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    2okPze5.png

    Code:
    #include <std_disclaimer.h>
    
    /*
    * Your warranty is now void.
    *
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.
    *
    */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Instructions:
    • Download the latest build, official TWRP (3.3.1 and newer) and GApps (if you need them)
    • Flash the downloaded TWRP via fastboot
    • Boot to recovery
    • Format system, vendor, data, cache, and dalvik cache
    • Reboot to recovery
    • Flash the latest build
    • Flash GApps and any other necessary add-ons

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • NFC
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE/VoWiFi
    • USB tethering/audio
    • SELinux: Enforcing

    Known issues:
    • You tell me

    Downloads:
    • Official builds: Download
    • Recovery: Official TWRP
    • Google Apps: OpenGApps (nano package is advisable, but you definitely should avoid using stock/super packages)

    Reporting Bugs
    • All bugs should be reported here: Issue Tracker
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Thanks to:
    @GivFNZ for testing my builds
    @wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
    LineageOS team

    Changelogs:

    Code:
    2020-11-19:
    Updated kernel based on Moto's Moto One (deen) QPKS30.54-12-23 tag and CAF's LA.UM.8.6.r1-05300-89xx.0 tag
    Updated Moto Actions UI
    Improved boot animation speed and smoothness
    Partially resolved perf HAL spam in logs
    
    2020-11-15:
    Added support for montana_retcn (XT1799-2)
    Fixed a bug where the back flash wouldn't work properly when taking a photo using Snap
    Fixed a bug where loudspeakers would crackle on some VoIP calls
    Improved RIL stability
    Improved Wi-Fi stability
    Increased ZRAM to 1.33GB
    Updated kernel based on Moto's Moto One (deen) QPKS30.54-12-22 tag and CAF's LA.UM.8.6.r1-04700-89xx.0 tag
    Updated Moto Actions UI
    November security patch
    
    2020-10-11:
    Added customizable vibration intensity in Settings > Accessibility
    New FM radio app
    Added support for factory reset protection (only partially effective)
    Fixed boot with SELinux: Enforcing on GSIs
    October security patch
    
    2020-09-23:
    Minor improvements and under the hood changes (check technical changes for more details)
    
    2020-09-20:
    Improved GPS stability
    Fixed an issue where there would be random UI lag
    
    2020-09-17:
    Fixed an issue where you couldn't exit from offline charging mode
    
    2020-09-16:
    Fixed offline charging
    
    2020-09-15:
    Actually fixed random color inversion that could occur (Note: Color calibration in LiveDisplay is no longer available as a result of fixing the bug)
    Fixed bootloop when enabling secure startup
    Fixed manual network selection
    Fixed dual SIM menu not appearing - needs testing
    Mobile data settings now only displays 3 modes (LTE, 3G and 2G)
    September security patch
    
    2020-09-11:
    Fixed random color inversion that could occur
    
    2020-09-10:
    Fixed Wi-Fi Display
    Updated listen blobs to Q
    Added support for Color profiles (Settings > Display > Colors)
    Fixed an issue where you couldn't connect to certain Wi-Fi networks
    
    2020-09-08:
    Initial release.


    Source code:
    8
    Hi all, in case you're wondering why there has been a lack of builds last month and this month, this is because we are awaiting official status, so if you could be understanding I'd appreciate it a lot!
    6
    First official build is up at https://download.lineageos.org/montana. Clean flash will be required when switching (because Lineage signs their ROMs with their own keys).
    2
    Thanks alot Jarl. official build is working way better than stock ever did.
    I just wish motorola would not have cheaped out on battery. My old sony have better SOT with similar capacity.
    @JarlPenguin you sir, are a one man army :cowboy:
    2
    I know that and I have, my fingerprintsensor is working fine. I'm talking about that extra MotoActions, here using on Moto G5S with the Rom mentioned before - I attached some screenshots

    Recent flashed this ROM, great experience!

    About finger gesture, try this
    System -> Button -> Enable/Disable navigation bar on screen (the first one in top)

    Buttons should be gone, and the finger print sensor should make the back, home, apps function again.
    (Block device from 2 tap is gone)

    PS - Sorry for bad english
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone