• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][montana][11] LineageOS 18.1

Search This thread


Recognized Developer
Oct 16, 2018
Moto G5S
Moto G7
First of all, awsome work. Thanks for all of this.
I see though unofficial this is a good place to "report" a bug or at least do a heads-up.
I have an XT1794 latest montana linage build from today.
If I plug analogic earphones I can't controll the volume during a network call.
Volume is controlable in any other circumstance (Bluetooth earphones, or IP calls on analog earphones).

Is there anything I can provide you to help tackle this?
What do you mean by network calls? How are they different from IP calls?


Senior Member
Aug 14, 2014
Finally got the upgrade through and everything set up with no data loss.
Some tips:
1. If you are using MAGISK make sure to remove or disable all modules before reflashing the patched boot.img. I got into a bootloop and had to "fastboot boot twrp.img" into twrp to go into the data partition to manually remove the modules.
2. If you are using MICROG make sure to update fakestore.apk to the latest version for android 11 compatibility. Also the nanodroid patcher method to fake signatures doesnt work anymore so you have to use a patched xposed or lsposed module (Fakegapps by whew-inc)

Other than that everything looks okay except the power menu (long press power button) which is now a full black screen with only 3/5 options visible. Not sure if it's supposed to look like that, the 17.1 version was more useful

I aslo used @mattdpollard tip to remove pin and figerprint before upgrading, just to be sure


New member
Jul 27, 2021
What do you mean by network calls? How are they different from IP calls?
Hi! I mean cellular phone carrier network (using the dialer) vs Internet based (Whatsapp, Duo etc). On the first ones toggling the volume while on wired earphones does nothing, on the second ones it works perfectly.

Ps: I've tried the linage stock dialer and the Google one from play store, same result.


Senior Member
Nov 1, 2011
I've been having problems with multitasking in this rom. apps are being closed by the system as soon as I switch apps or hit home. I need apps to run in the background, without closing, are there any config Im missing?
*EDIT* - managed a workaround, if anyone interested can see it here.
Last edited:


Senior Member
Dec 2, 2020
127|montana:/ # ls -l /persist
total 108
drwxrwx--- 2 system system 4096 1970-01-01 05:31 alarm
drwxr-xr-x 2 mot_pwric mot_pwric 4096 2019-06-18 23:37 batt_health
drwxrwx--- 2 bluetooth bluetooth 4096 2017-06-27 12:45 bluetooth
drwx------ 2 root system 4096 1970-01-01 05:31 bms
drwxr-xr-x 2 mot_tcmd bluetooth 4096 1970-01-01 05:31 bt
drwxr-xr-x 5 mot_tcmd mot_tcmd 4096 1970-05-20 00:11 camera
drwxrwx--- 2 system system 4096 1970-02-02 09:18 chargeonly
drwx------ 6 system system 4096 2018-05-08 12:33 data
drwxrwx--- 2 system graphics 4096 1970-02-02 09:18 display
drwxrwx--- 2 system system 4096 1970-01-01 05:31 drm
drwxr-xr-x 5 mot_tcmd mot_tcmd 4096 2017-06-27 12:46 factory
drwxrwx--- 3 oem_2903 oem_2904 4096 1970-01-01 05:31 hlos_rfs
drwx------ 2 root root 4096 1970-01-01 05:30 lost+found
drwxrwx--- 2 radio radio 4096 2017-06-27 12:45 mdm
drwxrwx--- 2 system system 4096 1970-01-01 05:31 misc
drwxrws--- 2 mot_tcmd mot_tcmd 4096 1970-02-02 09:17 paks
drwxrwx--- 2 system system 4096 1970-10-23 17:57 properties
drwxr-xr-x 11 mot_tcmd mot_tcmd 4096 1970-02-02 09:17 public
drwx--x--x 6 oem_2903 oem_2903 4096 1970-01-01 05:31 rfs
drwx------ 2 system system 4096 1970-01-03 02:07 sds
drwxrwx--- 2 system system 4096 1970-02-02 09:18 secnvm
drwxrws--- 2 drmrpc drmrpc 4096 2018-05-08 12:33 security
drwxrwxr-x 3 system system 4096 1970-02-02 09:18 sensors
drwxrwx--- 2 system system 4096 2019-06-19 05:59 time
drwxrwx--- 2 media media 4096 1970-02-02 09:18 vpp
drwxr-xr-x 2 mot_tcmd mot_tcmd 4096 1970-01-01 05:31 wifi
drwxrwxr-x 2 mot_drm mot_drm 4096 1970-01-01 05:31 wmdrm


Senior Member
Dec 2, 2020
I'm flashing los 18.1 and I'll see if anything changes...
What should I do now, I'm back on stock ROM and its still like that...
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Hi, normally I post here only when there is a problem. This time I wanted to post just to say everything has been working very smoothly for weeks and I really appreciate all the work that goes into making that happen!
    Tried APN settings through YouTube but not working.
    Use the jio call app from play store, just be sure to keep data and location on all the time, it works for me...

    Set the location to allow all the time otherwise you will have issues with incoming and also, keep your mobile data and location always enabled to make and receive calls...
    An important notice for jio users,
    If the rom you use doesn't currently support VoLTE, then download this app to make and receive calls
    And set it up, then you will be able to make calls without native VoLTE support, but a few things are to be kept in mind to use this app without issues,
    1. Your mobile data must babe enabled all the time, because the app services only work with jio mobile data for now, so, connecting to a wifi network might prevent you from getting any calls
    2. You have to keep location enabled at all times, I don't know why but calls won't work without location being on, and also, if you use android 10 or Android 11 you have to manually change the app location access from 'Only while using the app' to 'Allow all the time' otherwise incoming won't work unless the app itself is open
    3. Don't worry if you run out of mobile data, this app can work normally even if your data has been exhausted, as long as your mobile data is on regardless of the remaining data
    4. Calling from this app won't use your data, so, don't worry about it, this app needs data only to maintain a connection with the jio servers, that's all, and that's the reason calls will still work, because the 5-10kbps speed after exhaustion of your data is good enough for the app to be connected to the jio servers...
    Edit: You must never enable battery saver otherwise calls won't come in...
    Got any permanent solution...?? Coz when connected to wifi it goes offline. And I don't want to go back to stock.
    Nope, no other solution, and I did mention beforehand that calls won't work when connected to a WiFi network, if you really want to use calls while connected to WiFi, then you must be connected to a JioFi network, so, yeah, stick to data for now
  • 3

    #include <std_disclaimer.h>
    * Your warranty is now void.
    * We are not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at us for messing up your device, we will laugh at you.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    • Download the latest build, recovery image and GApps (if you need them)
    • Flash the downloaded recovery image via fastboot
    • Boot to recovery
    • Format system and perform a factory reset
    • Reboot to recovery
    • Flash the latest build
    • Flash GApps and any other necessary add-ons

    What's working:
    • WiFi
    • Camera and Camcorder
    • Bluetooth
    • NFC
    • Fingerprint - Oreo firmware required
    • GPS
    • OTG
    • Video Playback
    • Audio
    • RIL
    • VoLTE
    • USB tethering/audio
    • SELinux: Enforcing

    Known issues:
    • VoWiFi
    • You tell me


    Reporting Bugs
    • All bugs should be reported here: Issue Tracker
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Thanks to:
    @GivFNZ for testing my builds
    @wiktorek140, @karthick mostwanted, @wh0dat, @KalilDev, @AsD Monio, @GoldeneyeS2, @Steve Mathew Joy and @rajatgupta1998 for their hard work on our device sources
    LineageOS team


    Initial 18.1 build.
    Initial release.

    Source code:
    I've uploaded a build for LineageOS 18.1. Official status will be gained shortly after we've tested things on a wider variety of devices.
    Hi, normally I post here only when there is a problem. This time I wanted to post just to say everything has been working very smoothly for weeks and I really appreciate all the work that goes into making that happen!
    Thank you! Just curious, what was the core reason of the issue?
    It was a problem with the F2FS driver.
    I'm not rushing him for updates, just a question to mention that someone still with some interest on his ROM
    I will continue with this project, but only after the 18.1 source is fully ready.