• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][OFFICIAL][ms013g][9] LineageOS 16.0 [EOL]

Search This thread

djchittoor

Senior Member
Mar 31, 2020
89
48
Trivandrum
So i flashed this rom and noticed some things;
1. No bootanimation, but booted super fast:D .Maybe a flashable zip will do the job but i didn't find any.
2. Brightness becomes pitch black at half. Disable the brightness bar in quick setting to avoid accidentally making your phone super dark.
But a great rom, great performance, and great battery life:cool: .Credits to @djchittoor well done!

Hi,

As for issue number 1 some particular panels are not supported referring to the 3rd party replacement panels as suspect it has to do with the kernel as before pie we were using the ms013g kernel now we are using an unified kernel brought up from S5 Mini kernel source... for issue number 2 I am aware of the issue I will guess its the brightness overlays so i will try to fix it ASAP:good::good:
 
  • Like
Reactions: alirezahabiz

djchittoor

Senior Member
Mar 31, 2020
89
48
Trivandrum
i have Last Android Original Update (G7102DDSBQF1)
And i have last Update linage (2020-08-08 ) install With TWRP Recovery 3.0.3 , But sim ( MIC & Speaker in call ) 2 DO NOT WORK .
If I use internet 3g on SIM 2, the sound and microphone call on SIM Card 1, similar to SIM Card 2 does not work.

Hi,

Thanks for reporting this. I will take a look at it.
 
  • Like
Reactions: alirezahabiz

K--R

Member
Jun 9, 2020
32
3
THIRUVANANTHAPURAM
Hi,

As for issue number 1 some particular panels are not supported referring to the 3rd party replacement panels as suspect it has to do with the kernel as before pie we were using the ms013g kernel now we are using an unified kernel brought up from S5 Mini kernel source... for issue number 2 I am aware of the issue I will guess its the brightness overlays so i will try to fix it ASAP:good::good:

No worries... Still the best rom I used in this phone!
Keep up the good work!!
 
  • Like
Reactions: alirezahabiz

alirezahabiz

Member
Nov 28, 2019
11
1
US
[/COLOR]
Hi,

Thanks for reporting this. I will take a look at it.

Thanks . If i Use 3G on Sim 1 , call ( MIC & Speaker ) Is Work . But IF i Use 2G or GSM , Dont Work .
Sim 2 Don't Work At all in Both 3g & 2G .
Bugs:
1_ After getting the update in the phone settings, I pressed the restart key in the update section settings , the update will not start in recovery. In fact, nothing happens.
(TWIPVersion 3.0.3 )

2_ format SD in internal : When I use internal SDCARD , Apps in internal , do not work .
And I can't install app on google store ,
When apps move on SD card app is hide in menu and don't work . apps deleted When I restart my phone ( when use internal SD card format )

3_ Auto Dark Mode : not work correct ly , please add manuall time (between 01:00 to 00:00 ) time . or more .
 
Last edited:

Ali-otman97

New member
Aug 22, 2020
1
0
Can't connect to a hidden wifi network

I am trying to connect to a hidden wifi network but the mobile doesn't find it, even though I checked the hidden WiFi option in the advanced options
Update: problem solved by flashing the rom again and flashing gapps
 
Last edited:
D

deepeshmeena

Guest
Does not charge if device shut off and also the google keep saying updating ok google

I have clean flash and using all thing stock provided by rom and gapps mini. The problem is when device is shut off, the device does not charges although samsung logo of charging and rom's logo of charging is shown but it does not charges I switched off and put it to charge and when I turn on the battery is was still 1%. Also google just keep spamming in notifications " Ok google voice model updating" and after few minutes it shows it as failed. I tried to set google assitant when first time setting phone and when in google assistant it asks to set up google assistant to enable advance feature and it shows problem while connecting error although my internet 100/20 is perfect and I tried other method too and is working properly in phone .
Last, the britghtness slider is not calibrated properly and only moving more than half real brightness began to change.
SORRY IF I MADE IT LONG BUT I AM LEARNING TYPING SO SOMETIMES I GOT OVEREXCITED.
 

usamael2000

New member
Aug 29, 2020
1
0
Thank you so much for this ROM

First of all, I would like to thank you so much for taking the time to develop this ROM for the Grand 2 mobile.
I replace my android 4.4 by this ROM 4 days ago and really love it. Now I can install and run applications that I was not able to use before.

I have a few issues:
1- sim 1 is working fine, but sim 2 is not. I can make/receive calls from/to sim 2, but cannot hear the other party and vice-versa. I tried different combinations to change the "preferred network mode" for both sims, but none worked for me.

2- The magnetic sensor and the compass are not working at all. Please note that the sensors tool applications show the details (name, vendor, etc.) of the magnetic sensor.

3- Although there are many satellites (around 20) show up when using the GPS status application, but did not get a location fix (coordinates) so far. I think this is related to issue #2.

I used this ROM: https://mirrorbits.lineageos.org/fu...neage-16.0-20200808-nightly-ms013g-signed.zip
In addition, I used Twrp v3.2.3.0 for Galaxy Grand 2 SM-G7102 (unofficial)[Updated]: https://forum.xda-developers.com/galaxy-grand-2/development/twrp-galaxy-grand-2-sm-g7102-t3778414)
and I used the arm architecture for Google Apps.

Thanks again
 

djchittoor

Senior Member
Mar 31, 2020
89
48
Trivandrum
[/COLOR]

Thanks . If i Use 3G on Sim 1 , call ( MIC & Speaker ) Is Work . But IF i Use 2G or GSM , Dont Work .
Sim 2 Don't Work At all in Both 3g & 2G .
Bugs:
1_ After getting the update in the phone settings, I pressed the restart key in the update section settings , the update will not start in recovery. In fact, nothing happens.
(TWIPVersion 3.0.3 )

2_ format SD in internal : When I use internal SDCARD , Apps in internal , do not work .
And I can't install app on google store ,
When apps move on SD card app is hide in menu and don't work . apps deleted When I restart my phone ( when use internal SD card format )

3_ Auto Dark Mode : not work correct ly , please add manuall time (between 01:00 to 00:00 ) time . or more .

Hi,

Sorry for addressing you late..

As for your bugs:-

1. as for this issue you just need to flash the latest twrp.
2. Can you provide a bit more info on this? I have personally tested this out and it works perfectly for me.
3. You just need to set your timezone correctly in the `Date and Time` in settings.

and as your report about the SIM2 problems, I initially thought it was something wrong with people's basebands but now as I am aware of the increasing reports about it .. I think its a problem from the vendor blobs we had some problems using klte RIL blobs and currently we are using the ones from stock anyways I will take a look into it more.

Thanks for reporting.
 

djchittoor

Senior Member
Mar 31, 2020
89
48
Trivandrum
First of all, I would like to thank you so much for taking the time to develop this ROM for the Grand 2 mobile.
I replace my android 4.4 by this ROM 4 days ago and really love it. Now I can install and run applications that I was not able to use before.

I have a few issues:
1- sim 1 is working fine, but sim 2 is not. I can make/receive calls from/to sim 2, but cannot hear the other party and vice-versa. I tried different combinations to change the "preferred network mode" for both sims, but none worked for me.

2- The magnetic sensor and the compass are not working at all. Please note that the sensors tool applications show the details (name, vendor, etc.) of the magnetic sensor.

3- Although there are many satellites (around 20) show up when using the GPS status application, but did not get a location fix (coordinates) so far. I think this is related to issue #2.

I used this ROM: https://mirrorbits.lineageos.org/fu...neage-16.0-20200808-nightly-ms013g-signed.zip
In addition, I used Twrp v3.2.3.0 for Galaxy Grand 2 SM-G7102 (unofficial)[Updated]: https://forum.xda-developers.com/galaxy-grand-2/development/twrp-galaxy-grand-2-sm-g7102-t3778414)
and I used the arm architecture for Google Apps.

Thanks again
Hi,

Sorry for the delay in responding.

As for for issues:-

1. https://forum.xda-developers.com/showpost.php?p=83431121&postcount=69
I have addressed your issue here in that post, please do wait till I find a proper fix for it and if you have telegram could you PM
me so we can test out the Radio blobs (t.me/djchittoor )

2. as for this issue our kernel has problems configuring the magnetic sensor it seems, I will take a look into and try to fix it ASAP
3. as for your issue with GPS, its related to LineageOS they have to merge some changes to fix the legacy GNSS hal that we are using and should in the coming updates

Thanks for reporting.. also appreciate with well explained report:good::good:
 

djchittoor

Senior Member
Mar 31, 2020
89
48
Trivandrum
I have clean flash and using all thing stock provided by rom and gapps mini. The problem is when device is shut off, the device does not charges although samsung logo of charging and rom's logo of charging is shown but it does not charges I switched off and put it to charge and when I turn on the battery is was still 1%. Also google just keep spamming in notifications " Ok google voice model updating" and after few minutes it shows it as failed. I tried to set google assitant when first time setting phone and when in google assistant it asks to set up google assistant to enable advance feature and it shows problem while connecting error although my internet 100/20 is perfect and I tried other method too and is working properly in phone .
Last, the britghtness slider is not calibrated properly and only moving more than half real brightness began to change.
SORRY IF I MADE IT LONG BUT I AM LEARNING TYPING SO SOMETIMES I GOT OVEREXCITED.


Hi,

Are you sure you are running the official builds? because I am pretty we dont have problems with offline charging
 

Galileoo

New member
Aug 9, 2020
4
0
"bluetooth keeps Stopping"

Oh .. That has to do with your firmware iirc .. please flash another one
i tried flash another firmware mine was EGY and the following was XSE and the Problem Still there
and i googled some solutions like backup EFS from official firmware and restore it after flash the custom rom and this did not fix it
another Solution was to reset Wi-fi, mobile & Bluetooth from settings then do factory rest and this also did not fix it

rom build: lineage-16.0-20200905-nightly-ms013g-signed.zip
Gapps : open_gapps-arm-9.0-nano-20200809
 

djchittoor

Senior Member
Mar 31, 2020
89
48
Trivandrum
i tried flash another firmware mine was EGY and the following was XSE and the Problem Still there
and i googled some solutions like backup EFS from official firmware and restore it after flash the custom rom and this did not fix it
another Solution was to reset Wi-fi, mobile & Bluetooth from settings then do factory rest and this also did not fix it

rom build: lineage-16.0-20200905-nightly-ms013g-signed.zip
Gapps : open_gapps-arm-9.0-nano-20200809


I had very similar problem where it pops up Bluetooth not responding this happened to me after flashing very latest firmware but then to fix it I just flashed another firmware with the same PDA and it was working fine I suggest you to do the same
 

AJS_177

New member
Sep 19, 2020
1
0
I checked the sha265sum, copied the ISO to my SD Card and I get an error while trying to install
"Installing zip file '/external_sd/lineage-16.0-20200919-nightly-mso13g-signed.zip'
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
Warning No file_content
E3004: This package is for device: ms01, ms013g, mso1lte; this device is .
Updater process ended with ERROR 7
Error installing zip file '/external_sd/lineage-16.0-20200919-nightly-mso13g-signed.zip'
Updating partition details...
..done"

But I know for sure my device is ms013g and I have installed a few ms013g custom roms before.
 

K--R

Member
Jun 9, 2020
32
3
THIRUVANANTHAPURAM
I checked the sha265sum, copied the ISO to my SD Card and I get an error while trying to install
"Installing zip file '/external_sd/lineage-16.0-20200919-nightly-mso13g-signed.zip'
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
Warning No file_content
E3004: This package is for device: ms01, ms013g, mso1lte; this device is .
Updater process ended with ERROR 7
Error installing zip file '/external_sd/lineage-16.0-20200919-nightly-mso13g-signed.zip'
Updating partition details...
..done"

But I know for sure my device is ms013g and I have installed a few ms013g custom roms before.
Error 7 means outdated TWRP version. Install a newer version through the custom recovery you have installed.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    2okPze5.png


    LineageOS is a free, community-built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restores the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and GApps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash GApps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download URL:
    GApps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA thread information
    LineageOS 16.0 for ms013g, ROM for the Samsung Galaxy Grand 2

    Contributors
    djchittoor
    Source Code: https://github.com/LineageOS

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.4.x
    Based On: LineageOS

    Version Information
    Status:
    Stable

    Created 2020-06-24
    4
    my phone got inti bootloop
    Hi,

    Did you clean flash the ROM? and just to let you know these builds are for SM-G7102 that is ms013g only, as of now we are not supporting any LTE variants of Grand 2
    3
    Link to download the latest LoS 16 and Lineage recovery: GDrive .
    3
    No Bug! :D
    Facing just one problem. When I Switch on the phone No Boot Animation Shows. Anyone facing same problem? :(
    But Finally It's Official LOS for Grand 2. :good:

    Hi, so I have heard of this problem and its seems that guys with unofficial screens or panels are facing this, as of now there is no fix to it and I believe it has to do with the kernel-side as we are using a common kernel configured to work with the other MSM8226-Samsung family devices and I will try to fix ASAP so you guys can have the full experience:eek::eek: