[ROM][OFFICIAL][NIGHTLIES] LineageOS 17.1 Harpia

Search This thread

NGK2

Member
Feb 8, 2021
5
0
@mmortal03, well, I've just made the test :

- I've successfully installed 14.1 with TWRP 3.4.0.0
- I was able to have data on 14.1, from each of my 2 SIM cards : GREAT !
- Then I installed 17.1 : now I only have data on a single SIM card, whatever the slots are used... :cry: Curiously the MVNO whose data is working is "Bouygues Telecom", whereas before this test it was the contrary (only "Free Mobile" MVNO was working !) I don't understand what's happening actually !
I don't know if there could be a link but for my two trials installing 17.1 (today and Feb 8th), data that was working was from the SIM card which was located in slot n°1 during the install of LOS...
 

NGK2

Member
Feb 8, 2021
5
0
@mmortal03 , I've gave it a try 2 more times with TWRP 3.4.0.0 to install LOS 14.1 and then 17.1. Each time data was working on 14.1. After the first install of 17.1, I've noticed that only 1 SIM had data. On the 2nd trial, only the other SIM was working ! I definitely cannot understand...
As I don't mind having data on 1 SIM only, I think I'm going to stop my trials...
 

casouzaj

Senior Member
Oct 13, 2006
2,236
576
57
Haibara-gum Yoshida-cho Sumiyoshi-shi
@mmortal03 , I've gave it a try 2 more times with TWRP 3.4.0.0 to install LOS 14.1 and then 17.1. Each time data was working on 14.1. After the first install of 17.1, I've noticed that only 1 SIM had data. On the 2nd trial, only the other SIM was working ! I definitely cannot understand...
As I don't mind having data on 1 SIM only, I think I'm going to stop my trials...
My wife's XT1600 variant is no longer her daily driver, but I recall she facing no mobile data, whatsoever, after flashing the ROM through TWRP. Ever since, she uses the lineage recovery which is released along with each and every ROM. You could give it a try!
 
Last edited:

Heeni

Senior Member
Dec 25, 2020
71
12
Auckland NZ
I seem to recall reading somewhere that harpia - or some variants of it, at least - has only one 4G modem, so that you could have 4G (or LTE) on either sim, and 2G on the other, but not 3/4G on both. During most of the time I was using it as my daily driver, I had two prepaid sims (Vodafone NZ and 2Degrees NZ) and was fixated on minimising my data use, so I can't really comment on what it was like on earlier LOS versions.

I do know that when I finally moved to a "serious" phone plan with Vodafone, I had some trouble getting data on it. At that stage, I think I was running RROS 7 (Android 9 equiv) but I can't be sure. Shortly afterwards, I got a G7 power and moved the Vodafone sim to that, leaving just the 2degrees sim as a backup.

Oddly enough, it shows only 4G in LOS 17.1 (and also AICP), whereas in the earlier RROS it shows LTE. I will admit to not being quite sure of the difference. :oops:
 

mmortal03

Senior Member
Apr 15, 2014
119
15
I seem to recall reading somewhere that harpia - or some variants of it, at least - has only one 4G modem, so that you could have 4G (or LTE) on either sim, and 2G on the other, but not 3/4G on both.

His is a dual XT1602 where both work on 14.1, but only one works on 17.1. @NGK2, I know you want LOS, but like I mentioned before, AICP 15.0 is also based on Android 10, so it could be helpful to see if it works properly with your dual sim phone. Sometimes the code will translate.

Oddly enough, it shows only 4G in LOS 17.1 (and also AICP), whereas in the earlier RROS it shows LTE. I will admit to not being quite sure of the difference. :oops:

I don't know the answer to that, but a reddit thread from three years ago says they show LTE when it is used, because 4G doesn't describe the technology. The guy in the thread wants it to show 4G because they don't use the term LTE in his country, even though that's the underlying technology they use. Maybe something in the last three years changed and they *do* use 4G to describe certain situations?: https://www.reddit.com/r/LineageOS/comments/7p8t5v
 

Heeni

Senior Member
Dec 25, 2020
71
12
Auckland NZ
What might be relevant to this thread: I've never used the LineageOS recovery (TWRP instead) and on the odd occasion that I do need to use 4G data, I've not had any problems.

I did have a strange issue just with Vodafone and RROS 7: When I enabled data, it would not go directly to LTE. I had to change preferred network type in Settings ->Network and Internet -> Mobile Network -> Preferred Network Type to 3G, get a connection, and then select LTE (or global) as preferred type. I have no idea why this was the case, and as the sim is no longer in this phone, I've not looked for a solution. The other sim didn't exhibit this behaviour.

I thought I'd mention this, because it just might also be the case in this rom, and might explain why data isn't working with some carriers.
 

mmortal03

Senior Member
Apr 15, 2014
119
15
@Heeni , yeah, I also recall reading some reports like that, but I don't recall the particulars. I'd have to go back through this thread and see.

I did just notice that Jeferson has been active on Gerrit again (!) regarding a couple of msm8916 issues with firmware extraction, one specifically related to the recovery and modem firmware extraction, but I don't know if these could have anything to do with the weird issue you guys have reported with LOS recovery versus TWRP.

I also noticed that in the last few months there have been a handful of items added on the 18.1 branch for msm8916, so fingers crossed on that one. Maybe some of this resolves itself there?

Finally, I noticed that a 17.1 harpia weekly build was not released on Friday for whatever reason.
 

mmortal03

Senior Member
Apr 15, 2014
119
15
Here are those two fixes I previously mentioned, which are scheduled to be in next week's harpia build. I don't know if they are relevant to the issues that various people have been having here, but they've been merged, so we'll have to see next Friday:

"msm8916-common: Extract firmware in enforcing mode"

"msm8916-common: Allow recovery to unzip and chmod modem firmware"
 

mmortal03

Senior Member
Apr 15, 2014
119
15
Thanks !
The descriptions are not very explicit. If Jeferson could give us some lights about these fixes ...

@chrmhoffmann might be able to explain the fix, as it was first written by him for "clark" devices (he is the unofficial dev on 17.1 for clark).

I skimmed through his build's XDA thread and noticed that they, too, have had various TWRP and modem firmware issues, and people having issues with dual SIM cards, none necessarily identical to ours, but the following instructions from @kb8no actually don't sound that far off from what @iouri1664 described last month here on harpia:


Start over. Flash stock Nougat with fastboot which installs the Nougat firmware. That is the main reason to flash stock. I don't mean flashing a recovery back up. Once the firmware from stock is flashed you NEVER need to flash modem again. It's there.

The modem usually does not flash on the first try and you have to fastboot flash it more than once (usually twice). Make sure modem flashed. Check every ROM fragment that it flashed. Then fastboot LOS recovery. Then flash 17.1 with LOS.

Your SIM problem is reeks of a firmware problem.


@iouri1664 said the following. Just to recap, various people here on harpia have data working on 14.1, but when they install 17.1 data no longer works. Some people have successfully gotten data to work only after going back to 14.1 and then flashing back to 17.1 in some order:

Like @hamelg and @Brandroide, I could not get data to work properly on LOS 17.1. I confirm that first installing 14.1, then booting that version, then upgrading to 17.1 did the trick.
My own path was:
  • install TWRP (LOS 17.1 recovery would not allow me to install 14.1)
  • factory reset + wipe system
  • install 14.1
  • boot 14.1 and check that data is fine
  • reboot to recovery and flash 17.1 (+opengapps) over 14.1, wiping cache and dalvik only
  • enjoy!
It is very unclear what is wrong with LOS 17.1 and why booting 14.1 before installing 17.1 fixes it.
 

althafvly

Recognized Developer / Recognized Contributor
May 28, 2014
1,582
3,061
Malappuram
IMPORTANT MESSAGE
Lineage 17.1 users who uses lineage recovery please update recovery before the ota, downloading from official site. Possible risk of loss of data.
Builds after 20th of February will be affected

TWRP users are not affected
 

mmortal03

Senior Member
Apr 15, 2014
119
15
The weekly with the aforementioned firmware fixes is available. Remember to update the recovery before you install this as an ota, as there is a possible risk of loss of data (doesn't affect TWRP users):
 

mmortal03

Senior Member
Apr 15, 2014
119
15
Does it mean LOS recovery is mandatory to flash LOS 17.1 and avoid the data connectivity issue ?

I don't think that's been proven. While some people in this thread have suggested, based on various anecdotes, that using the LOS recovery might help matters *even before* these latest changes, it's really not clear that there's anything wrong with how TWRP flashes things, or why that technically would be. And the devs we've asked for further information from haven't replied. It's probably worth trying with the latest LOS recovery just to see what happens, though.
I actually found it revealing from reading through the "clark" thread that they have run into issues where, "The modem usually does not flash on the first try and you have to fastboot flash it more than once (usually twice). Make sure modem flashed. Check every ROM fragment that it flashed."
Something like that might also apply to harpia and such inconsistency might confound people's anecdotes, where they think the flash didn't work due to one thing, but, in reality, it was due to another thing.
It'd be great if there was built-in verification that "every ROM fragment" gets flashed so we'd immediately know. I don't know enough to say how that would be done other than some sort of manual extraction and CRC comparison? It seems a bit old school that there would be no error-correction built-in to firmware flashing, of all things!
 

MR4Y

Senior Member
Apr 25, 2012
234
22
Araras - SP
With the latest update, my SIM stopped being detected and the phone now gets stuck at the lock screen. And Bluetooth no longer works either. Phone feels slower, many apps are broken or don't function correctly, taking a very long time to fully load.

I'll try a clean install, although I'm not feeling too good about it.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    A note for those not wanting to install LOS recovery: you can use it without actually installing it.

    Download the recovery image and then run
    Code:
    adb reboot bootloader
    fastboot boot <filename-of-LOS-recovery>.img

    That boots into the LOS recovery just once, and leaves TWRP or other installed recovery intact.
  • 24
    http%3A%2F%2Fi.imgur.com%2F2okPze5.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10 (Q), which is designed to increase performance and reliability over stock Android for your device.

    Code:
    #include <std_disclaimer.h>
    
    /*
     * Your warranty is now void.
     *
     * We are not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at us for messing up your device, we will laugh at you.
     *
     */

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps). LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

    Known issues:
    • ....

    Instructions:
    • Download the latest build, official TWRP (3.3.0 and newer)
    • Boot the downloaded TWRP via fastboot
    • Flash the latest build
    • Reboot

    Downloads:



    XDA:DevDB Information
    LineageOS 17.1 Harpia, ROM for the Moto G4 Play

    Contributors
    jeferson1979
    althafvly
    Device tree

    ROM OS Version: Android 10
    ROM Kernel: Linux 3.10.x
    Based On: lineage

    Version Information
    Status: Stable
    Current Stable Version: 17.1
    Stable Release Date: 2020-03-22

    Created 2020-03-22
    Last Updated 2020-03-22
    8
    Regarding all last questions:
    1- carrier config is now roll backed to same we use in pie;
    2- I've made changes at kernel level related to core control, testing if worth enable in harpia. As you know, we change our code to squid basis to make it official, and things now will be a bit slow to keep the 5 devices of moto msm8916 working, earlier I supported only harpia and osprey, now lux also;
    3- Bugs without logs I consider a feature.

    Thanks for your understanding and hold with us
    7
    OP is updated with new release:

    Merged may security patches
    Stability enhancenments

    Download at OP
    7
    The ROM works great, however SELinux is not enabled, would it be possible to enable it?

    Selinux is on mode permissive, but you can expect next update to be on enforcing mode, by now don't turn enforcing :p
    6
    Update is out for lineage-17.1 with selinux Enforcing
    Download at OP
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone