[ROM][OFFICIAL] Omnirom for Oneplus7pro [10]

Status
Not open for further replies.

darkobas

Senior Member
Jan 11, 2011
4,765
9,222
0
plus.google.com
CLOSED PER OP REQUEST


Download:
DOWNLOAD Official

Kernel source:
Source



Selinux Status:
Enforcing

Safetynet Status:
PASS

MAJOR BUGS:
huh ?

Minor bugs:


flash on your own risk.

FLASHING
First Time:
First Time:
update fastboot and adb ( https://developer.android.com/studio...platform-tools )
download twrp
fastboot boot twrp-blabla.img
flash stock OOS (we use stock vendor, if you have that skip this step)-(but make sure your both slots are fine (look flashing oos update below))
flash omni
reboot to bootloader
fastboot boot twrp-blabla.img again
flash open gapps nano (ONLY GAPPS NANO ARE CURRENTLY SUPPORTED
reboot

Updating: (WILL WORK ONCE OFFICIAL)
Use OTA inside rom for updates

updating when stock OOS update is released:
boot twrp
flash oos
flash omni
reboot bootloader
boot twrp
flash oos
flash omni
reboot bootloader
boot twrp
flash gapps

if u did something else. we dont need/wanna know about it in the thread

May the force be with you

Device Maintainers
@vache,
@maxwen

XDA:DevDB Information
OmniRom, ROM for the OnePlus 7 Pro

Contributors
darkobas, vache, maxwen
Source Code: https://github.com/omnirom/

ROM OS Version: Android 10
ROM Kernel: Linux 4.x
ROM Firmware Required: OOS 10

Version Information
Status: Stable

Created 2019-10-02
Last Updated 2019-11-19
 
Last edited by a moderator:

paatha13

Senior Member
Jul 27, 2016
2,044
798
163
Athens
[ROM][BETA] Omnirom for Oneplus7pro [10]

Just installed the new version.

IMG_0001.jpg

What version of open gapps working fine on this build?

Sent from my iPad using Tapatalk Pro
 
Last edited:

B3n_Huxtable

Member
Nov 21, 2013
36
5
38
30
Barnstaple
Well i won't be using this rom. spent the last few hours trying to get this to work. nothing is working at all. Got it to boot then try to transfer my files back over. The phone then crashes and goes to a black screen with "qualcomm crashdump mode" Been installing roms on this phone since release with no issue. Finally given up with this one. Currently stuck in fastboot due to this.
 

darkobas

Senior Member
Jan 11, 2011
4,765
9,222
0
plus.google.com
Well i won't be using this rom. spent the last few hours trying to get this to work. nothing is working at all. Got it to boot then try to transfer my files back over. The phone then crashes and goes to a black screen with "qualcomm crashdump mode" Been installing roms on this phone since release with no issue. Finally given up with this one. Currently stuck in fastboot due to this.
Good luck
 

marko94

Senior Member
Jul 28, 2012
2,664
1,171
198
31
Zagreb
Well i won't be using this rom. spent the last few hours trying to get this to work. nothing is working at all. Got it to boot then try to transfer my files back over. The phone then crashes and goes to a black screen with "qualcomm crashdump mode" Been installing roms on this phone since release with no issue. Finally given up with this one. Currently stuck in fastboot due to this.
Probably you missed something, skipped one step etc.
 

gogoffm

Senior Member
May 2, 2017
497
126
0
Well i won't be using this rom. spent the last few hours trying to get this to work. nothing is working at all. Got it to boot then try to transfer my files back over. The phone then crashes and goes to a black screen with "qualcomm crashdump mode" Been installing roms on this phone since release with no issue. Finally given up with this one. Currently stuck in fastboot due to this.
I flashed the built which shows up on the weekend , had the same prob but when you use adb push you can transfer files to.your phone w/o probs. The rest was working for me fine only bigger prob was if you flash the oos10 cam then the phone reboots into crashdump. Removing the cam solved that. It's Beta, it's still in progress don't forgett that.
 

darkobas

Senior Member
Jan 11, 2011
4,765
9,222
0
plus.google.com
I flashed the built which shows up on the weekend , had the same prob but when you use adb push you can transfer files to.your phone w/o probs. The rest was working for me fine only bigger prob was if you flash the oos10 cam then the phone reboots into crashdump. Removing the cam solved that. It's Beta, it's still in progress don't forgett that.
No, oos camera also works fine
 

B3n_Huxtable

Member
Nov 21, 2013
36
5
38
30
Barnstaple
I have no idea what it is. Had to boot a fastboot rom just to get back up and running after that last crashdump. going to go back to OOS for a little I think. I have never had a rom do this but this one has done it every time I have tried. Thing is I love Omni so I hope one day i can get it running properly.

---------- Post added at 01:40 PM ---------- Previous post was at 01:38 PM ----------

I flashed the built which shows up on the weekend , had the same prob but when you use adb push you can transfer files to.your phone w/o probs. The rest was working for me fine only bigger prob was if you flash the oos10 cam then the phone reboots into crashdump. Removing the cam solved that. It's Beta, it's still in progress don't forgett that.
Don't worry i didn't forget lol. That's why i'm going to keep trying after every release. It will work for me one day.
 

paatha13

Senior Member
Jul 27, 2016
2,044
798
163
Athens
[ROM][BETA] Omnirom for Oneplus7pro [10]

Everything fine with installations no had any issue with first attempt.
Installing nano gapps not had any issue too this time at opposite with weekend build.

Seems this build more stable and I'm now charging the phone,download my usual staff from play store,will setup my device and will start to work on it later when phone full charge.

Thanks @darkobas.

No, oos camera also works fine
Yes I can confirm OOS camera working fine.


Sent from my iPad using Tapatalk Pro
 
Last edited:

f100cleveland

Senior Member
Aug 23, 2010
693
233
63
Minnesota
Does anyone know of an app or mod that allows the navigation buttons to be inverted? The custom navbar app doesn't work on 10 yet and that isn't integrated into the rom yet. I'll live but it is tough to try to retrain the brain, ha!
 

paatha13

Senior Member
Jul 27, 2016
2,044
798
163
Athens
First impressions using couple of hours is solid.
Battery life look promising and satisfactory.
Very smooth experience so far.
Speaker loudness and quality is on par with oxygen just like with Pie version.

Brightness level seems on par with high oxygen levels although I haven't test it in sunlight, will do tomorrow [emoji14]

Stock(android 10) gesture navigation works great but prefer oxygen one and since using nova launcher I'm with vivid gesture navigation app since when using third-party launcher automatically stock gesture navigation are disabled.

There's dark mode but I'm not fan of it since it's dark gray and not black that prefer (will use substratum to apply truly black theme almost everywhere)

Vast majority Omni features working fine so far.

Wi-Fi, mobile data, so far all excellent, BT will test tomorrow intensively.

Almost all oxygen features are present and worked fine, except vibration need some tuning but that also appy to stable OOS 10 version.

On Pie vibration was better both Omni and OOS.

High brightness level is still present

I found some bugs though like dt2w not such reliable almost half of the attempts needed 2 and rare 3 times to wake up screen or even press the power button at end because not responding at all.

Aldo digital wellbeing to me every time try to open I'm getting fc.

Safety net not passing through magisk also.

I assume will improve in future build don't forget it's still beta.

More observations and safe conclusions will have after couple of days of using the new rom.

But so far general impressions after few hours is at good and satisfactory level and the build is safe to be daily driver for sure.




Sent from my GM1913 using Tapatalk
 
Last edited:

NickMidd91

Senior Member
Oct 30, 2015
1,549
263
103
Just wondering why I can't download the Samsung wearable app in the Google Play Store on this. When I get it from the APK it tells me that this software which is on my phone is not compatible with the watch is there a way to fix this so I can connect my Galaxy watch to this amazing ROM this happens to me on every single ROM except CR Droid 9.0 don't know why:crying:
 
Last edited:
Status
Not open for further replies.