[ROM][OFFICIAL][OnePlus 6/6T][11.0_r32]PiXeN-OS[2021/03/03]

drpradsms

Senior Member
Aug 12, 2012
960
3,688
138
35
forum.xda-developers.com
i flash to booth slots too, doesn't work
New build doesn't boot.
I made fresh install like all previous builds and when i try boot to system i got reboot and phone boots to recovery.
All previous build's doesn't have this problem.
P.S. Dirty flash over previous build boots without problems.
Till the last update the back camera in 3rd party apps used to work really well, filming on tiktok with it had no lags and was filming just like on the stock camera, now it lags again...
Reinstalled OTA-049 of OOS 6T and followed the clean install procedure 4 times now and every time it boots up in recovery.
Checkout the new update 20210124.. It has your issues fixed..
 

abogrhen

Senior Member
Jul 10, 2012
390
147
73
Checkout the new update 20210124.. It has your issues fixed..
Thanks 01/24 works great

I have an app called mada pay ( it it like Google Pay but locally )


that for some reasons don't work with pixen
it crashes to the home screen

can you test it
and see if there is any solution
 

Mathorlaz

Senior Member
Jul 19, 2012
123
47
48
I’ll call it strange because network permission is enabled by default for all apps.
Hello @drpradsms . First of all thanks for the awesome ROM, I've been using it as a daily driver since the early days of version 11.

Regarding the network permissions, I know it seems strange, but out of the ~300 apps I had installed, around 100 had the network permission disabled. The big problem with this is that because this permissions is set on the AndroidManifest and not prompted to the user, if an app has this permission denied, it crashes immediately, as if the developer had forgotten to request the "NETWORK_ACCESS" permission on the app manifest.

I may be wrong, but normally there isn't any "Network Access" permission on the permission screen of Android, so this might have been introduced by someone "upstream" adding this feature, having this unintended consequence?

I have an app called mada pay ( it it like Google Pay but locally )


that for some reasons don't work with pixen
it crashes to the home screen
Try checking the app permissions, and see it "Network" is missing denied. This was the problem for all apps that were immediately crashing on my end.
 

kmr168401

Senior Member
Jul 2, 2016
181
28
28
Hi @drpradsms thanks for all the updates, in 1757 build front camera worked without crashing but in your latest build 830 it crashing, only one thing which is not working apart from it everything working fine in my mobile, I have installed all my programs which I use day to day use, everything running good no crash no nothing, everything fine. Thanks for all the updates you keep my sunday busy. 😍👍
 

abogrhen

Senior Member
Jul 10, 2012
390
147
73
Hi @drpradsms thanks for all the updates, in 1757 build front camera worked without crashing but in your latest build 830 it crashing, only one thing which is not working apart from it everything working fine in my mobile, I have installed all my programs which I use day to day use, everything running good no crash no nothing, everything fine. Thanks for all the updates you keep my sunday busy. 😍👍
Download the newer version 20210124-0850
it solved the camera problem
 

abogrhen

Senior Member
Jul 10, 2012
390
147
73
Hello @drpradsms . First of all thanks for the awesome ROM, I've been using it as a daily driver since the early days of version 11.

Regarding the network permissions, I know it seems strange, but out of the ~300 apps I had installed, around 100 had the network permission disabled. The big problem with this is that because this permissions is set on the AndroidManifest and not prompted to the user, if an app has this permission denied, it crashes immediately, as if the developer had forgotten to request the "NETWORK_ACCESS" permission on the app manifest.

I may be wrong, but normally there isn't any "Network Access" permission on the permission screen of Android, so this might have been introduced by someone "upstream" adding this feature, having this unintended consequence?



Try checking the app permissions, and see it "Network" is missing denied. This was the problem for all apps that were immediately crashing on my end.
no it was not from this version
i had the problem from few versions ago

can you install the app and tell me if it works
maybe it on my end omly
 

devil_tear

Member
Aug 17, 2012
28
9
23
@drpradsms thank you for the hard work and the amazing job, I really love this ROM and it is just what I was looking for! Stable, fast and battery efficient!

Just one thing that I noticed is that haptic feedback randomly stops working after a couple of restarts. This happened after 2 clean installs.