[ROM][OFFICIAL][PAYTON][NIGHTLIES]Lineage OS 17.1

Search This thread

leuko

New member
Jan 17, 2020
1
0
I can confirm similar behavior to the last post. When I try to establish a VoIP connection, then payton freezes and then reboots automatically. December build did not have this issue.
VoIP SW: MobileVOIP
 

DanielZRK

Senior Member
Jan 4, 2013
256
73
26
La Victoria
twitter.com
I've been using Lineage 16 from about 3 months without barely any issue, low volume I fixed installing Viper4Androud but only exception is that I can't shot at 16 megapixels on front facing camera using Moto Camera, no matter if I downloaded it from Google Play or flashing ports via TWRP, only shots 2.1 megapixels when I choose 16 on Moto Camera options.

Edit 1: This bug is present in Havoc 2.9, Mokee OS and all those 10 ROMs either.
 
Last edited:

craigviar

Senior Member
Aug 9, 2012
170
21
Help. Confused.

Lineage OS 16 is android 8 oreo or 9 pie?
the copy partitions zip is for 8 oreo
Google search shows Los 16 is 9 pie
My x4 is on stock 9 pie
Everything in the op says oreo.

When I installed the copy partitions zip there was a bunch of stuff about couldn't read, to many symlinks. But that is for 8,I'm on 9. Did I screw up?

WTF OVER?

EDIT : It's 9,pie. Got everything working fine.

On another note, does anyone know how to make the SD card writeable? I hoped it would be with LOS. It's basically useless to me as is. Phone can't write to it, computer gets really confused as soon as I plug it in (the card, not the phone).
 
Last edited:
  • Like
Reactions: Francesco Libera

craigviar

Senior Member
Aug 9, 2012
170
21
Is your SD Card formatted as FAT32?
Yes. The phone could read it but not write to it. Other phones could read it using otg. My win10 machine would get all screwy when trying to view it. Couldn't format it either. Tried to format it using otg on another phone, failed. It's in the trash now. It is a card I've had for awhile and was working fine when I first put it in the x4. Oh well.
 
  • Like
Reactions: flieswithhawks

jerryspring

Senior Member
Feb 18, 2018
1,934
168
I guess the Christmas gift arrived 3 days late. Today's build installed (via Updater) without issues.
Does your built-in updater take a long time to flash as mine does? It takes over a half an hour

---------- Post added at 05:41 AM ---------- Previous post was at 05:39 AM ----------

Help. Confused.

Lineage OS 16 is android 8 oreo or 9 pie?
the copy partitions zip is for 8 oreo
Google search shows Los 16 is 9 pie
My x4 is on stock 9 pie
Everything in the op says oreo.

When I installed the copy partitions zip there was a bunch of stuff about couldn't read, to many symlinks. But that is for 8,I'm on 9. Did I screw up?

WTF OVER?

EDIT : It's 9,pie. Got everything working fine.

On another note, does anyone know how to make the SD card writeable? I hoped it would be with LOS. It's basically useless to me as is. Phone can't write to it, computer gets really confused as soon as I plug it in (the card, not the phone).
I got a similar issue. The unofficial TWRP doesn't seem to recognize the SD card when I write a back up to it. Keep saying fail
 

Randy Power

Senior Member
Dec 16, 2007
60
21
Does your built-in updater take a long time to flash as mine does? It takes over a half an hour

Yes it takes an extremely long time, maybe even longer than 30 minutes. It seems to help keeping the screen on (plugged in and updater in the foreground). The Updater has a preference to prioritize the update process too. I cannot speak on the effectiveness of that option or why it takes so long.
 
  • Like
Reactions: jerryspring

jerryspring

Senior Member
Feb 18, 2018
1,934
168
Yes it takes an extremely long time, maybe even longer than 30 minutes. It seems to help keeping the screen on (plugged in and updater in the foreground). The Updater has a preference to prioritize the update process too. I cannot speak on the effectiveness of that option or why it takes so long.
Did you by chance ever try and make a backup with TWRP? Would it be in reference to one of the slots?
 

jerryspring

Senior Member
Feb 18, 2018
1,934
168
I have done a TWRP backup. I assume when you choose to include the system partition that it would be in reference to the current slot. But I am no expert on A/B behavior.

maybe if i try to back up all but that partition it will work.. maybe???
i also had a weird occurrance.. i turned phone off and charged it.. went to turn on and it kept showing the charging icon. i had to access bootloader and restart that way.. ever have that issue?
 

jerryspring

Senior Member
Feb 18, 2018
1,934
168
after flashing rom zip, i get no os installed when i go to reboot..i chose reboot anyways, but rom still loads..why did it do that? it didnt do that before when i flashed the rom . is this normal?
 

Randy Power

Senior Member
Dec 16, 2007
60
21
Sorry @jerryspring, I haven't had those experiences. Getting it working for me required a lot of trial and error. I shared things in this thread that helped me. One significant thing seemed to be formatting the data partition with f2fs.

Also there are reports that some people had to install two times. Maybe there's something that doesn't install right on B but does on A. Install and booting (even if it doesn't work) then sets you up to be able to install to A. I'm speculating here.
 
  • Like
Reactions: jerryspring

Top Liked Posts

  • There are no posts matching your filters.
  • 49
    2okPze5.png

    Code:
    /*
     * Your warranty is now void.
     *
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.
     */

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Introduction:

    This is the official Lineage OS thread for the Motorola Moto X4, codename payton.

    We support all the T-Mobile, International, and Project Fi variants, as their bootloaders are unlockable, while we can't support the Verizon and AT&T variants, as their bootloaders are permanently locked.

    How to install:
    • Boot the newest TWRP .img from the Official TWRP Project Site.
    • IF YOU ARE COMING FROM STOCK AND WANT TO INSTALL CUSTOM ROMS FOR FIRST TIME, INSTALL "Copy Partitions Zip" FROM POST #2
    • In TWRP, click "Wipe", "Format Data", then type "yes" as prompted.
    • ADB sideload the newest weekly
    • (Optionally) You can flash the newest TWRP Installer also found at the Official TWRP Project Site if you wish to maintain TWRP, though the pre-installed Lineage Recovery instance will do everything you need it to in most cases. We don't recommend or support the use of the TWRP installer, as it is overwritten on every update (will need to be re-installed every update), and has no addon.d-v2 persistence.
    • Click "Reboot, then choose "Recovery", this will boot you to either Lineage Recovery or TWRP depending on your choice to install TWRP or not. It is necessary to reboot between ROM flash and GApps/Addon flash due to verity/slot-swap logic.
    • (Optionally) Flash GApps - MindTheGApps arm64 are recommended, OpenGApps are compatible with A/B as of 09102018, but I still only reccoemend and support MindTheGApps.
    • (Optionally) Flash SU - you'll need to turn it on from in developer settings after first boot Lineage OS SU Addon. - Magisk works fine, though is not supported.
    • Reboot

    Notes:
    • Official Lineage OS builds will not pass CTS/SafetyNet -- due to the AVB flag's "red" status. (Magisk works fine, though is not supported.)
    • Official Lineage OS builds ship with full treble compatibility, with VNDK runtime enforcement! This means that unlike most "ported treble" you'll see, ours is just as it would be from the OEM, and can run any GSI (yes, even Pie!) without need for hacks or additional flashable zips. We relabeled /oem as /vendor (as /oem isn't used in custom ROM's anyway). To use a GSI, flash official Lineage, then flash your GSI, it's that simple! Flashing a factory image will likely write over /oem and remove the mock vendor image. Please don't report GSI bugs here, report them instead to the GSI's maker.

    Download:


    XDA:DevDB Information
    Lineage OS 17.1, ROM for the Moto X4

    Contributors
    erfanoabdi, Lineage Team
    Source Code: https://github.com/LineageOS

    ROM OS Version: 10.x Oreo
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Official Pie

    Version Information
    Status: Stable

    Created 2018-09-01
    Last Updated 2019-03-02
    17
    new updated versions is out
    * minor bug fixes
    * volte bug fixes in dual sim device
    * updated blobs to official 8.1
    https://www.androidfilehost.com/?fid=5862345805528062600
    -----------------------------------------------------------------------------------------
    Full Treble Version :
    * fully treblized
    * wifi/video calling fixes
    * minor volte bug fixes
    * battery and performance optimization

    Treble Lineage : https://www.androidfilehost.com/?fid=5862345805528063250
    Treble TWRP : https://www.androidfilehost.com/?fid=5862345805528063210
    Treble TWRP Installer : https://www.androidfilehost.com/?fid=5862345805528063564

    **this is treble build and should be flashed ONLY with treble twrp**

    FAQ:
    Magisk?
    - try magisk 16.7 if you want
    GSIs?
    - yes all GSIs is installable
    P?
    - yep follow AB flashing guide

    ENJOY
    17
    new build is up :
    https://www.androidfilehost.com/?fid=11050483647474829452

    * Fingerprint navigation gestures fixed (settings -> system -> buttons -> on screen navbar)
    * SElinux is enforced
    * stronger haptics
    * dual camera fixes
    * CPU and Battery optimizations
    * kernel update to latest moto source
    * with full lineage A/B support : xda-developers.com/lineageos-15-1-supports-a-b-devices-moto-z2-force
    16
    Guys Official build is up on Lineage updater : https://download.lineageos.org/payton
    please recheck OP for installation guide it's also updated (for guys coming from stock don't forget copy partition zip, and for first installing gapps and stuffs don't forget re-reboot to recovery)
    official TWRP is also updated (make sure you are in latest version of it) : https://twrp.me/motorola/motorolamotox4.html
    also in official twrp we dropped MTP support (Like Pixel devices) it was affecting on many horrible things but "adb push/pull" works so read Installation guide from link above

    we will get updates official lineage updated WEEKLY, with OTA support

    i was reading posts @MotoX4, you need to use official twrp and for gapps you forgot to reboot to recovery, for safety net you need to install magisk as all mentioned in OP ;)
    + lineage recovery is only for "adb sideload" not for installing zips from internal storage
    ____________________________
    about lineage 16, we will get official los as soon as lineage gets ready, for now there is some platform side bugs like clock... but all device specific bugs fixed

    thanks for using lineage :fingers-crossed: