• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][OFFICIAL][pioneer][10] LineageOS 17.1

Search This thread


Senior Member
May 8, 2014
Sony Xperia 10 II
Hi Luk, I see that Kirin first build of LOS 17.1 is available now and for Pioneer is building, do we have to upgrade from 9 to 10 as was on oreo-pie ?

Enviado desde mi H3123 mediante Tapatalk
Last edited:


Senior Member
Nov 4, 2011
well, this time didn't booted on LOS 17, after flashed ROM zip, turned off, then booted on TWRP, flashed gapps, and then keeps on LOS logo almost 2 hours, any suggestion? as i want to keep my data from LOS 16

Some people on reddit are having problems with newer open gapps builds.
Try older ones


Senior Member
Jun 19, 2012
I insta downloaded (and flashed) the first 17.1 nightly yesterday, was it removed because it's bugged?


New member
Apr 3, 2020
I installed 50.2 FW and April 2 LOS build, everything is fine except for video playback which is very laggy and audio doesn't work. It happens on recorded video and Newpipe.

Top Liked Posts

  • There are no posts matching your filters.
  • 21

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
     restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][10] LineageOS 17.1, ROM for the Sony Xperia XA2

    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2019-10-08
    Last Updated 2020-04-01
    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261716572 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Reboot to recovery mode (both Lineage recovery and TWRP will work)
    6. Flash https://androidfilehost.com/?fid=4349826312261712574
    7. Profit?
    PSA: Official downloads are back again.
    Anyone have any clue on when the builds will resume? Is the hacking incident sorted?
    From Twitter (for the sake of completeness):

    LineageOS @LineageAndroid · 3. Mai

    Around 8PM PST on May 2nd, 2020 an attacker used a CVE in our saltstack master to gain access to our infrastructure.

    We are able to verify that:
    - Signing keys are unaffected.
    - Builds are unaffected.
    - Source code is unaffected.

    See http://status.lineageos.org for more info.

    From Reddit (haggertk = a LOS director):

    haggertk · 7 days ago

    Well, it looked like the compromise was fairly contained (more details will be forthcoming in a blog post), but burning it all to the ground and rebuilding, using backups where appropriate, is better than hoping you fully cleaned it all.


    No, we're in the process of rebuilding pretty much everything except signing - web, mail, gerrit, buildbots, mirrorbits, etc.

    If it's public and up right now it's because it was rebuilt.

    haggertk · 3 days ago

    Something completely independent from the salt exploitation happened somewhere around/just after April 23. The build trees on some of our build servers got "stuck" and weren't picking up submitted changes. Because the build date would be a lie, and it wasn't worth the effort to map which specific builds came off the "stuck" servers, we removed all builds for all devices after the apparent fault timeframe.


    They aren't unsafe, just potentially with a codebase that is a few days older than what's represented in the build info.

    If the concern is in any way related to the infra exploit, I will repeat what we publicly stated a week ago - no completed builds, source code, keys, or signing servers were compromised in any way.


    Did we run into problems? Sure, if you call people's actual paying jobs and personal lives a problem.

    Still in work, hoping for by the end of weekend, which is rather good for a "rebuild the entire world" kind of situation. If we miss the date, we miss the date.

    It's important to note that development was only halted for less than two days. And let's be honest, the vast majority of devices haven't had anything truly important submitted in a way that really needs a new build.
    I just released new builds /w Nov SPL but there's a c-catch.
    If you're updating from 20191025-20191102 to newer build you'll need to do: `rm -rf /data/data/com.android.providers.downloads /data/data/com.android.providers.media /data/misc/wifi /data/misc_ce/0/wifi` in root shell (adb root && adb shell or adb shell × su if using Magisk or something)