[ROM][OFFICIAL][pioneer][10] LineageOS 17.1

Search This thread

wtflawlxd

Member
Sep 4, 2014
28
8
I have a problem with video recording: the volume of the recorded audio is very low. I don't have this problem with phone calls or audio recordings, their volume is fine.
Latest Lineage, tested with Lineage camera.
Does it happen to you?
It used to work fine until some updates ago, I don't know when exactly because I rarely record videos.

With the 1st Oct. update it's working fine again!
:good::D
 

counterphone

Member
Dec 17, 2013
5
0
No wakeup on authentication messages...

Hi Guys,
Did anyone experienced problems with messages containing codes for authenticating accessing bank/google account/payments etc. NOT waking up locked phone? I start logging in, page I use tells me that message was sent to my no. and I don't see any notification unless I unlock phone...

Didn't change anything with messaging app (stock) notifications permission.
 

d210

Senior Member
Nov 29, 2010
56
7
This is usually a sign that the messaging app is "too deep" sleeping, you might look into the battery optimization list and disable whatever power optimization you might have for this app.
 

samhhmobil

Senior Member
May 25, 2017
342
179
Hamburg
Yeah I know this method. It replaces recovery ramdisk, but it's replaced again every time I update system.
Yeah, so I prefer(!) to have the LOS recovery installed in the phone, and if I need really TWRP, I connect the phone to the PC, booting in fastboot-mode, and boot TWRP via "fastboot boot twrp.img". That worked all the time I did need it.

samhhmobil
 

counterphone

Member
Dec 17, 2013
5
0
This is usually a sign that the messaging app is "too deep" sleeping, you might look into the battery optimization list and disable whatever power optimization you might have for this app.

You may be right, although messaging app is not optimised for battery usage. Similar thing, in a form of delayed delivery, I observe in whatsapp.
Btw, checking battery usage first place is always taken by the app(?) named "-5" and android bot icon...
 
Jun 11, 2017
8
1
Thank you very much for the development of this ROM, I have been testing it for a few days for the first time and I can say that it works amazingly. The only drawback that I've found is when recording videos: with the AOSP camera the videos are recorded and played with lag, and also with audio problems (low volume and poor quality) With other cameras (Google Camera, for example) there is no lag but the audio problems persist.

I tried flashing the package pioneer_modem_bt_dsp_50.2.A.3.22.zip but without success (both problems persist). Is there anything I am doing wrong? I've had these problems with the last two builds. I have a H4113 and my baseband is 20191108_BY12O_Daily, in case it helps.

Thanks!
 
Last edited:

zupert

Member
Aug 7, 2018
8
0
Hello,
i can't get the Wifi hotspot to work :(
It starts, and other devices can connect to it, but they report having no internet connectivity.
Am i missing some config step, or is it a known bug?
 

zupert

Member
Aug 7, 2018
8
0
Huh, 17.1 shouldn't have any issues with hotspot... Older 18.0 builds did tho.

ok... I tried with several devices, so i'm pretty confident that the issue is on the XA2 side.

I tried changing the AP's name, its password. But the issue persists.
Is there something else i could try?
 

malerocks

Senior Member
Mar 6, 2018
429
102
ok... I tried with several devices, so i'm pretty confident that the issue is on the XA2 side.

I tried changing the AP's name, its password. But the issue persists.
Is there something else i could try?
Check with your network provider. Some of them don't allow WiFi tethering.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I found a "workaround" for staying with LOS17.1 on XA2 (for those people who cannot upgrade to 18.1 for different reasons).

    It's "iodéOS" for XA2 (to find in this forum), based on LOS17.1, but focused on much better privacy. And it's yet on security patch level of 2021/05. Not frequently updated, but when it's necessary, and OTA-updates are working.

    Nice. What else do I want?

    samhhmobil
    Another alternative also based on LOS17.1:

    /e/OS
    https://e.foundation/e-os/

    XA2 ROM install instructions and download links:
    https://doc.e.foundation/devices/pioneer/install/
  • 21
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build and gapps
    • Boot to recovery
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][OFFICIAL][pioneer][10] LineageOS 17.1, ROM for the Sony Xperia XA2

    Contributors
    LuK1337
    Source Code: https://github.com/LineageOS

    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2019-10-08
    Last Updated 2020-04-01
    11
    [ protip: 20191010+ builds require 50.2 FW (at least bluetooth, dsp, modem from it) If you're still running 50.1 you can flash this package in TWRP: https://androidfilehost.com/?fid=4349826312261716572 unless you're fine with having partially broken audio and broken Egistec fingerprint sensor ;3 ]

    However if you want to flash whole firmware package onto both slots, you can follow the guide below:

    1. Download latest firmware with XperiFirm.
    NOTE: When using mono XperiFirm will fail to unpack the firmware, you can do it manually using following commands:
    Code:
    for f in FILE_*; do unzip $f; done
    unzip boot.zip -d boot
    2. Go to the directory where the firmware got downloaded to and remove following files:
    - boot_X-FLASH-ALL-18AE_0x00.hash
    - boot_X-FLASH-ALL-18AE.sin
    - persist_X-FLASH-ALL-18AE_0x00.hash
    - persist_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-18AE_0x00.hash
    - system_other_X-FLASH-ALL-18AE.sin
    - system_other_X-FLASH-ALL-9B8D_0x00.hash
    - system_X-FLASH-ALL-18AE_0x00.hash
    - system_X-FLASH-ALL-18AE.sin
    - system_X-FLASH-ALL-9B8D_0x00.hash
    - userdata_X-FLASH-CUST-18AE.sin
    - vendor_X-FLASH-ALL-18AE_0x00.hash
    - vendor_X-FLASH-ALL-18AE.sin
    - vendor_X-FLASH-ALL-9B8D_0x00.hash
    3. Turn off your phone, hold vol dn and plug in the USB cable, the screen should be off and green LED lit.
    4. Run Newflasher, it'll flash entire FW to your current slot then unplug the USB cable and power on your phone.
    5. Reboot to recovery mode (both Lineage recovery and TWRP will work)
    6. Flash https://androidfilehost.com/?fid=4349826312261712574
    7. Profit?
    7
    PSA: Official downloads are back again.
    6
    Anyone have any clue on when the builds will resume? Is the hacking incident sorted?
    From Twitter (for the sake of completeness):

    LineageOS @LineageAndroid · 3. Mai

    Around 8PM PST on May 2nd, 2020 an attacker used a CVE in our saltstack master to gain access to our infrastructure.

    We are able to verify that:
    - Signing keys are unaffected.
    - Builds are unaffected.
    - Source code is unaffected.

    See http://status.lineageos.org for more info.
    https://twitter.com/LineageAndroid/status/1256821056100163584

    From Reddit (haggertk = a LOS director):

    haggertk · 7 days ago

    Well, it looked like the compromise was fairly contained (more details will be forthcoming in a blog post), but burning it all to the ground and rebuilding, using backups where appropriate, is better than hoping you fully cleaned it all.

    (...)

    No, we're in the process of rebuilding pretty much everything except signing - web, mail, gerrit, buildbots, mirrorbits, etc.

    If it's public and up right now it's because it was rebuilt.

    haggertk · 3 days ago

    Something completely independent from the salt exploitation happened somewhere around/just after April 23. The build trees on some of our build servers got "stuck" and weren't picking up submitted changes. Because the build date would be a lie, and it wasn't worth the effort to map which specific builds came off the "stuck" servers, we removed all builds for all devices after the apparent fault timeframe.

    (...)

    They aren't unsafe, just potentially with a codebase that is a few days older than what's represented in the build info.

    If the concern is in any way related to the infra exploit, I will repeat what we publicly stated a week ago - no completed builds, source code, keys, or signing servers were compromised in any way.

    (...)

    Did we run into problems? Sure, if you call people's actual paying jobs and personal lives a problem.

    Still in work, hoping for by the end of weekend, which is rather good for a "rebuild the entire world" kind of situation. If we miss the date, we miss the date.

    It's important to note that development was only halted for less than two days. And let's be honest, the vast majority of devices haven't had anything truly important submitted in a way that really needs a new build.
    https://www.reddit.com/user/haggertk/comments/
    5
    [announcement]
    I just released new builds /w Nov SPL but there's a c-catch.
    If you're updating from 20191025-20191102 to newer build you'll need to do: `rm -rf /data/data/com.android.providers.downloads /data/data/com.android.providers.media /data/misc/wifi /data/misc_ce/0/wifi` in root shell (adb root && adb shell or adb shell × su if using Magisk or something)